Sound and wlan [solved]

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
Jins
White ninja
White ninja
Posts: 6
Joined: 28 Aug 2011, 20:00
Location: Himitsu

Sound and wlan [solved]

Post#1 by Jins » 28 Aug 2011, 20:22

I'm happy that actualy on my HP Compaq 6715b all is working out of box :) on current porteus. I would like to know how to get work wireles module and sound module without trouble on slackware 13.37 :wall: Becouse wlan module witch one worked erlier not working enimore and sound on youtube cliping and video on mplayer losing words. :wall: :%) Any ideas suggestions? :Search:
Last edited by Jins on 02 Sep 2011, 09:26, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound and wlan

Post#2 by fanthom » 28 Aug 2011, 20:31

@Jins
welcome on board :)

i hope that i have understood you correctly: you have no problems with wlan and sound in Porteus but they are not working correctly in Slackware-13.37 - is it?

This forum is about Porteus but i think we will be happy to give a hand also to Slackware users as it's our parent distro along with Slax :)
please boot Porteus and provide output of 'lspci -k' command and post it here.

Cheers
Please add [Solved] to your thread title if the solution was found.

Jins
White ninja
White ninja
Posts: 6
Joined: 28 Aug 2011, 20:00
Location: Himitsu

Re: Sound and wlan

Post#3 by Jins » 29 Aug 2011, 16:06

Thanks for fast replay :)
So here it is lspci -k

Code: Select all

root@porteus:~# cat /home/guest/lspci
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel modules: ati-agp
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
        Kernel modules: shpchp
00:04.0 PCI bridge: ATI Technologies Inc Device 7914
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
        Subsystem: ATI Technologies Inc SB600 Non-Raid-5 SATA
        Kernel driver in use: ahci
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: ohci_hcd
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: ohci_hcd
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: ohci_hcd
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: ohci_hcd
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: ohci_hcd
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: ehci_hcd
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: piix4_smbus
        Kernel modules: i2c-piix4
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: pata_atiixp
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
        Subsystem: Hewlett-Packard Company Device 30c2
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Hyper Transport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
        Kernel driver in use: k8temp
        Kernel modules: k8temp
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: radeon
        Kernel modules: radeon
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: yenta_cardbus
02:04.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 02)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: firewire_ohci
        Kernel modules: firewire-ohci
10:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
        Subsystem: Hewlett-Packard Company Device 30c2
        Kernel driver in use: tg3
        Kernel modules: tg3
30:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02)
        Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller
        Kernel driver in use: b43-pci-bridge
        Kernel modules: wl, ssb
Also I upgrade kernel to 2.6.39.4 well wlan started to work but with sound no changes.... :unknown:

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound and wlan

Post#4 by fanthom » 29 Aug 2011, 16:59

@Jins
I upgrade kernel to 2.6.39.4 well wlan started to work but with sound no changes....
one sorted so :)

is the problem related to playing video's only or audio in general? do you have a normal sound in music players like audacious, qmmp, other?

please post output of 'cat /proc/asound/cards' and 'glxinfo | grep OpenGL' (these commands are case sensitive) when running Slackware.

Cheers
Please add [Solved] to your thread title if the solution was found.

Jins
White ninja
White ninja
Posts: 6
Joined: 28 Aug 2011, 20:00
Location: Himitsu

Re: Sound and wlan

Post#5 by Jins » 30 Aug 2011, 07:34

Hello fanthom.
here is from cat /proc/asound/cards
  • 0 [SB ]: HDA-Intel - HDA ATI SB
    HDA ATI SB at 0x84000000 irq 16
and here from glxinfo | grep OpenGL
  • OpenGL vendor string: X.Org R300 Project
    OpenGL renderer string: Gallium 0.4 on ATI RS690
    OpenGL version string: 2.1 Mesa 7.10.2
    OpenGL shading language version string: 1.20
    OpenGL extensions:
Well about sound xmms2 mpg321 clipping, mplayer and mplayer2 cutting out parts of audio in songs files mp3, ogg, flac and ape. Watching flv on web clipping werry hard and loud but watching in mplayer less. Even when I put proc on full 1.8GHZ. On any video in mplayer(2) cutting words.
Best regards.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound and wlan

Post#6 by fanthom » 30 Aug 2011, 08:47

hmmm... your graphics driver is fine so it must be something with audio.
are you running 32bit edition or 64 one?

you can use Porteus kernel in Slackware and check if that works. please boot Porteus and copy /boot/vmlinuz + /lib/modules + /lib/firmware directly to your Slackware installation (just in case do a backup of original Slackware files), point lilo to new kernel and restart to Slackware.
if that works then we will know that it's Slackware's kernel config fault (i would be surprised to see that).
if that wont work then it must be something with Slackware userland - it's a bit strange as Porteus 1.0 is based on slack-13.37 :%)

let me know if Porteus kernel made an audio working in Slackware correctly :wink:
Please add [Solved] to your thread title if the solution was found.

Jins
White ninja
White ninja
Posts: 6
Joined: 28 Aug 2011, 20:00
Location: Himitsu

Re: Sound and wlan

Post#7 by Jins » 30 Aug 2011, 19:41

Hello fanthom.
I using Slackware 13.37 32bit and this same porteus.
here is uname -a

Code: Select all

 Linux darkstar 2.6.38.8-porteus #1 SMP PREEMPT Tue Jun 14 07:33:06 UTC 2011 i686 AMD Turion(tm) 64 X2 Mobile Technology TL-56 AuthenticAMD GNU/Linux 
here lspci -k with porteus kernel

Code: Select all

 00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel modules: ati-agp
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
	Kernel modules: shpchp
00:04.0 PCI bridge: ATI Technologies Inc Device 7914
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
	Subsystem: ATI Technologies Inc SB600 Non-Raid-5 SATA
	Kernel driver in use: ahci
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: ohci_hcd
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: ohci_hcd
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: ohci_hcd
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: ohci_hcd
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: ohci_hcd
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: ehci_hcd
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: piix4_smbus
	Kernel modules: i2c-piix4
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: pata_atiixp
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
	Subsystem: Hewlett-Packard Company Device 30c2
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
	Kernel driver in use: k8temp
	Kernel modules: k8temp
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: radeon
	Kernel modules: radeon
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: yenta_cardbus
02:04.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 02)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: firewire_ohci
	Kernel modules: firewire-ohci
10:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
	Subsystem: Hewlett-Packard Company Device 30c2
	Kernel driver in use: tg3
	Kernel modules: tg3 
The same situation :wall: :%)

Best regards :)

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound and wlan

Post#8 by fanthom » 31 Aug 2011, 08:36

ok at least we know that it's not the kernel causing troubles :)

i have 3 other suggestions:
a) create new user and add him to audio, video, cdrom, xxx,xxx, groups in /etc/group file (use /etc/group from porteus as an example). check if audio is working normally for the new user.
if that wont work then:
b) boot porteus and go to /var/log/packages then compare packages used in porteus and slackware. make sure that packages are in the same version in both, if not then upgrade slackware to latest bits. pay attention especially to alsa* packages.
if the 2 above wont work:
c) install slackware from the scratch....

i have no other ideas - sorry.
Please add [Solved] to your thread title if the solution was found.

Jins
White ninja
White ninja
Posts: 6
Joined: 28 Aug 2011, 20:00
Location: Himitsu

Re: Sound and wlan

Post#9 by Jins » 31 Aug 2011, 08:56

Whell i instaled SalixOS 13.37 Slackware 13.37 also current from scratch 3 times and this same result. I'll try add new user and check out. But ebout porteous does it have enought development tools to compile packages?
Cheers

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Sound and wlan

Post#10 by francois » 31 Aug 2011, 15:50

Jins wrote:... But ebout porteous does it have enought development tools to compile packages?
Cheers
I imagine that you work with the 64-bit edition. :) Could you be more precise? There are all the already built packages or howto. You can look in cli mode verify the needed package (call the package or use slackyd) There are:

1) crippled sources:
http://ponce.cc/porteus/x86_64/current/ ... l-sources/
2) the main package there is PPM (Porteus package manager):
http://ponce.cc/porteus/x86_64/testing/1.0-fixes/
3) slackyd:
viewtopic.php?f=48&t=142
4) sbopkg:
viewtopic.php?f=53&t=680&hilit=sbopkg
Voltaire: Le mieux est l'ennemi du bien.

Jins
White ninja
White ninja
Posts: 6
Joined: 28 Aug 2011, 20:00
Location: Himitsu

Re: Sound and wlan

Post#11 by Jins » 31 Aug 2011, 16:31

Hi fanthom.
Plan a) new user worked out. Sou how can I drop sound settings and don't lose other settings and things? :unknown:
Cheers :Yahoo!:

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound and wlan

Post#12 by fanthom » 31 Aug 2011, 16:37

But ebout porteous does it have enought development tools to compile packages?
in Porteus world size matters: smaller = better :D
that's why not all development tools are included. for example 32bit edition lacks cmake, both editions lacks linuxdoc-tools, etc.
Luckily Porteus is Slackware compatible so you can convert txz packages to xzm modules or install them directly with installpkg command (this is useful especially when changes= cheatcode is used).

i believe that it's rather easy to convert Porteus into full blown development distro :wink:

EDIT:\\
Plan a) new user worked out. Sou how can I drop sound settings and don't lose other settings and things?
i'm glad to hear that :)
a) do a backup of your "old user" home folder
b) copy all files from "new user" home folder into old one

Code: Select all

cp -a /home/new_user/* /home/old_user
cp -a /home/new_user/.* /home/old_user
c) fix ownership/permissions on the "old user" home folder:

Code: Select all

chown -R old_user:old_user /home/old_user
d) log into old user account and check if everything is working ok including sound
e) in case of having problems recreate "old user" hoe folder from backup and copy files individually till you get everything working :)

good luck!
Please add [Solved] to your thread title if the solution was found.

Post Reply