Flash Video

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
tdrsam
Ronin
Ronin
Posts: 3
Joined: 20 Nov 2017, 05:31
Distribution: Cinnamon

Flash Video

Post#1 by tdrsam » 20 Nov 2017, 05:35

Is there a reason why I can't watch the live stream video from this website:

http://iview.abc.net.au/programs/abc-li ... 512H001S00

I'm using PaleMoon because I can't get Opera working. I can watch video on youtube, but not that other website.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1019
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Flash Video

Post#2 by ncmprhnsbl » 20 Nov 2017, 08:26

hi, welcome to porteus :)
you need the adobe flash plugin for that site
if you open a terminal and do:

Code: Select all

su
<root password>
update-flash
should get you the latest one in /tmp, just move it to the modules folder and activate it.
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

fulalas
DEV Team
DEV Team
Posts: 830
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Flash Video

Post#3 by fulalas » 20 Nov 2017, 08:32

It seems that there's something else with this link, because neither Opera 48 nor Firefox 57 can't load the video even with the last Pepper/Flash 27.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1019
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Flash Video

Post#4 by ncmprhnsbl » 20 Nov 2017, 09:17

fulalas wrote:
20 Nov 2017, 08:32
It seems that there's something else with this link, because neither Opera 48 nor Firefox 57 can't load the video even with the last Pepper/Flash 27.
interesting, because it just worked for me with palemoon and flash 27.0.0.170(not the latest)

edit just tried with firefox57 and it works too
i'll update my flash and see what happens... maybe abc iview is not compatible with the latest flash yet

edit 2: still working for me with firefox57 and flash 27.0.0.185
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1019
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Flash Video

Post#5 by ncmprhnsbl » 21 Nov 2017, 02:15

the other thing: is abc iview geo blocked outside of australia? if that's where you aren't..
tdrsam wrote:
20 Nov 2017, 05:35
I'm using PaleMoon because I can't get Opera working.
you probly need mozzilla-nss because the one in 3.2.2 is outdated(for opera, chromium, chrome)

Code: Select all

usm -g mozilla-nss
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Flash Video

Post#6 by Ed_P » 21 Nov 2017, 06:26

ncmprhnsbl wrote:
21 Nov 2017, 02:15
the other thing: is abc iview geo blocked outside of australia? if that's where you aren't..
I suspect that's the case. Blocked in Windows too, even with ActiveX filtering disabled.
Ed

tdrsam
Ronin
Ronin
Posts: 3
Joined: 20 Nov 2017, 05:31
Distribution: Cinnamon

Flash Video

Post#7 by tdrsam » 23 Nov 2017, 06:37

I still can't get this working.

It's not the geoblocking as I'm in Australia.

I tried updating flash but the command "update-flash" doesn't work. I get this error message: "bash: update-flash: command not found" There's nothing in the /tmp folder either.

I also have the flash module in my modules folder but nothing happens when I try to activate it.

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Flash Video

Post#8 by Ed_P » 23 Nov 2017, 06:47

tdrsam I don't know what version of flash you're using, or what version of Porteus for that matter, but USM has current flashplayers.

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# usm -s flashplayer

flashplayer-plugin-27.0.0.183-x86_64-1_slonly.txz was found in slackonly [upgrade]
flashplayer-plugin-11.2.202.635-x86_64-2sl.txz was found in slacky [downgrade]
flashplayer-plugin-27.0.0.183-x86_64-1alien.txz was found in alien [upgrade]
Packages found:   3 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/home/guest# 
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1019
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Flash Video

Post#9 by ncmprhnsbl » 23 Nov 2017, 07:35

tdrsam wrote:
23 Nov 2017, 06:37
I tried updating flash but the command "update-flash" doesn't work. I get this error message: "bash: update-flash: command not found"
sorry i keep forgetting this isn't in 3.2.2, :mega_shok:
what Ed said,
and if usm gives you trouble, here's a direct link:flashplayer-plugin-27.0.0.187-x86_64-1alien.txz
I also have the flash module in my modules folder but nothing happens when I try to activate it
nothing?
when its working it should show up in the browsers Addons>Plugins section
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

tdrsam
Ronin
Ronin
Posts: 3
Joined: 20 Nov 2017, 05:31
Distribution: Cinnamon

Flash Video

Post#10 by tdrsam » 23 Nov 2017, 08:16

Nope. I tried to install it from the adobe website. I tried to install it from that link. USM got stuck udpating a checksum.md5. There's nothing in the plugins section.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1019
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Flash Video

Post#11 by ncmprhnsbl » 23 Nov 2017, 09:18

tdrsam wrote:
23 Nov 2017, 08:16
I tried to install it from that link.
how?
here's what i'd do:
1. download the pkg (with web browser)
2. rightclick on it in the filemanager> choose "Convert <package>to Module"
3. move that module to /modules
4. doubleclick on it should active it
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

fulalas
DEV Team
DEV Team
Posts: 830
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Flash Video

Post#12 by fulalas » 23 Nov 2017, 20:26

I've just tested in Windows 10 + Opera last version and it doesn't work. Probably a geolocation issue for me, but maybe a Flash issue for tdrsam.

Post Reply