Gwenview settings never saved - NON KDE Porteus

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Gwenview settings never saved - NON KDE Porteus

Post#1 by Rava » 31 Jul 2011, 19:16

Hi,

I run Porteus 1.0 64 bit with all modules loaded, but I start LXDE, not KDE itself.

my problem: I always have to set "the [x] Enlarge smaller images" option by hand cause it is never saved.

And that means doing
Settings / Configure Gwenview / Image view -> [x] Enlarge smaller images
all over again when I started Porteus anew... :%)

Even when I re-started LXDE for some reasons then this setting was not saved and I have to set it again... :crazy:
It could be that the settings only got saved in a right manner when KDE is the desktop environment it runs in, but there should be a way to get that going in a NON KDE Porteus as well.

Any ideas how to do so?

The files and folders Gwenview uses seem to be:
./.kde4/share/config/gwenviewrc
./.kde4/share/apps/gwenview
./.kde4/share/apps/gwenview/recentfolders
./.kde4/share/apps/gwenview/gwenviewui.rc

in the user's home directory...
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Gwenview settings never saved - NON KDE Porteus

Post#2 by fanthom » 01 Aug 2011, 06:16

hi Rava,

works for me. make sure that you save your changes and make sure that you press "Apply" button after tweaking Gwenview settings, check
~/.kde4/share/config/gwenviewrc
and you should see:

Code: Select all

[ImageView]
EnlargeSmallerImages=true
Cheers
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Gwenview settings never saved - NON KDE Porteus

Post#3 by cttan » 03 Aug 2011, 00:37

Hi,

I have a question about Gwenview as well and thought of tagging to this one. Sorry Hamza.

I tried to load kipi-plugins-1.9.0-x86_64-2cf.xzm to be able to get plugins activated in Gwenview but no plugin is shown after kipi is activated.

The package is downloaded from Linux Package Search website. (kipi-plugins-1.9.0-x86_64-2cf.txz)

I would like to upload files to Facebook or Picasa Web Album using Gwenview.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Gwenview settings never saved - NON KDE Porteus

Post#4 by fanthom » 04 Aug 2011, 09:33

@cttan
'kipi-plugins' were not present in the system when i was compiling Gwenview so support for them may be disabled in this application.
OTOH - maybe it's enough to re-compile 'kipi-plugins' on Porteus-1.0 to get them working with Gwenview - i'll check this tomorrow.

cheers

EDIR:\\
yes - gwenview needs to be re-compiled with libkipi support. i'll do this for Porteus-1.1 and add kipi-plugins to official repo.
Please add [Solved] to your thread title if the solution was found.

cttan
Shogun
Shogun
Posts: 332
Joined: 26 Jan 2011, 16:15
Distribution: Porteus 3.2 64bit KDE
Location: Malaysia

Re: Gwenview settings never saved - NON KDE Porteus

Post#5 by cttan » 06 Aug 2011, 05:32

@fanthom
Thank you!

Post Reply