compat32-libraries

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
logick
White ninja
White ninja
Posts: 14
Joined: 18 Apr 2011, 08:38
Location: Poland

compat32-libraries

Post#1 by logick » 03 Oct 2017, 10:01

I am curious what should be added to Porteus-KDE-v3.2.2-x86_64 to make it capable of running SoftMaker-freeoffice2016-textmaker which I would like to use.
I already know that the large 0050-multilib-current-x86_64.xz will be sufficient but I feel that I do not need that much.
With Porteus-KDE4-v3.1-x86_64 I could run it with the little help of compat32-libraries-3.0-x86_64-1sl.xz

I will be grateful for any hint.

fulalas
DEV Team
DEV Team
Posts: 836
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

compat32-libraries

Post#2 by fulalas » 05 Oct 2017, 03:48


logick
White ninja
White ninja
Posts: 14
Joined: 18 Apr 2011, 08:38
Location: Poland

compat32-libraries

Post#3 by logick » 09 Oct 2017, 20:23

@fulalas

Thanks very much for your help but perhaps something more is needed to start
textmaker16free. With with libs-x86.xzm installed, I got the following message:

error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory

I run /home/guest# find /usr -name libX11* and I got:
/usr/lib64/libX11-xcb.so
/usr/lib64/libX11-xcb.so.1
/usr/lib64/libX11-xcb.so.1.0.0
/usr/lib64/libX11.so
/usr/lib64/libX11.so.6
/usr/lib64/libX11.so.6.3.0

which makes the present situation hard to understand
for a newbie like me.

tome
Contributor
Contributor
Posts: 577
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

compat32-libraries

Post#4 by tome » 01 Nov 2017, 20:34

Get any module from this post compat32-libraries-3.2 (Post by tome #59657)

fulalas
DEV Team
DEV Team
Posts: 836
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

compat32-libraries

Post#5 by fulalas » 02 Nov 2017, 02:15

@logick, sorry for the delay. If tome's libs are still not enough, you can try to manually download what's missing. Arch has a really good repository -- you just need to extract inside a root terminal or file manager and rename /usr/lib to /usr/lib64 and then repack it as a xzm module: https://www.archlinux.org/packages/mult ... 32-libx11/

Let me know if you've managed to make it work :)

logick
White ninja
White ninja
Posts: 14
Joined: 18 Apr 2011, 08:38
Location: Poland

compat32-libraries

Post#6 by logick » 15 Nov 2017, 11:30

@tome
@fulalas

I tried compat32-libraries-3.2-x86_64-2017-10-27-tm without
success but with 32bit-fd64_710 my freeoffice2016-textmaker
runs without any trouble.

Thanks very much for your help.

Post Reply