Looking for correct grub configuration for booting from an iso.

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
zerophase
Ronin
Ronin
Posts: 1
Joined: 16 Aug 2017, 17:36
Distribution: Arch Linux

Looking for correct grub configuration for booting from an iso.

Post#1 by zerophase » 16 Aug 2017, 20:02

When I boot I just get booting in blind mode, and sit there for 30 minutes without a change. I'm booting in efi by the way.

Here's my grub entry:
porteus='Porteus-CINNAMON-v3.2.2-x86_64.iso'

menuentry [loopback]$porteus {
set isofile='boot/iso/'$porteus
loopback loop $isofile
linux (loop)/boot/syslinux/vmlinuz vga=791 copy2ram
initrd (loop)/boot/syslinux/initrd.xz
}
Anyone see anything I'm missing?

User avatar
Ed_P
Contributor
Contributor
Posts: 3162
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Looking for correct grub configuration for booting from an iso.

Post#2 by Ed_P » 16 Aug 2017, 21:03

This is what I use with Grub2Win:

Code: Select all

menuentry " Porteus Cinnamon 3.2.2 ISO" --class slackware   --class icon-porteus  {

     set linux_folder=/porteus3.2
     set iso=/ISOs/Porteus-CINNAMON-v3.2.2-x86_64.iso
     set boot_parms="volume=33 reboot=cold changes=EXIT:$linux_folder/changes/porteussave.dat extramod=$linux_folder/Modules"
#     set boot_parms="nomodeset verbose delay=8 volume=33 reboot=cold changes=EXIT:$linux_folder/changes/porteussave.dat extramod=$linux_folder/Modules"
#     set gfxpayload=1024x768

     search -f $iso --set=root
     loopback loop $iso
     linux (loop)/boot/syslinux/vmlinuz from=$iso $boot_parms
     initrd (loop)/boot/syslinux/initrd.xz
     }
Note the "from=" cheatcode.

And be sure Secure Boot option is disabled on the EFI system.
Ed

Post Reply