[SOLVED] time zone issue

Share your opinion about Porteus Kiosk Edition.
Post Reply
pco
White ninja
White ninja
Posts: 5
Joined: 29 Jul 2017, 20:33
Distribution: 4.4.0

[SOLVED] time zone issue

Post#1 by pco » 29 Jul 2017, 20:48

I am working with my first installation of porteus. I am having an issue with the time.

I set the bios time to the local time (America/Detroit). I configure Porteus to use timezone=America/Detroit and load from saved file and burn to drive. After Porteus 4.4.0 boots, the bios time is shifted forward four hours to GMT. (I have a slow 1.5 Mbps internet connection for the kiosk.)

I want my kiosk to turn on a a certain time based on the bios time. Currently I have shifted the time by four hours (America/Detriot is four hours behind GMT), but I am not sure if I am seeing a bug, or if I am not understanding that Porteus uses only GMT even with the time zone set.
Last edited by pco on 16 Aug 2017, 16:18, edited 1 time in total.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 795
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

time zone issue

Post#2 by ncmprhnsbl » 29 Jul 2017, 23:39

hi, have moved your topic to the Kiosk section of the forum.
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

time zone issue

Post#3 by fanthom » 30 Jul 2017, 06:30

Hello pco,

If you want to keep the BIOS time (local time) then you need to set the time zone to 'Factory' and point ntp service to some non existing server. Please use these two parameters:

Code: Select all

timezone=Factory
ntp_server=fake.server.org
Let me know if this helped and i'll add this answer to the FAQ.

Thanks
Please add [Solved] to your thread title if the solution was found.

pco
White ninja
White ninja
Posts: 5
Joined: 29 Jul 2017, 20:33
Distribution: 4.4.0

time zone issue

Post#4 by pco » 30 Jul 2017, 13:04

Thank you. It may be just as easy for me to work with GMT, because with either setting I would need to make an adjustment when our local daylight savings time changes. It is OK for me to work with GMT. I was very confused when the BIOS time was changing. But now that I understand that this is intended, I can set the BIOS on my machine to boot according to GMT.

However, I will give your suggestion a try and respond with the results for the benefit of other users with the same question.

pco
White ninja
White ninja
Posts: 5
Joined: 29 Jul 2017, 20:33
Distribution: 4.4.0

time zone issue

Post#5 by pco » 16 Aug 2017, 16:17

Yes, the configuration by fanthom in #3 does work for me. However, I decided to let Porteus-Kiosk reset the BIOS time, because either way, I need to reset the boot time when our local time changes.

Post Reply