Nemesis update april-06-2017 discussion

Arch based Porteus community project
User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Nemesis update april-06-2017 discussion

Post#1 by francois » 07 Apr 2017, 03:34

Nemesis update april-06-2017 discussion and maybe bug report. Try to troubleshoot your problem as much as possible. This is to mean provide problems, research and solutions altogether as much as possible.

Thanks. :)
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Nemesis update april-06-2017 discussion

Post#2 by francois » 07 Apr 2017, 04:44

Installed xfce4 on Nemesis-06-04-2017
Problem 1
cheatcode login=root
loads me directly into openbox with no possibility of logout because of automatic reloading of openbox desktop.
Solution
removing login=root for now
finding the equivalent openrc to systemv init 3
Modifying ~/.xinitrc to boot xfce by inserting at the end of the file exec startxfce4 with a text editor like nano (command line) or mousepad (graphical environment):
exec startxfce4
https://forum.porteus.org/viewtopic.php?f=137&t=5105


Problem 2
xfce menu icon does not appear on panel bar: the icon themes are missing
Solution
I might go for gant icon theme which I had installed on porteus-wheezy
https://forum.porteus.org/viewtopic.php?f=114&t=3511
Curiously at second boot the icon theme resolved by itself.

Usefull settings in nemesis old thread:
https://forum.porteus.org/viewtopic.php?f=137&t=5105


chromium in root mode, no sandbox:

Code: Select all

chromium --no-sandbox
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Nemesis update april-06-2017 discussion

Post#3 by francois » 07 Apr 2017, 04:54

Hey man: nemesis this is really good shit. 8)

Great job neko and ncmprhnsbl. We now have the bleeding edge nemesis. I am running with the xfce4 desktop.

I will try to come with a functional xfce desktop module in the next few days if everything goes fine. Then the printer module. We will try to please jack with the in mate desktop.

Brokenman is a genius, pman wrapper is great, and nemesis is the brazilian wonder. We have solved the package pasture problem.

I can't wait for a ubuntu or debian version. :wink:
Voltaire: Le mieux est l'ennemi du bien.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 787
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Nemesis update april-06-2017 discussion

Post#4 by ncmprhnsbl » 10 Apr 2017, 02:39

have noticed that iptables is failing to start, during openrc startup.. have yet to investigate..
francois wrote:I can't wait for a ubuntu or debian version
this would take us back into systemd territory :wink:
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

Evan
Warlord
Warlord
Posts: 519
Joined: 11 Apr 2016, 09:00
Distribution: Anything Cinnamon
Location: London

Re: Nemesis update april-06-2017 discussion

Post#5 by Evan » 10 Apr 2017, 04:55

ncmprhnsbl wrote:
francois wrote:I can't wait for a ubuntu or debian version
this would take us back into systemd territory :wink:
Devuan
Forked from Debian, it offers various init systems excluding systemd.

User avatar
istinnjazz
Samurai
Samurai
Posts: 114
Joined: 15 May 2016, 14:10
Distribution: Manjaro-OpenRC/Nemesis

Re: Nemesis update april-06-2017 discussion

Post#6 by istinnjazz » 12 Apr 2017, 16:47

hallo. I have tested this update (and the previous one) by just replacing the corresponding files. I have kept my modded initrd, kernel and nvidia drivers.
There has to be some kind of X update problem because there is not any keyboard response. Previous nvidia driver seem to work ok though. tested with and without loading savefile and clean boot.
So, keyboard does not work and mouse reacts faster than before (only the notebook mouse pad works, usb mouse and keyboard does not). There has to be some kind of x option that is not compatible with my hardware.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 787
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Nemesis update april-06-2017 discussion

Post#7 by ncmprhnsbl » 12 Apr 2017, 21:46

hi istinnjazz, i think this is a problem with mesa-17.0.2-2and nvidia cards (neko warned me about this, but i went ahead anyway)
please try this earlier version of 002-gui 002-gui-4.xzm with mesa-17.0.1
hopefully a newer mesa will fix the issue with nvidia cards in future....
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

neko
Contributor
Contributor
Posts: 864
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

Re: Nemesis update april-06-2017 discussion

Post#8 by neko » 12 Apr 2017, 22:55

@ncmprhnsbl
mesa-17.0.1-1 includes as following libraries.
lrwxrwxrwx 1 root root 14 Mar 4 19:26 libGL.so -> libGL.so.1.2.0
lrwxrwxrwx 1 root root 14 Mar 4 19:26 libGL.so.1 -> libGL.so.1.2.0
-rwxr-xr-x 1 root root 457220 Mar 5 15:12 libGL.so.1.2.0

libGL.so.1 is symbolic linked to real entity libGL.so.1.2.0.

Later versions of mesa includes libGL.so.1 and libGL.so.1.2.0 too.
But libGL.so.1.2.0 is not a real entity.
It is symbolic linked to /usr/lib/mesa/libGL.so.1.2.0.
/usr/lib/mesa/libGL.so.1.2.0 is not included in this mesa package.

At boot, /usr/lib/xorg/modules/extensions/libglx.so, that is included in xorg-server package, needs the dependency library libGL.so.1.

Next APorteus update, I will fix this probrem by adding libglvnd package that includes libGL.so.1.

Thanks.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 787
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Nemesis update april-06-2017 discussion

Post#9 by ncmprhnsbl » 13 Apr 2017, 00:59

thanks neko, for clarifying that..
thinking about it, this doesnt seem like it would affect keyboard/mouse.. so maybe some other xorg update is the cause... need to look into this further...
check your Xorg.log for problems...
note: libglvd is included in 002-gui-5..
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
istinnjazz
Samurai
Samurai
Posts: 114
Joined: 15 May 2016, 14:10
Distribution: Manjaro-OpenRC/Nemesis

Re: Nemesis update april-06-2017 discussion

Post#10 by istinnjazz » 13 Apr 2017, 10:16

some xorg log/conf for whatever they worth for:

something valuable may be this:

xorg.0.log

Code: Select all

Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)

Code: Select all

[    29.051] 
X.Org X Server 1.17.4
Release Date: 2015-10-28
[    29.051] X Protocol Version 11, Revision 0
[    29.051] Build Operating System: Linux 4.2.5-1-ARCH x86_64 
[    29.051] Current Operating System: Linux porteus 4.6.3-xanmod5-porteus #2 SMP PREEMPT Tue Jul 12 19:06:47 UTC 2016 x86_64
[    29.052] Kernel command line: quiet initrd=dsdt_fixed1_init acpi.debug_level=0x2 acpi.debug_layer=0xFFFFFFFF acpi_osi="!Windows2006" zswap.enabled=1 zswap.compressor=lzo zswap.max_pool_percent=15 zswap.zpool=zbud fsck changes=/porteus/save.dat BOOT_IMAGE=vmlinuz 
[    29.052] Build Date: 01 November 2015  10:36:50AM
[    29.052]  
[    29.052] Current version of pixman: 0.32.8
[    29.052] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    29.052] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    29.052] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 13 12:16:56 2017
[    29.073] (==) Using config file: "/etc/X11/xorg.conf"
[    29.073] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    29.073] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    29.128] (==) ServerLayout "Layout0"
[    29.128] (**) |-->Screen "Screen0" (0)
[    29.128] (**) |   |-->Monitor "Monitor0"
[    29.128] (**) |   |-->Device "Device0"
[    29.128] (**) |-->Input Device "Keyboard0"
[    29.128] (**) |-->Input Device "Mouse0"
[    29.128] (**) Option "Xinerama" "0"
[    29.128] (==) Automatically adding devices
[    29.128] (==) Automatically enabling devices
[    29.128] (==) Automatically adding GPU devices
[    29.131] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".
[    29.131] 	Entry deleted from font path.
[    29.131] 	(Run 'mkfontdir' on "/usr/share/fonts/misc/").
[    29.132] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[    29.132] 	Entry deleted from font path.
[    29.132] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[    29.132] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    29.132] 	Entry deleted from font path.
[    29.132] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    29.132] 	Entry deleted from font path.
[    29.132] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    29.132] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    29.132] 	Entry deleted from font path.
[    29.132] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    29.132] (==) FontPath set to:
	/usr/share/fonts/TTF/
[    29.132] (==) ModulePath set to "/usr/lib/xorg/modules"
[    29.132] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    29.132] (WW) Disabling Keyboard0
[    29.132] (WW) Disabling Mouse0
[    29.132] (II) Loader magic: 0x817d60
[    29.132] (II) Module ABI versions:
[    29.132] 	X.Org ANSI C Emulation: 0.4
[    29.132] 	X.Org Video Driver: 19.0
[    29.132] 	X.Org XInput driver : 21.1
[    29.132] 	X.Org Server Extension : 9.0
[    29.134] (EE) systemd-logind: failed to get session: The name org.freedesktop.login1 was not provided by any .service files
[    29.134] (II) xfree86: Adding drm device (/dev/dri/card0)
[    29.136] (--) PCI:*(0:1:0:0) 10de:040d:103c:30c3 rev 161, Mem @ 0xe5000000/16777216, 0xd0000000/268435456, 0xe6000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/131072
[    29.136] (II) Open ACPI successful (/var/run/acpid.socket)
[    29.136] (II) LoadModule: "glx"
[    29.140] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    29.182] (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so: libnvidia-glcore.so.340.96: wrong ELF class: ELFCLASS32
[    29.182] (II) UnloadModule: "glx"
[    29.182] (II) Unloading glx
[    29.182] (EE) Failed to load module "glx" (loader failed, 7)
[    29.182] (II) LoadModule: "nvidia"
[    29.182] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    29.305] (II) Module nvidia: vendor="NVIDIA Corporation"
[    29.305] 	compiled for 4.0.2, module version = 1.0.0
[    29.305] 	Module class: X.Org Video Driver
[    29.329] (II) NVIDIA dlloader X Driver  340.96  Sun Nov  8 21:46:28 PST 2015
[    29.329] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    29.329] (++) using VT number 1

[    29.342] (II) Loading sub module "fb"
[    29.342] (II) LoadModule: "fb"
[    29.343] (II) Loading /usr/lib/xorg/modules/libfb.so
[    29.370] (II) Module fb: vendor="X.Org Foundation"
[    29.370] 	compiled for 1.17.4, module version = 1.0.0
[    29.370] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    29.370] (WW) Unresolved symbol: fbGetGCPrivateKey
[    29.370] (II) Loading sub module "wfb"
[    29.370] (II) LoadModule: "wfb"
[    29.371] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    29.371] (II) Module wfb: vendor="X.Org Foundation"
[    29.371] 	compiled for 1.17.4, module version = 1.0.0
[    29.371] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    29.371] (II) Loading sub module "ramdac"
[    29.371] (II) LoadModule: "ramdac"
[    29.371] (II) Module "ramdac" already built-in
[    29.398] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    29.398] (==) NVIDIA(0): RGB weight 888
[    29.398] (==) NVIDIA(0): Default visual is TrueColor
[    29.398] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    29.398] (**) NVIDIA(0): Option "Stereo" "0"
[    29.398] (**) NVIDIA(0): Option "nvidiaXineramaInfoOrder" "DFP-1"
[    29.398] (**) NVIDIA(0): Option "SLI" "Off"
[    29.398] (**) NVIDIA(0): Option "MultiGPU" "Off"
[    29.398] (**) NVIDIA(0): Option "BaseMosaic" "off"
[    29.398] (**) NVIDIA(0): Stereo disabled by request
[    29.398] (**) NVIDIA(0): NVIDIA SLI disabled.
[    29.398] (**) NVIDIA(0): NVIDIA Multi-GPU disabled.
[    29.398] (**) NVIDIA(0): Option "MetaModes" "LVDS-0: nvidia-auto-select +1920+0, DVI-D-0: nvidia-auto-select +0+0"
[    29.398] (**) NVIDIA(0): Enabling 2D acceleration
[    29.398] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[    29.398] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[    29.398] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[    29.398] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[    29.398] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
[    30.528] (II) NVIDIA(0): Display (LPL (DFP-0)) does not support NVIDIA 3D Vision
[    30.528] (II) NVIDIA(0):     stereo.
[    30.607] (II) NVIDIA(0): Display (Eizo SX2461W (DFP-1)) does not support NVIDIA 3D
[    30.607] (II) NVIDIA(0):     Vision stereo.
[    30.607] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[    30.609] (II) NVIDIA(0): NVIDIA GPU Quadro FX 1600M (G84GL) at PCI:1:0:0 (GPU-0)
[    30.609] (--) NVIDIA(0): Memory: 524288 kBytes
[    30.609] (--) NVIDIA(0): VideoBIOS: 60.84.74.00.11
[    30.609] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    30.617] (--) NVIDIA(0): Valid display device(s) on Quadro FX 1600M at PCI:1:0:0
[    30.617] (--) NVIDIA(0):     CRT-0
[    30.617] (--) NVIDIA(0):     TV-0
[    30.617] (--) NVIDIA(0):     LPL (DFP-0) (boot, connected)
[    30.617] (--) NVIDIA(0):     Eizo SX2461W (DFP-1) (connected)
[    30.617] (--) NVIDIA(0):     DFP-2
[    30.617] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    30.617] (--) NVIDIA(GPU-0): TV-0: 400.0 MHz maximum pixel clock
[    30.617] (--) NVIDIA(0): LPL (DFP-0): Internal LVDS
[    30.617] (--) NVIDIA(GPU-0): LPL (DFP-0): 330.0 MHz maximum pixel clock
[    30.617] (--) NVIDIA(0): Eizo SX2461W (DFP-1): Internal TMDS
[    30.617] (--) NVIDIA(GPU-0): Eizo SX2461W (DFP-1): 330.0 MHz maximum pixel clock
[    30.617] (--) NVIDIA(0): DFP-2: Internal TMDS
[    30.617] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[    30.617] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    30.617] (**) NVIDIA(0):     device LPL (DFP-0) (Using EDID frequencies has been
[    30.617] (**) NVIDIA(0):     enabled on all display devices.)
[    30.618] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    30.618] (**) NVIDIA(0):     device Eizo SX2461W (DFP-1) (Using EDID frequencies has
[    30.618] (**) NVIDIA(0):     been enabled on all display devices.)
[    30.620] (II) NVIDIA(0): Validated MetaModes:
[    30.620] (II) NVIDIA(0):    
[    30.620] (II) NVIDIA(0):     "LVDS-0:nvidia-auto-select+1920+0,DVI-D-0:nvidia-auto-select+0+0"
[    30.620] (II) NVIDIA(0): Virtual screen size determined to be 3600 x 1200
[    31.641] (--) NVIDIA(0): DPI set to (115, 115); computed from "UseEdidDpi" X config
[    31.641] (--) NVIDIA(0):     option
[    31.641] (--) Depth 24 pixmap format is 32 bpp
[    31.641] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[    31.678] (II) NVIDIA(0): Setting mode "LVDS-0:nvidia-auto-select+1920+0,DVI-D-0:nvidia-auto-select+0+0"
[    32.160] (==) NVIDIA(0): Disabling shared memory pixmaps
[    32.160] (==) NVIDIA(0): Backing store enabled
[    32.160] (==) NVIDIA(0): Silken mouse enabled
[    32.160] (**) NVIDIA(0): DPMS enabled
[    32.160] (II) Loading sub module "dri2"
[    32.160] (II) LoadModule: "dri2"
[    32.160] (II) Module "dri2" already built-in
[    32.160] (II) NVIDIA(0): [DRI2] Setup complete
[    32.160] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    32.160] (--) RandR disabled
[    32.399] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    32.399] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    32.399] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    32.399] (**) Power Button: Applying InputClass "Generic Keyboard"
[    32.399] (II) LoadModule: "libinput"
[    32.400] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.456] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.456] (II) UnloadModule: "libinput"
[    32.456] (II) Unloading libinput
[    32.456] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.456] (EE) No input driver matching `libinput'
[    32.456] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[    32.456] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    32.456] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    32.456] (**) Video Bus: Applying InputClass "Generic Keyboard"
[    32.456] (II) LoadModule: "libinput"
[    32.457] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.458] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.458] (II) UnloadModule: "libinput"
[    32.458] (II) Unloading libinput
[    32.458] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.458] (EE) No input driver matching `libinput'
[    32.458] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[    32.458] (II) No input driver specified, ignoring this device.
[    32.458] (II) This device may have been added with another device file.
[    32.458] (II) config/udev: Adding input device Sleep Button (/dev/input/event0)
[    32.458] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    32.458] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[    32.458] (**) Sleep Button: Applying InputClass "Generic Keyboard"
[    32.458] (II) LoadModule: "libinput"
[    32.459] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.460] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.460] (II) UnloadModule: "libinput"
[    32.460] (II) Unloading libinput
[    32.460] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.460] (EE) No input driver matching `libinput'
[    32.460] (II) config/udev: Adding input device HDA Intel Mic (/dev/input/event10)
[    32.460] (II) No input driver specified, ignoring this device.
[    32.460] (II) This device may have been added with another device file.
[    32.460] (II) config/udev: Adding input device HDA Intel Line (/dev/input/event11)
[    32.460] (II) No input driver specified, ignoring this device.
[    32.460] (II) This device may have been added with another device file.
[    32.461] (II) config/udev: Adding input device HDA Intel Headphone (/dev/input/event12)
[    32.461] (II) No input driver specified, ignoring this device.
[    32.461] (II) This device may have been added with another device file.
[    32.461] (II) config/udev: Adding input device A4Tech USB Mouse (/dev/input/event13)
[    32.461] (**) A4Tech USB Mouse: Applying InputClass "evdev pointer catchall"
[    32.461] (**) A4Tech USB Mouse: Applying InputClass "libinput pointer catchall"
[    32.461] (II) LoadModule: "libinput"
[    32.462] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.462] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.462] (II) UnloadModule: "libinput"
[    32.462] (II) Unloading libinput
[    32.462] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.462] (EE) No input driver matching `libinput'
[    32.463] (II) config/udev: Adding input device A4Tech USB Mouse (/dev/input/mouse2)
[    32.463] (II) No input driver specified, ignoring this device.
[    32.463] (II) This device may have been added with another device file.
[    32.463] (II) config/udev: Adding input device CHESEN USB Keyboard (/dev/input/event5)
[    32.463] (**) CHESEN USB Keyboard: Applying InputClass "evdev keyboard catchall"
[    32.463] (**) CHESEN USB Keyboard: Applying InputClass "libinput keyboard catchall"
[    32.463] (**) CHESEN USB Keyboard: Applying InputClass "Generic Keyboard"
[    32.463] (II) LoadModule: "libinput"
[    32.464] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.464] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.464] (II) UnloadModule: "libinput"
[    32.464] (II) Unloading libinput
[    32.464] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.464] (EE) No input driver matching `libinput'
[    32.465] (II) config/udev: Adding input device CHESEN USB Keyboard (/dev/input/event7)
[    32.465] (**) CHESEN USB Keyboard: Applying InputClass "evdev keyboard catchall"
[    32.465] (**) CHESEN USB Keyboard: Applying InputClass "libinput keyboard catchall"
[    32.465] (**) CHESEN USB Keyboard: Applying InputClass "Generic Keyboard"
[    32.465] (II) LoadModule: "libinput"
[    32.466] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.466] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.466] (II) UnloadModule: "libinput"
[    32.466] (II) Unloading libinput
[    32.466] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.466] (EE) No input driver matching `libinput'
[    32.466] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[    32.466] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    32.466] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[    32.466] (**) AT Translated Set 2 keyboard: Applying InputClass "Generic Keyboard"
[    32.466] (II) LoadModule: "libinput"
[    32.467] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.468] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.468] (II) UnloadModule: "libinput"
[    32.468] (II) Unloading libinput
[    32.468] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.468] (EE) No input driver matching `libinput'
[    32.468] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[    32.468] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    32.468] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "libinput touchpad catchall"
[    32.468] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    32.468] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    32.468] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    32.468] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    32.468] (II) LoadModule: "synaptics"
[    32.469] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    32.483] (II) Module synaptics: vendor="X.Org Foundation"
[    32.483] 	compiled for 1.17.4, module version = 1.8.3
[    32.483] 	Module class: X.Org XInput Driver
[    32.483] 	ABI class: X.Org XInput driver, version 21.1
[    32.483] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    32.483] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    32.483] (**) Option "Device" "/dev/input/event6"
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472 (res 70)
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448 (res 107)
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right middle double triple
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    32.505] (**) Option "TapButton1" "1"
[    32.505] (**) Option "TapButton2" "2"
[    32.505] (**) Option "TapButton3" "3"
[    32.505] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    32.505] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    32.517] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input12/event6"
[    32.517] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 6)
[    32.517] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    32.517] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    32.517] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.040
[    32.517] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    32.517] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    32.517] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    32.517] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    32.517] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    32.517] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    32.517] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    32.517] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event8)
[    32.518] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[    32.518] (**) PS/2 Generic Mouse: Applying InputClass "libinput pointer catchall"
[    32.518] (II) LoadModule: "libinput"
[    32.519] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.519] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.519] (II) UnloadModule: "libinput"
[    32.519] (II) Unloading libinput
[    32.519] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.519] (EE) No input driver matching `libinput'
[    32.519] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse1)
[    32.519] (II) No input driver specified, ignoring this device.
[    32.519] (II) This device may have been added with another device file.
[    32.519] (II) config/udev: Adding input device ST LIS3LV02DL Accelerometer (/dev/input/event9)
[    32.519] (II) No input driver specified, ignoring this device.
[    32.519] (II) This device may have been added with another device file.
[    32.520] (II) config/udev: Adding input device ST LIS3LV02DL Accelerometer (/dev/input/js0)
[    32.520] (II) No input driver specified, ignoring this device.
[    32.520] (II) This device may have been added with another device file.
[    32.520] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event14)
[    32.520] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    32.520] (**) HP WMI hotkeys: Applying InputClass "libinput keyboard catchall"
[    32.520] (**) HP WMI hotkeys: Applying InputClass "Generic Keyboard"
[    32.520] (II) LoadModule: "libinput"
[    32.521] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    32.521] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)
[    32.521] (II) UnloadModule: "libinput"
[    32.521] (II) Unloading libinput
[    32.521] (EE) Failed to load module "libinput" (loader failed, 7)
[    32.521] (EE) No input driver matching `libinput'
[    46.135] (II) NVIDIA(GPU-0): Display (LPL (DFP-0)) does not support NVIDIA 3D Vision
[    46.135] (II) NVIDIA(GPU-0):     stereo.
[    46.190] (II) NVIDIA(GPU-0): Display (Eizo SX2461W (DFP-1)) does not support NVIDIA 3D
[    46.190] (II) NVIDIA(GPU-0):     Vision stereo.
xorg.conf

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 340.96  (buildmeister@swio-display-x86-rhel47-05)  Sun Nov  8 22:50:12 PST 2015

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.96  (buildmeister@swio-display-x86-rhel47-05)  Sun Nov  8 22:50:27 PST 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LPL"
    HorizSync       30.0 - 75.0
    VertRefresh     59.9
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 1600M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "LVDS-0: nvidia-auto-select +1920+0, DVI-D-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

10-keyboard.conf

Code: Select all

Section "InputClass"
   Identifier  "Generic Keyboard"
   MatchIsKeyboard   "yes"
   Option      "CoreKeyboard"
   Option      "XkbRules"  "xorg"
   Option      "XkbModel"  "pc105"
   Option      "XkbLayout" "us,el"
   Option      "XkbOptions"   "grp:alt_shift_toggle,compose:menu,grp_led:scroll"
EndSection

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Nemesis update april-06-2017 discussion

Post#11 by francois » 13 Apr 2017, 22:59

There seems to be some understanding in the following threads :
http://www.linuxquestions.org/questions ... 175597804/
http://www.linuxquestions.org/questions ... 175597804/
https://askubuntu.com/questions/649103/ ... 122#678122

It turned out that I installed some unnecessary libraries (xf86-input-libinput)
https://unix.stackexchange.com/question ... ork/328872
Voltaire: Le mieux est l'ennemi du bien.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 787
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Nemesis update april-06-2017 discussion

Post#12 by ncmprhnsbl » 13 Apr 2017, 23:44

do you have libinput or xf86-input-libinput in any(if there are) other modules loaded? (they should only be in core and gui respectively)
check in /mnt/live/memory/images/<module.xzm>/var/lib/pacman/local/
what is the output of pacman -Syu ?
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
istinnjazz
Samurai
Samurai
Posts: 114
Joined: 15 May 2016, 14:10
Distribution: Manjaro-OpenRC/Nemesis

Re: Nemesis update april-06-2017 discussion

Post#13 by istinnjazz » 14 Apr 2017, 18:59

Just one gpu here. Both nvidia drivers and nouveau tested respectively. Clean system boot also tested (no modules). Same result. So I guess ncmprhnsbl asks francois about libinput etc. Remember no keyb input for me, except if I will make a software virtual keyboard module with the old core. Please inform me if you need such kind of log/data that need root or terminal.

User avatar
istinnjazz
Samurai
Samurai
Posts: 114
Joined: 15 May 2016, 14:10
Distribution: Manjaro-OpenRC/Nemesis

Re: Nemesis update april-06-2017 discussion

Post#14 by istinnjazz » 14 Apr 2017, 21:31

Ok, I had made a mistake, I had moved old core files to a folder inside base directory... sorry, so clean boot is ok now, I will test my system with savefile and modules also. So no problem with input, just a conflict. (moved old files dir to a path outside base). Sorry for the frustration.

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: Nemesis update april-06-2017 discussion

Post#15 by beny » 14 Apr 2017, 22:11

hi istinnjazz but nemesis work for you the first edition? if yes you can upgrade only the x package with the last xorg and the last mesa and repack .

Post Reply