Video playing lag incorrect vga driver installed?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
YonZeroYon
White ninja
White ninja
Posts: 9
Joined: 23 Mar 2017, 04:23
Distribution: Porteus
Location: Japan

Video playing lag incorrect vga driver installed?

Post#1 by YonZeroYon » 23 Mar 2017, 08:36

The video plays but with noticeable kinda lag while 240p, 360p Youtube videos playing through Firefox consumes nearly 50% cpu.

How to troubleshoot such issue?

Thank you.

lscpu
Model name: Intel(R) Pentium(R) CPU G2020 @ 2.90GHz

lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0b)
03:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe

dmesg | grep intel
[ 0.241685] intel_idle: MWAIT substates: 0x1120
[ 0.241685] intel_idle: v0.4.1 model 0x3A
[ 0.241736] intel_idle: lapic_timer_reliable_states 0xffffffff
[ 0.273615] intel_pstate: Intel P-state driver initializing
[ 8.495598] intel_rapl: Found RAPL domain package
[ 8.495600] intel_rapl: Found RAPL domain core
[ 8.495600] intel_rapl: Found RAPL domain uncore
[ 8.495603] intel_rapl: RAPL package 0 domain package locked by BIOS
[ 8.537739] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops 0xffffffffa01c4ec0)
[ 9.047891] fbcon: inteldrmfb (fb0) is primary device
[ 9.246918] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device

Code: Select all

lsmod
Module                  Size  Used by
ipv6                  228313  12
input_leds              2432  0
wl                   6225308  0
ppdev                   5064  0
intel_rapl              7776  0
coretemp                4740  0
kvm_intel             143484  0
kvm                   226297  1 kvm_intel
irqbypass               2176  1 kvm
crct10dif_pclmul        3264  0
crc32_pclmul            2048  0
crc32c_intel            7296  0
ghash_clmulni_intel     2944  0
cryptd                  4872  1 ghash_clmulni_intel
intel_cstate            4201  0
intel_rapl_perf         5088  0
arc4                    1728  2
snd_hda_codec_hdmi     23937  1
i2c_i801               10892  0
i2c_smbus               2368  1 i2c_i801
rt2800pci               4673  0
rt2800mmio              4928  1 rt2800pci
rt2800lib              58304  2 rt2800mmio,rt2800pci
rt2x00pci               2304  1 rt2800pci
rt2x00mmio              2176  2 rt2800mmio,rt2800pci
rt2x00lib              23936  5 rt2800lib,rt2x00pci,rt2800mmio,rt2x00mmio,rt2800pci
led_class               2760  2 rt2x00lib,input_leds
mac80211              249664  3 rt2800lib,rt2x00pci,rt2x00lib
snd_hda_codec_realtek    47824  1
snd_hda_codec_generic    36288  1 snd_hda_codec_realtek
cfg80211              159056  3 wl,rt2x00lib,mac80211
i915                  836032  5
rfkill                 10704  2 cfg80211
crc_ccitt               1408  1 rt2800lib
eeprom_93cx6            1856  1 rt2800pci
r8169                  47616  0
mii                     3072  1 r8169
mei_me                  9152  0
mei                    33080  1 mei_me
shpchp                 18502  0
snd_hda_intel          17280  3
snd_hda_codec          57728  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           30920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep               3976  1 snd_hda_codec
snd_pcm                50512  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_timer              14500  1 snd_pcm
intel_gtt               9096  1 i915
firmware_class          5248  4 r8169,snd_hda_intel,rt2x00lib,i915
fan                     3392  0
wmi                     5570  0
8250                   11880  0
parport_pc             20580  0
8250_base              16768  1 8250
serial_core            15168  2 8250,8250_base
parport                25136  2 parport_pc,ppdev
ite_cir                10716  0
fjes                   15552  0
/var/log/Xorg

Code: Select all

[    11.190] 
X.Org X Server 1.18.3
Release Date: 2016-04-04
[    11.192] X Protocol Version 11, Revision 0
[    11.192] Build Operating System: Slackware 14.2 Slackware Linux Project
[    11.192] Current Operating System: Linux DESKTOP-VM019VQ 4.9.0-porteus #1 SMP PREEMPT Sat Dec 17 19:22:10 BRST 2016 x86_64
[    11.194] Kernel command line: quiet initrd=initrd.xz copy2ram login=root BOOT_IMAGE=vmlinuz 
[    11.194] Build Date: 15 April 2016  11:05:21AM
[    11.194]  
[    11.194] Current version of pixman: 0.34.0
[    11.195] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    11.195] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.197] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 23 16:34:48 2017
[    11.201] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    11.205] (==) No Layout section.  Using the first Screen section.
[    11.205] (==) No screen section available. Using defaults.
[    11.205] (**) |-->Screen "Default Screen Section" (0)
[    11.205] (**) |   |-->Monitor "<default monitor>"
[    11.205] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    11.205] (==) Automatically adding devices
[    11.205] (==) Automatically enabling devices
[    11.205] (==) Automatically adding GPU devices
[    11.216] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    11.217] (WW) The directory "/usr/share/fonts/local" does not exist.
[    11.217] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (WW) The directory "/usr/share/fonts/cyrillic" does not exist.
[    11.218] 	Entry deleted from font path.
[    11.218] (==) FontPath set to:
	/usr/share/fonts/TTF
[    11.218] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    11.218] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    11.218] (II) Loader magic: 0x808c00
[    11.218] (II) Module ABI versions:
[    11.218] 	X.Org ANSI C Emulation: 0.4
[    11.218] 	X.Org Video Driver: 20.0
[    11.218] 	X.Org XInput driver : 22.1
[    11.218] 	X.Org Server Extension : 9.0
[    11.218] (II) xfree86: Adding drm device (/dev/dri/card0)
[    11.230] (--) PCI:*(0:0:2:0) 8086:0152:1025:074a rev 9, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[    11.230] (II) Open ACPI successful (/var/run/acpid.socket)
[    11.230] (II) LoadModule: "glx"
[    11.240] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    11.251] (II) Module glx: vendor="X.Org Foundation"
[    11.251] 	compiled for 1.18.3, module version = 1.0.0
[    11.251] 	ABI class: X.Org Server Extension, version 9.0
[    11.251] (==) AIGLX enabled
[    11.251] (==) Matched intel as autoconfigured driver 0
[    11.251] (==) Matched intel as autoconfigured driver 1
[    11.251] (==) Matched modesetting as autoconfigured driver 2
[    11.251] (==) Matched fbdev as autoconfigured driver 3
[    11.251] (==) Matched vesa as autoconfigured driver 4
[    11.251] (==) Assigned the driver to the xf86ConfigLayout
[    11.251] (II) LoadModule: "intel"
[    11.252] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    11.313] (II) Module intel: vendor="X.Org Foundation"
[    11.313] 	compiled for 1.18.3, module version = 2.99.917
[    11.313] 	Module class: X.Org Video Driver
[    11.313] 	ABI class: X.Org Video Driver, version 20.0
[    11.313] (II) LoadModule: "modesetting"
[    11.315] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    11.329] (II) Module modesetting: vendor="X.Org Foundation"
[    11.329] 	compiled for 1.18.3, module version = 1.18.3
[    11.329] 	Module class: X.Org Video Driver
[    11.329] 	ABI class: X.Org Video Driver, version 20.0
[    11.329] (II) LoadModule: "fbdev"
[    11.330] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[    11.348] (II) Module fbdev: vendor="X.Org Foundation"
[    11.348] 	compiled for 1.18.0, module version = 0.4.4
[    11.348] 	Module class: X.Org Video Driver
[    11.348] 	ABI class: X.Org Video Driver, version 20.0
[    11.348] (II) LoadModule: "vesa"
[    11.348] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    11.364] (II) Module vesa: vendor="X.Org Foundation"
[    11.364] 	compiled for 1.18.0, module version = 2.3.4
[    11.364] 	Module class: X.Org Video Driver
[    11.364] 	ABI class: X.Org Video Driver, version 20.0
[    11.364] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    11.365] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    11.365] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    11.365] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    11.365] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    11.365] (II) FBDEV: driver for framebuffer: fbdev
[    11.365] (II) VESA: driver for VESA chipsets: vesa
[    11.365] (--) using VT number 7

[    11.537] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[    11.547] (WW) Falling back to old probe method for modesetting
[    11.547] (WW) Falling back to old probe method for fbdev
[    11.547] (II) Loading sub module "fbdevhw"
[    11.547] (II) LoadModule: "fbdevhw"
[    11.549] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    11.555] (II) Module fbdevhw: vendor="X.Org Foundation"
[    11.555] 	compiled for 1.18.3, module version = 0.0.2
[    11.555] 	ABI class: X.Org Video Driver, version 20.0
[    11.555] (WW) Falling back to old probe method for vesa
[    11.555] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 2500
[    11.555] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[    11.555] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    11.555] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    11.555] (==) intel(0): RGB weight 888
[    11.555] (==) intel(0): Default visual is TrueColor
[    11.556] (II) intel(0): Output VGA1 has no monitor section
[    11.556] (II) intel(0): Enabled output VGA1
[    11.556] (II) intel(0): Output HDMI1 has no monitor section
[    11.556] (II) intel(0): Enabled output HDMI1
[    11.556] (II) intel(0): Output DP1 has no monitor section
[    11.556] (II) intel(0): Enabled output DP1
[    11.556] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    11.556] (II) intel(0): Output VIRTUAL1 has no monitor section
[    11.556] (II) intel(0): Enabled output VIRTUAL1
[    11.556] (--) intel(0): Output VGA1 using initial mode 1920x1080 on pipe 0
[    11.556] (==) intel(0): TearFree disabled
[    11.556] (==) intel(0): DPI set to (96, 96)
[    11.556] (II) Loading sub module "dri2"
[    11.556] (II) LoadModule: "dri2"
[    11.556] (II) Module "dri2" already built-in
[    11.556] (II) Loading sub module "present"
[    11.556] (II) LoadModule: "present"
[    11.556] (II) Module "present" already built-in
[    11.556] (II) UnloadModule: "modesetting"
[    11.556] (II) Unloading modesetting
[    11.556] (II) UnloadModule: "fbdev"
[    11.556] (II) Unloading fbdev
[    11.556] (II) UnloadSubModule: "fbdevhw"
[    11.556] (II) Unloading fbdevhw
[    11.556] (II) UnloadModule: "vesa"
[    11.556] (II) Unloading vesa
[    11.556] (==) Depth 24 pixmap format is 32 bpp
[    11.582] (II) intel(0): SNA initialized with Ivybridge (gen7, gt1) backend
[    11.582] (==) intel(0): Backing store enabled
[    11.582] (==) intel(0): Silken mouse enabled
[    11.582] (II) intel(0): HW Cursor enabled
[    11.582] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    11.583] (==) intel(0): DPMS enabled
[    11.583] (==) intel(0): Display hotplug detection enabled
[    11.583] (II) intel(0): [DRI2] Setup complete
[    11.583] (II) intel(0): [DRI2]   DRI driver: i965
[    11.583] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    11.583] (II) intel(0): direct rendering: DRI2 enabled
[    11.583] (II) intel(0): hardware support for Present enabled
[    11.583] (--) RandR disabled
[    11.731] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    11.731] (II) AIGLX: enabled GLX_ARB_create_context
[    11.731] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    11.731] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[    11.731] (II) AIGLX: enabled GLX_INTEL_swap_event
[    11.731] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    11.731] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    11.731] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    11.731] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[    11.731] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    11.731] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[    11.731] (II) AIGLX: Loaded and initialized i965
[    11.731] (II) GLX: Initialized DRI2 GL provider for screen 0
[    11.733] (II) intel(0): switch to mode 1920x1080@60.0 on VGA1 using pipe 0, position (0, 0), rotation normal, reflection none
[    11.744] (II) intel(0): Setting screen physical size to 508 x 285
[    11.833] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    11.833] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    11.833] (**) Power Button: Applying InputClass "keyboard-all"
[    11.833] (II) LoadModule: "evdev"
[    11.834] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    11.852] (II) Module evdev: vendor="X.Org Foundation"
[    11.852] 	compiled for 1.18.3, module version = 2.10.3
[    11.852] 	Module class: X.Org XInput Driver
[    11.852] 	ABI class: X.Org XInput driver, version 22.1
[    11.852] (II) Using input driver 'evdev' for 'Power Button'
[    11.852] (**) Power Button: always reports core events
[    11.852] (**) evdev: Power Button: Device: "/dev/input/event1"
[    11.852] (--) evdev: Power Button: Vendor 0 Product 0x1
[    11.852] (--) evdev: Power Button: Found keys
[    11.852] (II) evdev: Power Button: Configuring as keyboard
[    11.852] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    11.852] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    11.852] (**) Option "xkb_rules" "evdev"
[    11.852] (**) Option "xkb_layout" "us"
[    11.852] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    11.873] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[    11.874] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    11.874] (**) Video Bus: Applying InputClass "keyboard-all"
[    11.874] (II) Using input driver 'evdev' for 'Video Bus'
[    11.874] (**) Video Bus: always reports core events
[    11.874] (**) evdev: Video Bus: Device: "/dev/input/event5"
[    11.874] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    11.874] (--) evdev: Video Bus: Found keys
[    11.874] (II) evdev: Video Bus: Configuring as keyboard
[    11.874] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input13/event5"
[    11.874] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    11.874] (**) Option "xkb_rules" "evdev"
[    11.874] (**) Option "xkb_layout" "us"
[    11.874] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    11.874] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    11.874] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    11.874] (**) Power Button: Applying InputClass "keyboard-all"
[    11.874] (II) Using input driver 'evdev' for 'Power Button'
[    11.874] (**) Power Button: always reports core events
[    11.874] (**) evdev: Power Button: Device: "/dev/input/event0"
[    11.874] (--) evdev: Power Button: Vendor 0 Product 0x1
[    11.874] (--) evdev: Power Button: Found keys
[    11.874] (II) evdev: Power Button: Configuring as keyboard
[    11.874] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[    11.874] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[    11.874] (**) Option "xkb_rules" "evdev"
[    11.874] (**) Option "xkb_layout" "us"
[    11.874] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    11.875] (II) config/udev: Adding input device Genius USB Optical Mouse (/dev/input/event2)
[    11.875] (**) Genius USB Optical Mouse: Applying InputClass "evdev pointer catchall"
[    11.875] (II) Using input driver 'evdev' for 'Genius USB Optical Mouse'
[    11.875] (**) Genius USB Optical Mouse: always reports core events
[    11.875] (**) evdev: Genius USB Optical Mouse: Device: "/dev/input/event2"
[    11.875] (--) evdev: Genius USB Optical Mouse: Vendor 0x458 Product 0x3a
[    11.875] (--) evdev: Genius USB Optical Mouse: Found 12 mouse buttons
[    11.875] (--) evdev: Genius USB Optical Mouse: Found scroll wheel(s)
[    11.875] (--) evdev: Genius USB Optical Mouse: Found relative axes
[    11.875] (--) evdev: Genius USB Optical Mouse: Found x and y relative axes
[    11.875] (II) evdev: Genius USB Optical Mouse: Configuring as mouse
[    11.875] (II) evdev: Genius USB Optical Mouse: Adding scrollwheel support
[    11.875] (**) evdev: Genius USB Optical Mouse: YAxisMapping: buttons 4 and 5
[    11.875] (**) evdev: Genius USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    11.875] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:0458:003A.0001/input/input5/event2"
[    11.875] (II) XINPUT: Adding extended input device "Genius USB Optical Mouse" (type: MOUSE, id 9)
[    11.875] (II) evdev: Genius USB Optical Mouse: initialized for relative axes.
[    11.875] (**) Genius USB Optical Mouse: (accel) keeping acceleration scheme 1
[    11.875] (**) Genius USB Optical Mouse: (accel) acceleration profile 0
[    11.875] (**) Genius USB Optical Mouse: (accel) acceleration factor: 2.000
[    11.875] (**) Genius USB Optical Mouse: (accel) acceleration threshold: 4
[    11.875] (II) config/udev: Adding input device Genius USB Optical Mouse (/dev/input/mouse0)
[    11.875] (II) No input driver specified, ignoring this device.
[    11.875] (II) This device may have been added with another device file.
[    11.875] (II) config/udev: Adding input device NOVATEK USB Keyboard (/dev/input/event3)
[    11.875] (**) NOVATEK USB Keyboard: Applying InputClass "evdev keyboard catchall"
[    11.875] (**) NOVATEK USB Keyboard: Applying InputClass "keyboard-all"
[    11.875] (II) Using input driver 'evdev' for 'NOVATEK USB Keyboard'
[    11.875] (**) NOVATEK USB Keyboard: always reports core events
[    11.875] (**) evdev: NOVATEK USB Keyboard: Device: "/dev/input/event3"
[    11.875] (--) evdev: NOVATEK USB Keyboard: Vendor 0x461 Product 0x10
[    11.875] (--) evdev: NOVATEK USB Keyboard: Found keys
[    11.875] (II) evdev: NOVATEK USB Keyboard: Configuring as keyboard
[    11.875] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0461:0010.0002/input/input6/event3"
[    11.875] (II) XINPUT: Adding extended input device "NOVATEK USB Keyboard" (type: KEYBOARD, id 10)
[    11.875] (**) Option "xkb_rules" "evdev"
[    11.875] (**) Option "xkb_layout" "us"
[    11.875] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    11.876] (II) config/udev: Adding input device NOVATEK USB Keyboard (/dev/input/event4)
[    11.876] (**) NOVATEK USB Keyboard: Applying InputClass "evdev keyboard catchall"
[    11.876] (**) NOVATEK USB Keyboard: Applying InputClass "keyboard-all"
[    11.876] (II) Using input driver 'evdev' for 'NOVATEK USB Keyboard'
[    11.876] (**) NOVATEK USB Keyboard: always reports core events
[    11.876] (**) evdev: NOVATEK USB Keyboard: Device: "/dev/input/event4"
[    11.876] (--) evdev: NOVATEK USB Keyboard: Vendor 0x461 Product 0x10
[    11.876] (--) evdev: NOVATEK USB Keyboard: Found keys
[    11.876] (II) evdev: NOVATEK USB Keyboard: Configuring as keyboard
[    11.876] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.1/0003:0461:0010.0003/input/input7/event4"
[    11.876] (II) XINPUT: Adding extended input device "NOVATEK USB Keyboard" (type: KEYBOARD, id 11)
[    11.876] (**) Option "xkb_rules" "evdev"
[    11.876] (**) Option "xkb_layout" "us"
[    11.876] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    11.876] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event8)
[    11.876] (II) No input driver specified, ignoring this device.
[    11.876] (II) This device may have been added with another device file.
[    11.876] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event9)
[    11.876] (II) No input driver specified, ignoring this device.
[    11.876] (II) This device may have been added with another device file.
[    11.876] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event10)
[    11.877] (II) No input driver specified, ignoring this device.
[    11.877] (II) This device may have been added with another device file.
[    11.877] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event11)
[    11.877] (II) No input driver specified, ignoring this device.
[    11.877] (II) This device may have been added with another device file.
[    11.877] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event6)
[    11.877] (II) No input driver specified, ignoring this device.
[    11.877] (II) This device may have been added with another device file.
[    11.877] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event7)
[    11.877] (II) No input driver specified, ignoring this device.
[    11.877] (II) This device may have been added with another device file.

fulalas
Contributor
Contributor
Posts: 580
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: Video playing lag incorrect vga driver installed?

Post#2 by fulalas » 23 Mar 2017, 21:54

Does it run well inside a stand-alone video player?

YonZeroYon
White ninja
White ninja
Posts: 9
Joined: 23 Mar 2017, 04:23
Distribution: Porteus
Location: Japan

Re: Video playing lag incorrect vga driver installed?

Post#3 by YonZeroYon » 24 Mar 2017, 03:15

mp4, mkv, or etc video formats generally runs using SMPlayer or the default Gnome MPlayer, but I could see a slight frame lag which is unnoticeable in Porteus 3.1

I don't know how to diagnose such issue. :cry:

So far, I suspect something to do with VDPAU, I installed Avidemux 2.6.18, the default video display is VDPAU (best) but the movie barely play under this setting and this system has no Nvidia GPU.

It works if I set it to XVideo (best), but still I could notice some slight frame lag.

fulalas
Contributor
Contributor
Posts: 580
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: Video playing lag incorrect vga driver installed?

Post#4 by fulalas » 24 Mar 2017, 05:14

Usually SMPlayer comes with no GPU acceleration activated, so you're probably running only with your CPU. If it's running fine inside SMPlayer, it means that you have enough CPU-power to handle videos, so the problem inside a browser is not related to your hardware. Maybe you can try another browser, like Opera, or if you're already using Chromium engine based browser, you can try Firefox.

I have a Pentium G4560, which is a little bit faster than your Pentium G2020, but it cannot handle 1080p Youtube videos without dropping some frames. However, it can handle the same video inside SMPlayer with no GPU acceleration and no drops at all. I can't understand why, but that's life... :unknown: The good news is that Opera is implementing HTML5 video decoding accelerated by GPU, so maybe in the near future we won't have problems in this regard. :good:

YonZeroYon
White ninja
White ninja
Posts: 9
Joined: 23 Mar 2017, 04:23
Distribution: Porteus
Location: Japan

Re: Video playing lag incorrect vga driver installed?

Post#5 by YonZeroYon » 24 Mar 2017, 05:32

But everything seems to work fine in Porteus 3.1 :unknown: Why 3.2.2 having such issues?

fulalas
Contributor
Contributor
Posts: 580
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: Video playing lag incorrect vga driver installed?

Post#6 by fulalas » 24 Mar 2017, 05:52

Can you try to switch the browser you used in 3.1 to 3.2.2 and vice-versa? I suspect that this is related to the browser more than anything else.

YonZeroYon
White ninja
White ninja
Posts: 9
Joined: 23 Mar 2017, 04:23
Distribution: Porteus
Location: Japan

Re: Video playing lag incorrect vga driver installed?

Post#7 by YonZeroYon » 24 Mar 2017, 07:01

I could see noticeable frames drop using SMPlayer or Gnome MPlayer, playing some 1080p or 720p MKV or MP4 which doesn't occur when under Porteus 3.1 on the exact desktop.

I give up using Flash on Firefox, change to webm currently, still detect noticeable frames drop especially when the tube scenes moving fast, it appears like video playing in Windows using generic standard vga driver.

fulalas
Contributor
Contributor
Posts: 580
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: Video playing lag incorrect vga driver installed?

Post#8 by fulalas » 24 Mar 2017, 08:54

I see. Try this 002-xorg module: viewtopic.php?f=75&t=6721

Just put it inside porteus_path/porteus/base and rename the old one to avoid conflict.

If this solves the problem, so you have a driver problem. Let me know :)

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Video playing lag incorrect vga driver installed?

Post#9 by Bogomips » 24 Mar 2017, 15:33

PaleMoon (the no hassles FF ;) )
It's the html5 player here with cpu load around 40%. Halved that by using GreaseMonkey with Gecko-Mediaplayer Plugin. 8)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

YonZeroYon
White ninja
White ninja
Posts: 9
Joined: 23 Mar 2017, 04:23
Distribution: Porteus
Location: Japan

Re: Video playing lag incorrect vga driver installed?

Post#10 by YonZeroYon » 24 Mar 2017, 23:21

Bogomips wrote:PaleMoon (the no hassles FF ;) )
It's the html5 player here with cpu load around 40%. Halved that by using GreaseMonkey with Gecko-Mediaplayer Plugin. 8)
Hi, what are the script's functions you run on top of Youtube or other video streaming websites?
fulalas wrote:I see. Try this 002-xorg module: viewtopic.php?f=75&t=6721
Thanks fulalas, cross fingers hope this Mesa & Xorg update could solve all the glitches.

YonZeroYon
White ninja
White ninja
Posts: 9
Joined: 23 Mar 2017, 04:23
Distribution: Porteus
Location: Japan

Re: Video playing lag incorrect vga driver installed?

Post#11 by YonZeroYon » 26 Mar 2017, 09:35

fulalas wrote:Just put it inside porteus_path/porteus/base and rename the old one to avoid conflict.
System seems hangs upon login screen, mouse and keyboard freezes, (keyboard indicators don't work when I pressed caps lock, num lock or srcoll lock) Ctrl + Alt + F2 doesn't work.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Video playing lag incorrect vga driver installed?

Post#12 by Bogomips » 26 Mar 2017, 11:42

YonZeroYon wrote:Hi, what are the script's functions you run on top of Youtube or other video streaming websites?
Greasemonkey user script & Viewtube. Also Linktube for embedded.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fulalas
Contributor
Contributor
Posts: 580
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: Video playing lag incorrect vga driver installed?

Post#13 by fulalas » 26 Mar 2017, 22:56

YonZeroYon wrote:System seems hangs upon login screen, mouse and keyboard freezes, (keyboard indicators don't work when I pressed caps lock, num lock or srcoll lock) Ctrl + Alt + F2 doesn't work.
It happens with current Porteus' DEs. You should try the LXQt module linked inside the same topic.

BTW, I've finally managed to put VAAPI to work, now consuming less than 5% of CPU at 4k videos :good: You just need to load these 2 modules and set SMPlayer to enable vaapi under Preferences -> Performance -> Decoding -> Hardware decoding:
http://www.mediafire.com/file/qi8jvi3t8 ... x86_64.xzm
http://www.mediafire.com/file/p204l75n8 ... x86_64.xzm

I recommend Mpv instead of MPlayer. Note that Mpv is the default video-engine player inside my LXQt module, so you just need to open SMPlayer and be happy. If this sounds weird, it's because SMPlayer is just a frontend (graphic interface) for the video-engine player, that can be MPlayer or Mpv.

Post Reply