usm inconsistency

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
franbcki
White ninja
White ninja
Posts: 7
Joined: 23 Jan 2017, 15:47
Distribution: Porteus 3.2 32bit
Location: Buenos Aires

usm inconsistency

Post#1 by franbcki » 26 Feb 2017, 04:22

So, I don't know if this is a bug or some kind of blatantly obvious mistake I made.

Let's say I do a package search with usm:

Code: Select all

# usm -s pdfview

epdfview-0.1.8-i486-2_slonly.txz was found in slackonly [not installed]
qpdfview-0.4.16-i486-1_slonly.txz was found in slackonly [not installed]
epdfview-0.1.8-i586-3gv.txz was found in salix [not installed]
Packages found:   3 
Now I do:

Code: Select all

# usm -g pdfview

 Nothing found for:  pdfview 
What is going on? Is this the expected behavior? Curiously enough, I can try to build them from source with the -b option, but it's rather difficult to make it work with all the dependencies.

EDIT: And yes, I ran

Code: Select all

# usm -u all
before this.

User avatar
Ed_P
Contributor
Contributor
Posts: 3201
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: usm inconsistency

Post#2 by Ed_P » 26 Feb 2017, 05:23

franbcki wrote:Now I do:

Code: Select all

# usm -g pdfview

 Nothing found for:  pdfview 
What happens if you use:

Code: Select all

# usm -g epdfview

or

# usm -g qpdfview
Or if you use the USM GUI and search for pdfview?

:)
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: usm inconsistency

Post#3 by Bogomips » 26 Feb 2017, 13:20

Database out of sync. Has been for a few days now.

Code: Select all

root@porteus:/home/guest# usm -s conky

conky-1.10.6-x86_64-1ponce.txz was found in ponce [not installed]
conky-manager-r136-x86_64-3_slonly.txz was found in slackonly [not installed]
conkyforecast-2.24-noarch-4_slonly.txz was found in slackonly [not installed]
conky-1.10.5-x86_64-1_slonly.txz was found in slackonly [not installed]
Packages found:   4 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/home/guest# usm -g conky

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) conky-1.9.0-x86_64-1ponce.txz
2) conky-1.9.0-x86_64-2dj.txz
3) conky-1.9.0-x86_64-3sl.txz
4) conky-1.9.0-x86_64-5_slack.txz
5) conky-manager-2.3.3-x86_64-1_slack.txz
6) conkyforecast-2.24-noarch-4_slack.txz
On 64 bit at moment, could not test 32 bit:

Code: Select all

root@porteus:/home/guest# usm -g epdfview

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) epdfview-0.1.8-x86_64-2_slack.txz
2) epdfview-0.1.8-x86_64-2gv.txz
#? 2

Processing:   epdfview-0.1.8-x86_64-2gv.txz 
Ignored libraries: 

Libraries required:  27
Libraries found in system: 27
Libraries to resolve: 0



 The following packages are required. 
epdfview-0.1.8-x86_64-2gv.txz [] [not installed]

Total size: 0 KB
Uploaded 32 bit: viewtopic.php?f=51&p=53354&sid=d25b395f ... 8fa#p53354
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
normalGuy
Black ninja
Black ninja
Posts: 48
Joined: 06 Nov 2015, 23:36
Distribution: porteus 3.2 xfce archBang
Location: uk & portugal

Re: usm inconsistency

Post#4 by normalGuy » 26 Feb 2017, 15:47

Hi,
All working here!! :D

Code: Select all

root@porteus:/home/guest/Desktop# usm -g epdfview

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) epdfview-0.1.8-x86_64-2_slonly.txz
2) epdfview-0.1.8-x86_64-3gv.txz
#? 2

Processing:   epdfview-0.1.8-x86_64-3gv.txz 
Ignored libraries: 

Libraries required:  24
Libraries found in system: 24
Libraries to resolve: 0



 The following packages are required. 
epdfview-0.1.8-x86_64-3gv.txz [114K] [installed]

Total size: 114 KB
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.

 Updates are available. 
 Program update:   not required 
 Database update:  available 
 Please run:  usm -u all  and/or  usm -u usm 
 This message can be disabled in /etc/usm/usm.conf
 ############################### 
Downloading: epdfview-0.1.8-x86_64-3gv.txz  DONE

 Commencing package conversion ... 
Verifying package epdfview-0.1.8-x86_64-3gv.txz.
Installing package epdfview-0.1.8-x86_64-3gv.txz:
PACKAGE DESCRIPTION:
# epdfview (a PDF document viewer)
# 
# ePDFView is a free lightweight PDF document viewer using Poppler
# and GTK+ libraries.
# 
Executing install script for epdfview-0.1.8-x86_64-3gv.txz.
Package epdfview-0.1.8-x86_64-3gv.txz installed.

Creating /tmp/usm/epdfview-0.1.8-x86_64-3gv.xzm

 Enter a custom path to install packages to or press enter to install to the system: 
>
Installing to system

+==============================================================================
| Upgrading epdfview-0.1.8-x86_64-2jay package using /tmp/usm/epdfview-0.1.8-x86_64-3gv.txz
+==============================================================================

Pre-installing package epdfview-0.1.8-x86_64-3gv...

Removing package //var/log/packages/epdfview-0.1.8-x86_64-2jay-upgraded-2017-02-26,15:30:35...

Verifying package epdfview-0.1.8-x86_64-3gv.txz.
Installing package epdfview-0.1.8-x86_64-3gv.txz:
PACKAGE DESCRIPTION:
# epdfview (a PDF document viewer)
# 
# ePDFView is a free lightweight PDF document viewer using Poppler
# and GTK+ libraries.
# 
Executing install script for epdfview-0.1.8-x86_64-3gv.txz.
Package epdfview-0.1.8-x86_64-3gv.txz installed.

Package epdfview-0.1.8-x86_64-2jay upgraded with new package /tmp/usm/epdfview-0.1.8-x86_64-3gv.txz.

franbcki
White ninja
White ninja
Posts: 7
Joined: 23 Jan 2017, 15:47
Distribution: Porteus 3.2 32bit
Location: Buenos Aires

Re: usm inconsistency

Post#5 by franbcki » 26 Feb 2017, 16:07

Ok, yeah, trying for

Code: Select all

# usm -g epdfview

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) epdfview-0.1.8-i586-3gv.txz
Works, but not for "qpdfview"

I'm using the 32 bit version, so we have different repos maybe? How long will it take to sync them?

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: usm inconsistency

Post#6 by Bogomips » 26 Feb 2017, 16:12

^ Been able to update OK, but still not working here. Tried fastest-mirror, but still no joy. Suppose will have to wait for fix to propagate thru the mirrors.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Post Reply