Issues booting PK from USB

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
rans_au
White ninja
White ninja
Posts: 4
Joined: 24 Jan 2017, 21:58
Distribution: Porteus Kiosk
Location: Australia

Issues booting PK from USB

Post#1 by rans_au » 25 Jan 2017, 00:20

Hi,

I've encountered a strange issue with Porteus Kiosk (PK) ISO.

Have burnt the v4.2.0 ISO to USB, and it boots fine. Using the wizard, I've created an ISO which points to a remote configuration file. PK then applies that ISO back to the USB - this is where I'm encountering issues, but only on select PCs.

On reboot, I get a flashing cursor top left of screen (the one you see briefly on a normal boot) however the boot does not progress past this.
Strange thing is, if I use that same USB to boot on a different PC, it boots fine. So the issue seems to be hardware related.

So the problem PCs are all hp dc7800s - super old hardware, but what's available to us. Now the really weird thing is that I have one dc7800 that boots the PK USB fine.
Have tried comparing and matching all BIOS settings on PC that works with settings on PC that doesn't, no cigar.

I feel like this has to be BIOS/hardware related, however any suggestions at this stage would be appreciated.

Thanks in advance (fingers crossed),
rans.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Issues booting PK from USB

Post#2 by fanthom » 25 Jan 2017, 10:13

Hello Rans,

I have these suggestions:
1) try disabling UEFI component in the wizard or your remote config (remove uefi.zip from 'additional_components=' parameter).
2) try different usb stick
3) add this parameter 'kernel_parameters=debug' and show me a photo where booting hangs. You should see a lot of text scrolling on the screen when kernel initializes. You may test on working PC first to see the difference.

Please let us know if anything helped.

Thank you.
Please add [Solved] to your thread title if the solution was found.

rans_au
White ninja
White ninja
Posts: 4
Joined: 24 Jan 2017, 21:58
Distribution: Porteus Kiosk
Location: Australia

Re: Issues booting PK from USB

Post#3 by rans_au » 31 Jan 2017, 23:35

Thanks for your reply fanthom.

I have tried your suggestions, unfortunately they have not resolved the issue.
The kernel_parameters=debug setting did not show anything (just had a blinking cursor top left of screen as mentioned previously), which suggests to me the PC is not even attempting to boot. So I think we can fairly safely say this is not an issue with Porteus Kiosk, but a hardware issue.
I have used HDDs as a workaround, they're booting no problems, and changes made to the central config are being reflected in the kiosks.

Once again, thanks for your help, and thanks for putting together such an easy to use (and open source!) kiosk solution!

Regards,
rans_au

Post Reply