respawning too fast

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
User avatar
Ed_P
Contributor
Contributor
Posts: 3061
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

respawning too fast

Post#1 by Ed_P » 13 Dec 2016, 22:28

Booting ISO Cinnamon 3.2.1 64-bit with grub2. Got the following error msg:

Code: Select all

INIT: Id "x1" respawning too fast: disabled for 5 minutes.
I wait a few minutes then press Enter and it continued but I had to manually signon and start startx. Anyway to prevent this from happening? I don't have the problem booting the ISO with grub4dos.
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: respawning too fast

Post#2 by Bogomips » 14 Dec 2016, 00:02

^ Checked for a stale /tmp/.X0-lock?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3061
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: respawning too fast

Post#3 by Ed_P » 14 Dec 2016, 01:01

Code: Select all

guest@porteus:~$ ls /tmp
google-chrome/  pulse-PKdhtXMmr18n/
guest@porteus:~$ 
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: respawning too fast

Post#4 by Bogomips » 14 Dec 2016, 01:40

^ ls -a /tmp?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3061
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: respawning too fast

Post#5 by Ed_P » 14 Dec 2016, 04:28

Code: Select all

guest@porteus:~$ ls -a /tmp
./   .ICE-unix/  .X11-unix/  google-chrome/
../  .X0-lock    .esd-1000/  pulse-PKdhtXMmr18n/
guest@porteus:~$ 

Code: Select all

guest@porteus:~$ ls --help
Usage: /bin/ls [OPTION]... [FILE]...
List information about the FILEs (the current directory by default).
Sort entries alphabetically if none of -cftuvSUX nor --sort is specified.

Mandatory arguments to long options are mandatory for short options too.
  -a, --all                  do not ignore entries starting with .
Interesting.

But the original error referenced "x1" not "X0".

-update-

No "x1" here either.

Code: Select all

guest@porteus:~$ ls -a /mnt/live/memory/changes/tmp
./   .ICE-unix/  .X11-unix/  google-chrome/
../  .X0-lock    .esd-1000/  pulse-PKdhtXMmr18n/
guest@porteus:~$ ls -a /mnt/live/memory/images/changes/tmp
./   .ICE-unix/  .esd-1000/      pulse-PKdhtXMmr18n/
../  .X11-unix/  google-chrome/
guest@porteus:~$ 
Ed

jssouza
Samurai
Samurai
Posts: 172
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Re: respawning too fast

Post#6 by jssouza » 14 Dec 2016, 06:07

Hi Ed_P,

The Id x1 comes from the /etc/inittab file used by init when switching to runlevel 4 (X and the GUI).
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

...

# Runlevel 4 also starts /etc/rc.d/rc.4 to run a display manager for X.
# Display managers are preferred in this order: gdm, kdm, xdm
x1:4:respawn:/etc/rc.d/rc.4

User avatar
Ed_P
Contributor
Contributor
Posts: 3061
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: respawning too fast

Post#7 by Ed_P » 15 Dec 2016, 00:27

Thanks jssouza for the explanation.

Fortunately the error appears to be a one time thing. :Search:
Ed

donald
Full of knowledge
Full of knowledge
Posts: 1123
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: respawning too fast

Post#8 by donald » 15 Dec 2016, 01:54

Hi Ed
I have this too, 1 out of 10 boot up. :(
When i wait the 5 min. the system continues to boot normally.

User avatar
Ed_P
Contributor
Contributor
Posts: 3061
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: respawning too fast

Post#9 by Ed_P » 15 Dec 2016, 21:01

donald wrote:When i wait the 5 min. the system continues to boot normally.
I could be wrong but I'm pretty sure I pressed the Enter key before the 5 minutes were up and the booting continued.


-edit-

A related posting: viewtopic.php?f=117&t=6761&p=53882#p53882
Ed

Post Reply