Proxy required after installation

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
alt126
Ronin
Ronin
Posts: 2
Joined: 24 Nov 2016, 11:56
Distribution: 3.7.0
Location: Rome

Proxy required after installation

Post#1 by alt126 » 24 Nov 2016, 12:06

Hi all,

I don't know if it's a bug or a wrong configuration, but I have installed Porteus version 3.7.0 on two PC using a proxy during installation. The proxy isn't used for the main application URL configured in the browser and after the installation everything works. But this week I changed the password of proxy and then I see a popup on these PC with a username/password request for the proxy used in the installation. If I close the popup the navigation with the web application configured works without problem but every X minutes I have this popup.
I have also other two PC with the latest version of Porteus, installed using the same proxy, but the problem doesn't occur there. Anyone have an idea of the possible problem?

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Proxy required after installation

Post#2 by Bogomips » 24 Nov 2016, 12:15

Anyway welcome to Porteus. Someone knowledgeable should be along any moment now. :)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

jssouza
DEV Team
DEV Team
Posts: 353
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Re: Proxy required after installation

Post#3 by jssouza » 24 Nov 2016, 13:11

Is this on the Kiosk variant?

alt126
Ronin
Ronin
Posts: 2
Joined: 24 Nov 2016, 11:56
Distribution: 3.7.0
Location: Rome

Re: Proxy required after installation

Post#4 by alt126 » 24 Nov 2016, 14:14

Yes it's on Kiosk

jssouza
DEV Team
DEV Team
Posts: 353
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Re: Proxy required after installation

Post#5 by jssouza » 24 Nov 2016, 18:42

Mods please move this to kiosk section.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4620
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Proxy required after installation

Post#6 by fanthom » 24 Nov 2016, 19:43

Hello alt126,

Probably because latest kiosk release has following Firefox configuration parameter enabled by default:

Code: Select all

user_pref("signon.autologin.proxy", true);
Not sure if it would work for 3.7.0 (Firefox may be too old).
Please add [Solved] to your thread title if the solution was found.

Post Reply