How to autoconnect on a wifi network during boot?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
fulalas
DEV Team
DEV Team
Posts: 786
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

How to autoconnect on a wifi network during boot?

Post#1 by fulalas » 18 Nov 2016, 05:02

I've managed to save my wifi network password (creating a xzm module of /etc/NetworkManager/system-connections/), but after a reboot the wifi connection is down so I have to manually connect it every time (although it doesn't ask for the password anymore). So where's the folder/file that tells which wifi network should be connected during boot?

I'm using Porteus 3.2 final x64 kernel 4.8.8 + XFCE.

User avatar
FURRY_NOVA
Black ninja
Black ninja
Posts: 84
Joined: 11 Aug 2016, 17:26
Distribution: Porteus XFCE v3.2 i586
Location: United Kingdom

Re: How to autoconnect on a wifi network during boot?

Post#2 by FURRY_NOVA » 18 Nov 2016, 06:31

Sadly, it lost that functionality in a previous update. I attempted researching a terminal command to manually connect to mine, so I could embed it in my startup script. But I was unsuccessful since the terminal commands wouldn't connect to my WiFi.
New to Linux but learning. Hoping to help out Porteus community. :)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5576
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: How to autoconnect on a wifi network during boot?

Post#3 by brokenman » 18 Nov 2016, 20:04

Please right click on the network manager applet on the taskbar and choose to edit connection. Find your wifi connection and in the general tab tick the box that says "All users may connect to this network".

Now copy your network config from /etc/NetworkManager/system-connections/youConnection back into your rootcopy or make a module from it. Reboot and check that it auto connects.

Do you think this is a bug? It seems like a safe default to me.
How do i become super user?
Wear your underpants on the outside and put on a cape.

fulalas
DEV Team
DEV Team
Posts: 786
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: How to autoconnect on a wifi network during boot?

Post#4 by fulalas » 18 Nov 2016, 20:40

brokenman, thanks. I'll try this later. :)

I don't think it's a bug, but maybe not the best default. OK not saving the password by default. But saving the connection as a default one on the first connect (if there'is no other previously chosen) maybe is a better approach in my opinion. What you think?

User avatar
brokenman
Site Admin
Site Admin
Posts: 5576
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: How to autoconnect on a wifi network during boot?

Post#5 by brokenman » 18 Nov 2016, 20:50

Booting as a user (let's say guest) I would expect the connection to be saved and autoconnect at boot without having to allow other users access. I'm sure that was the default before. I'm not sure why it changed in this version of NetworkManager. It seems a bit buggy.
How do i become super user?
Wear your underpants on the outside and put on a cape.

fulalas
DEV Team
DEV Team
Posts: 786
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Re: How to autoconnect on a wifi network during boot?

Post#6 by fulalas » 19 Nov 2016, 05:49

I've managed to save the autoconnect option the way you told me. Thanks!

The other good news is that Asus wifi usb stick is working! :)

The problem now is that wifi takes a looooong time to start a connection or even sees the networks availables after boot. But if you manually create a new dummy connection then the real networks are found quickly. :(

Post Reply