Porteus Kiosk 4.1 on Intel NUC 6

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
PortAlpha
White ninja
White ninja
Posts: 4
Joined: 05 Nov 2016, 06:05
Distribution: Porteus kiosk 4.1
Location: Europe

Porteus Kiosk 4.1 on Intel NUC 6

Post#1 by PortAlpha » 07 Nov 2016, 09:41

Hello,

First, thanks to the development team for making this product!

We are a software company making software for interactive kiosks running as a web application in Chrome. We are experimenting with using Porteus Kiosk for locking the system.

There is a problem with the graphics: on a 5th generation NUC (Intel NUC 5CPYH) we could run PK in "portrait" mode without problems. Picture was perfect, touch automatically rotated the right way.
Now, when I run the PK wizard on a new (6th generation) NUC (6i3SYK) I can get PK to run, but several things don't work:
- I can't run it in portrait-mode: when testing the setup, screen goes black. Only the system messages form the wizard are visible (e.g. the countdown) but the chrome webpage is not visible. Alt-Tabbing around will sometimes show a part of this. Apparently, the GPU is not driven the right way.
- maybe connected with the previous problem, but the touch interface works "half": I can touch a button on the screen, but I can't swipe (our app uses a lof of swiping). I can test when using PK in landscape mode.

What can we do to make it work?
- using Porteus Kiosk release 4.1
- tried KMS and VESA to no avail (no image)

I have to say I am not a Linux expert, I am just able to run the wizard and get that to work. Or used to get that working ;-)

User avatar
fanthom
Site Admin
Site Admin
Posts: 4620
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk 4.1 on Intel NUC 6

Post#2 by fanthom » 07 Nov 2016, 10:02

Hello PortAlpha,

Please enable free trial of the automatic updates and check if latest code resolves the problem. If yes then you need to wait for next public kiosk release (December/January) or buy a custom build with latest system revision which has upgraded Xorg and drivers:
http://porteus-kiosk.org/builds.html
http://porteus-kiosk.org/changelog-auto ... tml#161023

If free trial does not resolve the issues then kernel upgrade to version 4.8.x may be necessary (custom build again).

Thank you.
Please add [Solved] to your thread title if the solution was found.

PortAlpha
White ninja
White ninja
Posts: 4
Joined: 05 Nov 2016, 06:05
Distribution: Porteus kiosk 4.1
Location: Europe

Re: Porteus Kiosk 4.1 on Intel NUC 6

Post#3 by PortAlpha » 07 Nov 2016, 10:32

...and that works! Although the implementation of the driver seems a bit shaky, it shows some artifacts, but that will probably improve over time.

Thanks for your quick service. We will be looking into remote management next. Looks promising ;-)

PortAlpha
White ninja
White ninja
Posts: 4
Joined: 05 Nov 2016, 06:05
Distribution: Porteus kiosk 4.1
Location: Europe

Re: Porteus Kiosk 4.1 on Intel NUC 6

Post#4 by PortAlpha » 07 Nov 2016, 12:03

Strange things happening: at first it worked.

Now, after a resetting the NUC, without a rebuild, the touch works "half" again: swiping does not work anymore.
Changing the config and having the PK rebuild again does not solve this.

Is this a driver problem?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4620
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk 4.1 on Intel NUC 6

Post#5 by fanthom » 08 Nov 2016, 09:19

Hello PortAlpha,

Perhaps kernel upgrade will be necessary? Please boot latest Ubuntu and check if touch works correctly on it.

If yes then please download and run this script: http://porteus-kiosk.org/public/files/debug.sh

Code: Select all

sudo sh debug.sh
Please send me generated report to support@porteus-kiosk.org and link this thread.

If Ubuntu does not work correctly then i see no hope for this hardware until upstream fix things (could take months).

Thank you.
Please add [Solved] to your thread title if the solution was found.

PortAlpha
White ninja
White ninja
Posts: 4
Joined: 05 Nov 2016, 06:05
Distribution: Porteus kiosk 4.1
Location: Europe

Re: Porteus Kiosk 4.1 on Intel NUC 6

Post#6 by PortAlpha » 11 Nov 2016, 09:45

Hi,

Something odd is happening:
- We use chrome for our web app: when using firefox, everything is OK and the touch works 100%.
- When removing the persistence setting from the config or use no persistence (=none), everything works 100%. We needed to save the login credentials on our web app page, so persistence was set to full.
- When setting persistence to full but using google.com as startup page and then go to our web app, the web app touch works 100%. All using Chrome browser.

From what we can see on our servers, Porteus Kiosk only downloads the webpage once when persistence=full, without reloading it after a restart of the hardware Is that correct?

Apparently, this strange behavior of the swipe-touch control seems to be a Chrome and/or implementation issue on our side, but rather cryptic.

If necessary, we can mail the debug log you requested earlier but I'm not sure if that sheds a brighter light on this.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4620
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk 4.1 on Intel NUC 6

Post#7 by fanthom » 11 Nov 2016, 10:53

Hello PortAlpha,

I have seen similar issue on another website: touch behaved differently with persistence enabled and disabled. I still dont know why ...
The solution was to create a custom build with cookies hardcoded into ISO and keep persistence disabled.

Please contact me through builds@porteus-kiosk.org if you are interested.

Thank you.
Please add [Solved] to your thread title if the solution was found.

Post Reply