Cannot set Keyboard Layout

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
jmbmichael
White ninja
White ninja
Posts: 8
Joined: 26 Jan 2015, 19:21
Distribution: Porteus Kiosk
Location: OK

Cannot set Keyboard Layout

Post#1 by jmbmichael » 11 Oct 2016, 20:33

I'm trying to run Kiosk 4.1 on some Asus EEE netbooks but I cannot get the Keyboard layout to stick. I can set it as soon as it boots and it works for the wifi setup but as soon as I get to the configuration page it's back to whatever the default is which types some numbers instead of letters. I connected an external keyboard and it worked fine so I went through the config and set the Primary Keyboard layout to US but as soon as it rebooted it was back to the other keyboard layout. Is there any fix for this or am I stuck not being able to use it on these devices?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Cannot set Keyboard Layout

Post#2 by fanthom » 12 Oct 2016, 07:08

Hello jmbmichael,

I cant recreate this issue.

1) Please tell me the layout you set in the network wizard
2) Do you have primary_keyboard_layout= parameter in your kiosk config?
http://porteus-kiosk.org/parameters.htm ... ard_layout

Thank you.
Please add [Solved] to your thread title if the solution was found.

jmbmichael
White ninja
White ninja
Posts: 8
Joined: 26 Jan 2015, 19:21
Distribution: Porteus Kiosk
Location: OK

Re: Cannot set Keyboard Layout

Post#3 by jmbmichael » 12 Oct 2016, 14:16

1. I set the keyboard layout to English(US) on the Network setup wizard and that allows me to configure the wifi.
2. In the kiosk config I set the primary and secondary to English(US), but within the kiosk config the keyboard layout has already reverted back to something else so I'm unable to configure anything that requires the keyboard unless I plug in a usb keyboard.

connection=wifi
network_interface=wlan0
dhcp=yes
primary_keyboard_layout=us
browser=firefox
dpms_idle=15
session_idle=30
secondary_keyboard_layout=us
scheduled_action=Monday-18:00 Tuesday-18:00 Wednesday-18:00 Thursday-18:00 Friday-18:00 Saturday-18:00 Sunday-18:00 action:halt
allow_popup_windows=yes
right_mouse_click=yes
shutdown_combination=yes
volume_level=100%
timezone=America/Chicago
zRAM=30%
additional_components=uefi.zip 07-java.xzm 05-flash.xzm

jmbmichael
White ninja
White ninja
Posts: 8
Joined: 26 Jan 2015, 19:21
Distribution: Porteus Kiosk
Location: OK

Re: Cannot set Keyboard Layout

Post#4 by jmbmichael » 12 Oct 2016, 15:14

I found that by setting both the primary and secondary keyboard I can now do ctrl+spacebar and it says "Keyboard now changed to US Default..." and it works fine until the next reboot, but this is going to throw off my users. I don't understand why it's not being set as the Default from the beginning.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Cannot set Keyboard Layout

Post#5 by fanthom » 12 Oct 2016, 15:17

As mentioned on the very first page of the wizard the English (US) is default layout in kiosk so please skip setting up primary/secondary layouts completely and remove relevant parameters from kiosk config.
Setting up primary and secondary layouts to the same value is probably whats confusing our system (you need secondary layout only when its different than primary).

Thanks.
Please add [Solved] to your thread title if the solution was found.

jmbmichael
White ninja
White ninja
Posts: 8
Joined: 26 Jan 2015, 19:21
Distribution: Porteus Kiosk
Location: OK

Re: Cannot set Keyboard Layout

Post#6 by jmbmichael » 12 Oct 2016, 23:33

I'll try that in the morning but the first try all I set was the Primary to US and it didn't work either. If US is the default shouldn't it work during the kiosk config wizard?

jmbmichael
White ninja
White ninja
Posts: 8
Joined: 26 Jan 2015, 19:21
Distribution: Porteus Kiosk
Location: OK

Re: Cannot set Keyboard Layout

Post#7 by jmbmichael » 14 Oct 2016, 18:55

I just tried it with no keyboard layout settings and it's still not using the correct layout. For instance instead of typing an j,k, or L I get 1,2 and 3.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Cannot set Keyboard Layout

Post#8 by fanthom » 14 Oct 2016, 20:16

Please boot Ubuntu live CD on this PC, confirm that keyboard layout is ok then post the output of 'setxkbmap -query' command.

Thanks.
Please add [Solved] to your thread title if the solution was found.

Post Reply