Porteus Kiosk ThinClient (Remmina)

New features which should be implemented in Porteus Kiosk Edition and the kiosk wizard.
Post Reply
SVblue
Ronin
Ronin
Posts: 3
Joined: 29 Aug 2016, 13:04
Distribution: Thin Client and Kiosk
Location: Germany

Porteus Kiosk ThinClient (Remmina)

Post#1 by SVblue » 29 Aug 2016, 13:13

Is it possible to setup a rdp-Connection (Remmina) within the startup-config.txt of Porteus? (maybe also set to autostart this rdp-Connection)
Actually I've to Setup the rdp-Config after every reboot.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk ThinClient (Remmina)

Post#2 by fanthom » 29 Aug 2016, 13:59

Hello SVblue,

"Is it possible to setup a rdp-Connection (Remmina) within the startup-config.txt of Porteus?"
This is not possible at the moment.

"Actually I've to Setup the rdp-Config after every reboot."
Please enable full persistence for the session and Remmina all settings will be remembered.

If you need plain GUI with just rdesktop session which automatically opens on specific URL (configurable through the kiosk config) then custom build will be necessary:
porteus-kiosk.org/builds.html

Thank you.
Please add [Solved] to your thread title if the solution was found.

SVblue
Ronin
Ronin
Posts: 3
Joined: 29 Aug 2016, 13:04
Distribution: Thin Client and Kiosk
Location: Germany

Re: Porteus Kiosk ThinClient (Remmina)

Post#3 by SVblue » 30 Aug 2016, 08:37

Thanks.

connecting to Windows 7-PC via rdp is now working - "enable full persistence" solved the Problem.

BUT:
The keyboard does not work in windows-session. [CRTL-R] doesn't help.

I've tried several keyboard-language-settings but nothing works!

???

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk ThinClient (Remmina)

Post#4 by fanthom » 30 Aug 2016, 08:42

"The keyboard does not work in windows-session. [CRTL-R] doesn't help.
I've tried several keyboard-language-settings but nothing works!"
This bug is resolved in the automatic updates channel already. Please enable free trial or wait about 2 weeks for new kiosk version to go public.

Thank you.
Please add [Solved] to your thread title if the solution was found.

Post Reply