Connman problems...

Technical issues/questions of an intermediate or advanced nature.
fullmoonremix

Connman problems...

Post#1 by fullmoonremix » 19 Aug 2016, 13:53

I deprecated NetworkManager in favor of ConnMan .

When entering...

Code: Select all

connmanctl scan wifi
I get this error...

Code: Select all

/net/connman/technology/wifi : not supported
I've seached the "Net" but I'm not making progress. Does anyone know the solution?
If anyone knows what's behind this issue... I welcome any and all outreach.
Last edited by fullmoonremix on 02 Oct 2016, 17:35, edited 3 times in total.

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Connman problems...

Post#2 by jmhoward56 » 19 Aug 2016, 14:53

Do you have wpa_supplicant installed, it is an optional dependency for wifi support as is bluez if you want bluetooth support. Only other thing I see is the need to disable any other network configurations before enabling the service.

fullmoonremix

Re: Connman problems...

Post#3 by fullmoonremix » 19 Aug 2016, 16:45

Thanks... jmhoward56. I have bluez and wpa_supplicant installed and NetworkManager is removed.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Connman problems...

Post#4 by brokenman » 19 Aug 2016, 21:37

My thoughts.

1) Make sure the connman service is started first.
2) Check permissions on dbus-daemon-launch-helper.
How do i become super user?
Wear your underpants on the outside and put on a cape.

fullmoonremix

Re: Connman problems...

Post#5 by fullmoonremix » 19 Aug 2016, 21:46

Thanks... brokenman

Yes connmand was started in /etc/rc.d/rc.local...

Code: Select all

# summon connman daemon...
connmand

# wifi
connmanctl enable wifi
This is my /etc/wpa_supplicant.conf...

Code: Select all

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root

# In order to get wpa_supplicant and Connection Manager working properly
# together you should edit wpa_supplicant .config file and set:

CONFIG_WPS=y
CONFIG_AP=y
CONFIG_CTRL_IFACE_DBUS_NEW=y

# add:

CONFIG_BGSCAN_SIMPLE=y

# This last option will enable the support of background scanning while being
# connected, which is necessary when roaming on wifi.

# and finally:

CONFIG_AUTOSCAN_EXPONENTIAL=y

# This will enable the exact same function as bgscan but while being
# disconnected.

# It is recommended to use wpa_supplicant 1.x or later.

# If wpa_supplicant is configured to D-Bus autostart, then ConnMan will
# trigger the autostart of wpa_supplicant. However please keep in mind
# that this trigger only happens once. If wpa_supplicant stops or crashes,
# ConnMan does not periodically try to autostart it. It is up to systemd or
# similar service management tool to autostart it.


I'm not sure about how to check permissions on dbus-daemon-launch-helper.
Also... in Slackware what is the wpa_supplicant.conf referenced "service management tool"?

fullmoonremix

Re: Connman problems...

Post#6 by fullmoonremix » 28 Aug 2016, 17:05

Ok... now that I've resolved (half of?) my 001-core.xzm deprecation
issues I can refocus on getting Connman up and running.

Perhaps the problem is that I may still have a NetworkManager configuration lingering in my loadout.

I will drill down on this @ some point this afternoon.
I may need to create a null configuration to overwrite it.


Posted by 73.112.16.173 via http://webwarper.net
This is added while posting a message to avoid misusing the service

Jack
Contributor
Contributor
Posts: 1063
Joined: 09 Aug 2013, 14:25
Distribution: Porteus 3.2.rc5 Mate 64 bit
Location: Marysville, OHIO USA

Re: Connman problems...

Post#7 by Jack » 28 Aug 2016, 18:11

Will this module or program setup WiFi? Here is my output.

Code: Select all

root@porteus:/home/guest/Downloads# connmanctl scan wifi
Error /net/connman/technology/wifi: The name net.connman was not provided by any .service files
root@porteus:/home/guest/Downloads# connmanctl enable wifi
Error wifi: The name net.connman was not provided by any .service files
root@porteus:/home/guest/Downloads# 
I just like Slackware because I think it teach you about Linux to build packages where Ubuntu is like Windows you just install programs you want.

fullmoonremix

Re: Connman problems...

Post#8 by fullmoonremix » 28 Aug 2016, 19:28

I deprecated NM but left the config. I need to make a null one. I suspect... what
this is boils down to a remaining NetworkManager installation/configuration.

There is a (forked?) Connman compatibility parameter for NM apps...
@ https://github.com/ev3dev/connman

--enable-nmcompat

Enable support for NetworkManager compatibility interfaces

This allows to expose a minimal set of NetworkManager
interfaces. It is useful for systems with applications
written to use NetworkManager to detect online/offline
status and have not yet been converted to use ConnMan.
Posted by 73.112.16.173 via http://webwarper.net
This is added while posting a message to avoid misusing the service

fullmoonremix

Re: Connman problems...

Post#9 by fullmoonremix » 29 Aug 2016, 14:36

P: _I'm not sure if this is related but @ boot I get this error...

Code: Select all

Unknown group "network" in message bus file
S: _???...@ https://forums.freebsd.org/threads/7979/
Delete them from /etc/passwd and use `vipw` and add them (`env EDITOR=ee vipw` if you are not familar with vi).

Posted by 73.112.17.110 via http://webwarper.net
This is added while posting a message to avoid misusing the service

fullmoonremix

Re: Connman problems...

Post#10 by fullmoonremix » 30 Aug 2016, 11:23

I made a null NetworkManager config but I'm still getting errors.

Posted by 73.112.17.110 via http://webwarper.net
This is added while posting a message to avoid misusing the service

fullmoonremix

Re: Connman problems...

Post#11 by fullmoonremix » 30 Aug 2016, 19:48

P: _I'm convinced this error is behind the problem...

Code: Select all

Unknown group "network" in message bus file
Q: _Could the solution be found in the Porteus scripts?

If I can solve the Connman puzzle and get it up and running I can finally complete this project.


Posted by 73.112.19.112 via http://webwarper.net
This is added while posting a message to avoid misusing the service

fullmoonremix

Re: Connman problems...

Post#12 by fullmoonremix » 30 Aug 2016, 20:58

I removed the net-tools package from 001-core.xzm but I don't believe that it is the bottleneck.

Posted by 73.112.19.112 via http://webwarper.net
This is added while posting a message to avoid misusing the service

fullmoonremix

Re: Connman problems...

Post#13 by fullmoonremix » 01 Sep 2016, 16:33

Ok... for the sake of expediency I am breaking off from resolving Connman.
Instead unfortunately (without the aid of USM)... I will finish the derivative by hand (the Arch Linux "way").


Already I have achieved the following (by hand)...

001-core.xzm
(more or less... 001-core.xzm "rc5" with all the modules removed)

Deprecating... 002 and 003.

04-userland.xzm
(using the Arch Linux "way"... glibc "tree" + MC + Connman + USM + Linux From Scratch )

05-distribution.xzm
(more or less... 001-core.xzm "v1.0" minus 04-userland.xzm modules)


Regrettably I am now forced to build by hand...

06-environment.xzm
(Qingy + PekWM + Xfe + Tint)


The current state of my build... confirms I'm no stranger to building w/out automation.
What this means is... I'm not holding my breath waiting to solve Connman.

The Connman stage of the derivative now goes on the back burner.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Connman problems...

Post#14 by brokenman » 02 Sep 2016, 02:45

P: _I'm convinced this error is behind the problem...
Unknown group "network" in message bus file


Really fullmoon! What is this error message telling you?
How do i become super user?
Wear your underpants on the outside and put on a cape.

fullmoonremix

Re: Connman problems...

Post#15 by fullmoonremix » 02 Sep 2016, 05:03

I can't pinpoint it yet... but there appears to be a problem it seems in /etc/password and/or with dbus as you indicated.
Check permissions on dbus-daemon-launch-helper
I'm not sure how to do this...


Posted by 73.112.18.225 via http://webwarper.net
This is added while posting a message to avoid misusing the service

Post Reply