ALSA

Добро пожаловать!

Moderator: Blaze

Post Reply
upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

ALSA

Post#1 by upv » 15 Jul 2016, 20:43

В Porteus 3.2rc были вырезаны утилиты настройки ALSA(alsamixer и amixer).Хотелось бы узнать есть ли способы управлять Alsa без них?

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: ALSA

Post#2 by Bogomips » 15 Jul 2016, 21:45

Code: Select all

su
alsactl restore
и.т.д.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

Re: ALSA

Post#3 by upv » 16 Jul 2016, 10:24

Можно конкретизировать "т.д."?

Code: Select all

root@porteus:/home/guest# alsactl restore
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: No such file or directory
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "VIA VT1705" "HDA:11064397,101905b3,00100000" "0x1019" "0x05b3"
Hardware is initialized using a generic method
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "Nvidia Generic" "HDA:10de0041,156911c6,00100100" "0x1569" "0x11c6"
Hardware is initialized using a generic method

User avatar
Blaze
Moderator
Moderator
Posts: 1358
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: ALSA

Post#4 by Blaze » 16 Jul 2016, 11:36

Здравствуйте, upv.
Какую точно Вы используете версию Porteus 3.2 (rc2. rc3 или rc4)?

PulseAudio работает некорректно (нет звука)?

Если ввести команду

Code: Select all

pulseaudio
то что выдает?
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

Re: ALSA

Post#5 by upv » 16 Jul 2016, 11:53

rc4
Да нет звука

Code: Select all

root@porteus:/home/guest# pulseaudio 
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authentication key '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authentication key '/root/.pulse-cookie': No such file or directory
W: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
W: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files
потом

Code: Select all

guest@porteus:~$ pulseaudio 
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

User avatar
Blaze
Moderator
Moderator
Posts: 1358
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: ALSA

Post#6 by Blaze » 16 Jul 2016, 12:18

upv, попробуйте так:

Code: Select all

rm -r ~/.config/pulse*; pulseaudio -k
pulseaudio --kill
pulseaudio --start
у меня что-то подобное было, я решил проблему так см. это сообщение (пункт 1. PulseAudio in Cinnamon RC4 does not play sound and I don't see a sound applet in the tray at the right corner.)
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

Re: ALSA

Post#7 by upv » 16 Jul 2016, 12:45

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# rm -r ~/.config/pulse*; pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such process
root@porteus:/home/guest# pulseaudio --kill
E: [pulseaudio] main.c: Failed to kill daemon: No such process
root@porteus:/home/guest# pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {3a1ba190dd5e9ed43a9c8a6c578a516a}unix:/tmp/pulse-PKdhtXMmr18n/native, refusing to start/autospawn.
root@porteus:/home/guest# rm -r ~/.config/pulse*; pulseaudio -k

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: ALSA

Post#8 by Bogomips » 16 Jul 2016, 13:20

upv wrote:Можно конкретизировать "т.д."?
При 3.2:

Code: Select all

alsactl   [ -f  <сохраненный файл>.state ]   restore
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

Re: ALSA

Post#9 by upv » 16 Jul 2016, 14:26

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# alsactl store
root@porteus:/home/guest# kwrite /var/lib/alsa/asound.state 
Изменил нужный параметр

Code: Select all

root@porteus:/home/guest# alsactl restore
Звук есть.Другй вопрос незная в чем причина осусвия звука без alsamixer можно чень долго редактировать asound.state (часами(((()

User avatar
Blaze
Moderator
Moderator
Posts: 1358
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: ALSA

Post#10 by Blaze » 16 Jul 2016, 16:40

upv, в Always Fresh mode проблема со звуком так же присутствует?
Введите там

Code: Select all

su
toor
pulseaudio
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

Re: ALSA

Post#11 by upv » 16 Jul 2016, 19:19

все дело в параметре 'Auto-Mute Mode' который по умолчанию включен и звук не выводится((( и из PA его изменить нельзя

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: ALSA

Post#12 by Bogomips » 16 Jul 2016, 20:48

upv wrote:все дело в параметре 'Auto-Mute Mode' который по умолчанию включен и звук не выводится(((
Спасибо за фидбак. А интересно, что у меня звук есть, несмотря на то, что asound.state

Code: Select all

	control.20 {
		iface MIXER
		name 'Auto-Mute Mode'
		value Enabled
		comment {
			access 'read write'
			type ENUMERATED
			count 1
			item.0 Disabled
			item.1 Enabled
		}
	}
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

upv
White ninja
White ninja
Posts: 15
Joined: 15 Jun 2016, 21:22
Distribution: Porteus KDE,Lubuntu
Location: Belarus

Re: ALSA

Post#13 by upv » 16 Jul 2016, 22:34

Все полностью разобрался,вероятно неправильно распаяна передняя аудио панель, после ее отключения звук работает без ковыряния в ALSA
Всем спасибо.

Post Reply