Porteus-v3.2rc4 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
Slaxmax
Contributor
Contributor
Posts: 403
Joined: 03 Jan 2013, 09:51
Distribution: KDE4
Location: Campinas Brazil https://goo.gl/yrxwKi

Re: Porteus-v3.2rc4 bug reports

Post#76 by Slaxmax » 16 Jul 2016, 23:10

thx jack

rc4 kde5 x86_64
1- missing icons (gwenview, firefox, krdc, krfb, porteus faq, usm, vbox builder, create liveusb, UXterm, Kcharselect, SSH askpass, gftp, xzm icon, folder icon, etc...)
2- dolphin in menu bar not retentive option (edit)
3- update-firefox make a module with restrictive pemissions to copy as guest
4- google chrome not start
5- bluettoth fail
[ 10.088234] Bluetooth: Patch file not found ar3k/AthrBT_0x31010000.dfu
[ 10.088234] Bluetooth: Loading patch file failed
[ 10.088238] ath3k: probe of 1-7:1.0 failed with error -2
6- automount disable
“DNA is like a computer program but far, far more advanced than any software ever created.”
― Bill Gates, The Road Ahead

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Porteus-v3.2rc4 bug reports

Post#77 by Bogomips » 16 Jul 2016, 23:27

Slaxmax wrote:4- google chrome not start
Tried Run: /opt/google/chrome/chrome ?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3150
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Porteus-v3.2rc4 bug reports

Post#78 by Ed_P » 16 Jul 2016, 23:53

A plan B to circumvent the save.dat root signon problem.

Code: Select all

#!/bin/bash

# Save key 3.2 changes as a mod file 

# Color definitions
txtbld=$(tput bold)               # Bold
txtred=${txtbld}$(tput setaf 1)   # Red
rst=$(tput sgr0)                  # Reset

function redpswd() {
  echo -e "$1" $txtred  
}

if [ `whoami` != "root" ]; then
    redpswd "Enter root's password"
    su -c "sh $0 $1"
    exit
fi
echo $rst

if [ -d /tmp/mod/ ]; then
   rm -rf /tmp/mod
fi
mkdir -p /tmp/mod

# copy modified files
cp -a --parents    /home/guest/.config/nemo/*                     /tmp/mod/
cp -a --parents    /home/guest/.config/gtk-3.0/*                  /tmp/mod/
cp -a --parents    /home/guest/.config/dconf/*                    /tmp/mod/
cp -a --parents    /home/guest/.cache/dconf/*                     /tmp/mod/
cp -a --parents    /home/guest/*                                  /tmp/mod/

cp -a --parents    /home/guest/.mozilla/firefox/dxsqumip.default/places.sqlite    /tmp/mod/
cp -a --parents    /home/guest/.mozilla/firefox/dxsqumip.default/prefs.js         /tmp/mod/
#cp -a --parents    /home/guest/.mozilla/firefox/dxsqumip.default/signons.sqlite   /tmp/mod/

cp -a --parents    /etc/NetworkManager/system-connections/*      /tmp/mod/

du -h /tmp/mod/

echo
echo Press Enter to create module, Ctrl+C to end.
read

dir2xzm /tmp/mod /tmp/mychanges.xzm   &&   rm -rf /tmp/mod

echo 
ls -sh  /tmp/*.xzm
echo 
Ed

User avatar
Slaxmax
Contributor
Contributor
Posts: 403
Joined: 03 Jan 2013, 09:51
Distribution: KDE4
Location: Campinas Brazil https://goo.gl/yrxwKi

Re: Porteus-v3.2rc4 bug reports

Post#79 by Slaxmax » 17 Jul 2016, 00:03

Bogomips wrote:
Slaxmax wrote:4- google chrome not start
Tried Run: /opt/google/chrome/chrome ?
I have tested it. Not show any message in terminal.

KDE5 poor performance with all effects disable.
gpu lspci info

Code: Select all

04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun LE [Radeon HD 8550M / R5 M230] (rev ff) (prog-if ff)
        !!! Unknown header type 7f
        Kernel driver in use: radeon
        Kernel modules: radeon
 
glxinfo (direct rendering: Yes) but..
(0x0b3 24 dc 0 24 0 r y . 8 8 8 0 . . 0 24 8 16 16 16 0 0 0 Slow) Slow performance?

thx
“DNA is like a computer program but far, far more advanced than any software ever created.”
― Bill Gates, The Road Ahead

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Porteus-v3.2rc4 bug reports

Post#80 by Bogomips » 17 Jul 2016, 00:49

Slaxmax wrote:
Bogomips wrote:
Slaxmax wrote:4- google chrome not start
Tried Run: /opt/google/chrome/chrome ?
I have tested it. Not show any message in terminal.
This works in Cinnamon, made from Update Script, but gave system crash in kde5, but mainly due to not having enough ram. If you have enough ram this google chrome should work in kde.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Blaze
Moderator
Moderator
Posts: 1383
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#81 by Blaze » 17 Jul 2016, 07:20

Slaxmax wrote:6- automount disable
Can you test this

Code: Select all

sed -i 's/async/comment=x-gvfs-show,async/' /etc/fstab
in KDE5?

Cheers
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
Slaxmax
Contributor
Contributor
Posts: 403
Joined: 03 Jan 2013, 09:51
Distribution: KDE4
Location: Campinas Brazil https://goo.gl/yrxwKi

Re: Porteus-v3.2rc4 bug reports

Post#82 by Slaxmax » 17 Jul 2016, 16:40

Blaze in kde options show automount disable
“DNA is like a computer program but far, far more advanced than any software ever created.”
― Bill Gates, The Road Ahead

alexgorr
White ninja
White ninja
Posts: 20
Joined: 23 Nov 2011, 12:48
Location: italy

Re: Porteus-v3.2rc4 bug reports

Post#83 by alexgorr » 18 Jul 2016, 07:06

Before all Thanks for your work !
I noticed a few things.
1) python seems not working. I've check on /var/log/packages file list but files are not present . I've resolved all dependencies using this packages (2 there were already, but they appeared broken)
dbus-python-1.2.4-x86_64-1.xzm,notify-python-0.1.1-x86_64-5.xzm,pycairo-1.10.0-x86_64-1.xzm,pycups-1.9.73-x86_64-1.xzm,pygobject3-3.18.2-x86_64-1.xzm,pygobject-2.28.6-x86_64-2.xzm,pygtk-2.24.0-x86_64-2.xzm,python-2.7.11-x86_64-2.xzm
2) alsamixer does not start. I've read that now is used pulseaudio. Is alsamixer necessary again ?
3) A strange thing happens to me with virtualbox. If I use bridged adapter network goed down. Using NAT all seems working fine.
4) /dev/ppp is not created by default (in the previuos version it was) I don't know if it is a bug ....
Last edited by alexgorr on 01 Aug 2016, 08:21, edited 1 time in total.

User avatar
wread
Module Guard
Module Guard
Posts: 1064
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#84 by wread » 18 Jul 2016, 18:05

@alexgorr
Python is contained in 07-printing;
in a console, try "#ldd /usr/bin/alsamixer" to see if you are missing some libraries.
Pulseaudio is not a substitue of alsamixer...

Good luck!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
wread
Module Guard
Module Guard
Posts: 1064
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#85 by wread » 18 Jul 2016, 18:25

@Slaxmax
5- bluettoth fail
Do you have /etc/rc.d/rc.bluetooth installed? Is it executable?

Good luck!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
wread
Module Guard
Module Guard
Posts: 1064
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#86 by wread » 18 Jul 2016, 18:43

@Slaxmax
1- missing icons (gwenview, firefox, krdc, krfb, porteus faq, usm, vbox builder, create liveusb, UXterm, Kcharselect, SSH askpass, gftp, xzm icon, folder icon, etc...)
Is your shared-mime-info ok? Is it patched for xzm, Porteus, etc?
Look in /usr/share/mime/packages/freedesktop.org.xml; try to find ".xzm"

Regards!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

jmhoward56
Black ninja
Black ninja
Posts: 37
Joined: 08 Dec 2011, 19:28
Location: USA

Re: Porteus-v3.2rc4 bug reports

Post#87 by jmhoward56 » 19 Jul 2016, 02:37

@alexgorr
Which version of 3.2rc4 are you using for the missing python modules?

porteus-v3.2rc4 is based on slackware 14.2 and many things have changed. I would not recommend using the old packages from v3.1. There is a new command to retrieve packages from slackware called "getpkg". Read some of the earlier posts for use. There is also usm, I believe it is now pointing to the slackware 14.2 repositories in rc4. The cinnamon version also is using both python 2 and the new python 3 which was developed for gtk3 this is why I asked which version. Pulseaudio is new in slackware 14.2 as is eudev, it is also using a 4.6.x kernel.

rchase
Samurai
Samurai
Posts: 154
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Porteus-v3.2rc4 bug reports

Post#88 by rchase » 19 Jul 2016, 03:25

Still no luck integrating Faenza icons into x86_64 XFCE rc4 -- on an old Toshiba Satellite; weirdly, it seems specific to this machine. I tried making a module out of /usr/share/icons/Faenza* out of x86_64 XFCE rc3, but booting with it in /porteus/modules leaves me with almost no icons (selecting different icons in Appearance has no effect).

May brokenman return to Porteus soon, may rc4 be perfectable, and may it become an official release soon -- or is it not to be?

Bogomips
Full of knowledge
Full of knowledge
Posts: 2536
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Porteus-v3.2rc4 bug reports

Post#89 by Bogomips » 19 Jul 2016, 10:33

jmhoward56 wrote:There is also usm, I believe it is now pointing to the slackware 14.2 repositories in rc4.
Not yet. Have to wait for brokenman to sort out the repositories. viewtopic.php?f=117&t=6021#p46874
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Blaze
Moderator
Moderator
Posts: 1383
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#90 by Blaze » 20 Jul 2016, 06:54

Cinnamon x86_64

1. When I mount a module - I see that XZM icon is absent in this dialog
Image

2. Probably, need to replace this green round icon on more quality image
Image

3. I vote for remove nemo-image-converter

Code: Select all

Resize Images...
Rotate Images...
from context menu (if click on image you will see these items). These functions are useless and they does not work.

BTW I done Russian localization for nemo-image-converter - you can download it from here
copy nemo-image-converter.mo to /usr/share/locale/ru/LC_MESSAGES

4. If I try (how root) to share folder via samba in Context menu -> Sharing Options

I had this error
Image

after I created password, account (for samba) and run demon of samba

Code: Select all

root@porteus:~# smbpasswd -a root
New SMB password:
Retype new SMB password:
Added user root.
root@porteus:~# smbpasswd -e root
Enabled user root.
root@porteus:~# usermod -a -G sambashare root
root@porteus:~# chmod +x /etc/rc.d/rc.samba
root@porteus:~# /etc/rc.d/rc.samba start
Starting Samba:  /usr/sbin/smbd -D
                 /usr/sbin/nmbd -D
root@porteus:~# 
I have this error

Code: Select all

"'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. Access denied." 
Image
Anybody knows how to fix it?

5. If run cinnamon-settings (System Settings | Control Center) - Users and Groups have missing icon.
Image
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

Post Reply