Porteus-v3.2rc4 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Ed_P
Contributor
Contributor
Posts: 3072
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Porteus-v3.2rc4 bug reports

Post#196 by Ed_P » 09 Aug 2016, 05:16

brokenman wrote:Ed_P I understand that this is a problem that occurred with more than one user. Without log info there is little I can do to see why.
Any particular log you're interested in seeing?
Ed

burdi01
Black ninja
Black ninja
Posts: 47
Joined: 18 Aug 2013, 12:09
Distribution: Slackware, Xubuntu
Location: The Netherlands

Re: Porteus-v3.2rc4 bug reports

Post#197 by burdi01 » 09 Aug 2016, 08:37

brokenman wrote:To remove desktop icons open dconf-editor in applications --> system tools and select:
Its in org -> mate -> desktop -> background -> show-desktop-icons
That removes all desktop icons instead of just the mounted devices ones.
:D

User avatar
Ed_P
Contributor
Contributor
Posts: 3072
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Porteus-v3.2rc4 bug reports

Post#198 by Ed_P » 09 Aug 2016, 14:45

Cinnamon 64-bit ISO boot rc5 mods

have nemo open to /home/guest/
dbl click on a .txt file
mousepad opens the file
and wallpaper disappears.

nothing else open.

earlier usm update running
screen dimmed while watching the update
screen brightened when I touched the mousepad
wallpaper did not disappear.
brokenman wrote:Ed_P I understand that this is a problem that occurred with more than one user. Without log info there is little I can do to see why.
I will zip this folder up and email it to you.

Code: Select all

root@porteus:/home/guest# cp /var/log/* /mnt/sda5/logs/
cp: target '/mnt/sda5/logs/' is not a directory
root@porteus:/home/guest# mkdir /mnt/sda5/logs
root@porteus:/home/guest# cp /var/log/* /mnt/sda5/logs/
cp: omitting directory '/var/log/ConsoleKit'
cp: omitting directory '/var/log/cups'
cp: omitting directory '/var/log/nfsd'
cp: omitting directory '/var/log/packages'
cp: omitting directory '/var/log/removed_packages'
cp: omitting directory '/var/log/removed_scripts'
cp: omitting directory '/var/log/samba'
cp: omitting directory '/var/log/scripts'
cp: omitting directory '/var/log/setup'
root@porteus:/home/guest# ls /mnt/sda5/logs
Xorg.0.log*      dmesg*     pm-powersave.log*  spooler*
Xorg.0.log.old*  faillog*   pm-suspend.log*    syslog*
btmp*            lastlog*   porteus-livedbg*   wpa_supplicant.log*
cron*            maillog*   secure*            wtmp*
debug*           messages*  slim.log*
root@porteus:/home/guest# 
Ed

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#199 by brokenman » 10 Aug 2016, 01:27

Thanks Ed_P. I don't remember the other user with the same problem. Are they also using a machine with RADEON graphics?

Can you please let me know which kernel driver you are using: lspci -k | egrep -A1 "AMD|RADEON"
How do i become super user?
Wear your underpants on the outside and put on a cape.

burdi01
Black ninja
Black ninja
Posts: 47
Joined: 18 Aug 2013, 12:09
Distribution: Slackware, Xubuntu
Location: The Netherlands

Re: Porteus-v3.2rc4 bug reports

Post#200 by burdi01 » 10 Aug 2016, 09:03

Code: Select all

root@porteus:~# lspci -k | egrep -A1 "AMD|RADEON"
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper PRO [Radeon HD 5750]
	Subsystem: PC Partner Limited / Sapphire Technology Device 3000
--
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Juniper HDMI Audio [Radeon HD 5700 Series]
	Subsystem: PC Partner Limited / Sapphire Technology Device aa58
root@porteus:~#

Cinnamon with the rc4 and rc5 mods: I do not see the symptoms as reported by by Ed_P » 09 Aug 2016, 16:45
:D

User avatar
Blaze
Moderator
Moderator
Posts: 1358
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#201 by Blaze » 10 Aug 2016, 16:23

brokenman wrote:Are they also using a machine with RADEON graphics?
I used NVIDIA video card on the old PC configuration and had trouble with missing wallpaper.
On a new PC configuration with AMD Radeon video card I have this bug too

Code: Select all

root@porteus:~# lspci -k | egrep -A1 "AMD|RADEON"
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81)
	Subsystem: PC Partner Limited / Sapphire Technology Device e322
--
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
	Subsystem: PC Partner Limited / Sapphire Technology Device aac0
root@porteus:~#
francois, any news about a new printing module for Porteus 3.2?

brokenman, I done a new version Evo-Vertex-only.xzm
- fixed active and inactive windows (was not clear what window is active or inactive)
- white color was changed on a blue color when you are renaming file(s)/folder(s)

I have two questions for you. I can compress svg files - it will be ultra optimization of Evo-Vertex theme.
It is worth it if I will do this? Do you plan to add Evo-Vertex theme to Porteus 3.2?
Last edited by Blaze on 10 Aug 2016, 20:19, edited 1 time in total.
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
Ed_P
Contributor
Contributor
Posts: 3072
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Porteus-v3.2rc4 bug reports

Post#202 by Ed_P » 10 Aug 2016, 17:08

brokenman wrote: Are they also using a machine with RADEON graphics?
hmmmm AMD yes, RADEON no, Radeon yup.
Can you please let me know which kernel driver you are using: lspci -k | egrep -A1 "AMD|RADEON"

Code: Select all

guest@porteus:~$ lspci -k | egrep -A1 "AMD|RADEON"
bash: lspci: command not found
guest@porteus:~$ su
Password: 

root@porteus:/home/guest# lspci -k | egrep -A1 "RADEON"
root@porteus:/home/guest# 

root@porteus:/home/guest# lspci -k | egrep -A1 "Radeon"
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6290]
	Subsystem: Acer Incorporated [ALI] Device 0598
root@porteus:/home/guest# 

root@porteus:/home/guest# lspci -k | egrep -A1 "AMD|RADEON"
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Complex
	Subsystem: Acer Incorporated [ALI] Device 0598
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6290]
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
	Subsystem: Acer Incorporated [ALI] Device 0598
--
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
	Subsystem: Acer Incorporated [ALI] Device 0598
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
	Kernel driver in use: pcieport
--
00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 2)
	Kernel driver in use: pcieport
--
00:15.3 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 3)
	Kernel driver in use: pcieport
--
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 3
	Kernel driver in use: k10temp
--
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 7
06:00.0 Ethernet controller: Qualcomm Atheros AR8152 v2.0 Fast Ethernet (rev c1)
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

vlc & kde

Post#203 by Bogomips » 11 Aug 2016, 01:34

64 Bit KDE & 64 Bit Cinnamon (Both using Nvidia driver)
Under KDE the VLC player is perfectly well behaved, closes without problem, and the whole VLC bundle deactivates nicely. Cinnamon however shows a new symptom, and this is repeatable. After the GUI come up, Ctl+O does not bring up Open Dialog, but instead turns window grey. Cinnamon crashes or aborts. Recovery possible thru startx. Extract from a log:

Code: Select all

var/log/messages:Aug  9 18:16:16 porteus kernel: 
[ 3066.891670] vlc[2306]: segfault at 0 ip 00007f3b9e095980 sp 00007f3b93a218e8 error 4 in ld-2.23.so[7f3b9e093000+14000]
 
32 & 64 Bit Cinnamon (No Nvidia driver)
Both can open and play, but closing causes Cinnamon crash or abort. Recovery possible thru startx.

KDE 64 Bit Verbosity

Code: Select all

guest@porteus:~$ txz2xzm  p10/Por/tmp64/libcgroup-0.41-x86_64-1.txz
guest@porteus:~$ kdesu(3381)/kdesu (kdelibs) KDESu::PtyProcess::exec: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/process.cpp : 293 ]  Running "/bin/su"
kdesu(3381)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/su.cpp : 259 ]  Read line "Password: "
kdesu(3381)/kdesu (kdelibs) KDESu::PtyProcess::exec: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/process.cpp : 293 ]  Running "/bin/su"
kdesu(3381)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/su.cpp : 259 ]  Read line "Password: "
kdesu(3381)/kdesu (kdelibs) KDESu::PtyProcess::WaitSlave: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/process.cpp : 379 ]  Child pid 3388
kdesu(3381)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/su.cpp : 259 ]  Read line ""
kdesu(3381)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /tmp/kde-build/kde4/kdelibs-4.14.21/kdesu/su.cpp : 259 ]  Read line "kdesu_stub"
<- Does not return to Prompt.
guest@porteus:~$
Ed_P wrote:I will zip this folder up and email it to you.

Code: Select all

root@porteus:/home/guest# cp /var/log/* /mnt/sda5/logs/
cp: target '/mnt/sda5/logs/' is not a directory
root@porteus:/home/guest# mkdir /mnt/sda5/logs
root@porteus:/home/guest# cp /var/log/* /mnt/sda5/logs/
cp: omitting directory '/var/log/ConsoleKit'
cp: omitting directory '/var/log/cups'
cp: omitting directory '/var/log/nfsd'
cp: omitting directory '/var/log/packages'
cp: omitting directory '/var/log/removed_packages'
cp: omitting directory '/var/log/removed_scripts'
cp: omitting directory '/var/log/samba'
cp: omitting directory '/var/log/scripts'
cp: omitting directory '/var/log/setup'
root@porteus:/home/guest# ls /mnt/sda5/logs
Xorg.0.log*      dmesg*     pm-powersave.log*  spooler*
Xorg.0.log.old*  faillog*   pm-suspend.log*    syslog*
btmp*            lastlog*   porteus-livedbg*   wpa_supplicant.log*
cron*            maillog*   secure*            wtmp*
debug*           messages*  slim.log*
root@porteus:/home/guest# 
Used to do all this copying stuff, but lately found quick zip for it:

Code: Select all

su
zip   cin64vlcrc5-nvd.zip   /var/log/*
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Cinnamon vlc issue

Post#204 by Bogomips » 13 Aug 2016, 00:10

brokenman wrote:Have you tried using a different theme Bogomips?
No change. :( If this is what is meant by a different theme: Image
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#205 by brokenman » 13 Aug 2016, 02:27

Thanks guys. Looks like we can rule out video card for the missing wallpaper problem. Bogomips I will tackle the vlc problem next. Probably this weekend.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Blaze
Moderator
Moderator
Posts: 1358
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#206 by Blaze » 14 Aug 2016, 10:50

I done compression of svg files for Evo-Vertex-only theme.
A new size 1.5 Mb. Download Evo-Vertex-only.xzm

Cinnamon x86_64
Image
I can't create icons at the desktop of Cinnamon.
But icons are present at the /root/Desktop directory.
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

Jack
Contributor
Contributor
Posts: 1063
Joined: 09 Aug 2013, 14:25
Distribution: Porteus 3.2.rc5 Mate 64 bit
Location: Marysville, OHIO USA

Re: Porteus-v3.2rc4 bug reports

Post#207 by Jack » 14 Aug 2016, 12:21

@blaze

Where did you get the wallpaper you use cause I like it to use with Mate. Can I have the link? I know this is off topic.
I just like Slackware because I think it teach you about Linux to build packages where Ubuntu is like Windows you just install programs you want.

User avatar
Blaze
Moderator
Moderator
Posts: 1358
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#208 by Blaze » 14 Aug 2016, 17:13

Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

tome
Contributor
Contributor
Posts: 561
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: Porteus-v3.2rc4 bug reports

Post#209 by tome » 19 Aug 2016, 08:25

A little old bug with load, noload cheatcodes, example:
noload=003 load=00 should load 000, 001 and 002 but loads also 003.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

rc5- & changes

Post#210 by Bogomips » 19 Aug 2016, 15:15

Cinnamon 32 Bit

Confirming two Issues concerning running with changes file, previously reported on rc4:
  • Login Dialog on blotchy Pink Background Looping.
    • Been running smoothly using changes, and here am not sure if it was the change to changes=EXIT or redirecting /tmp to a real filesystem which was the cause of

      Code: Select all

      guest@porteus:~$ ls -ld /home/guest/
      drwxr-xr-x 39 root root 60 Aug 18  2016 /home/guest//
      guest@porteus:~$ sudo chown guest:users /home/guest/
      guest@porteus:~$ ls -ld /home/guest/
      drwxr-xr-x 39 guest users 60 Aug 18  2016 /home/guest//                  
      fixed in test mode before init 4
    • Fix for GUI applied in cliexec:

      Code: Select all

      root@porteus:/home/guest# usm -i
      ++++++++++++++++++++++++++++++
      usm application information
      
      USM version:  3.2.0
      DB version:  160320
      Current storage: /home/guest/p10/Por/tmp/usm
      Current config: /etc/usm/usm.conf
      Current platform: Porteus-v3.2rc5
      Current arch: i686
      Current Slackware 14.2
      Current kernel 4.6.3-porteus
      Current distros: slackware slackwarepatches slacky salix alien ponce slackonly
      quiet from=/dev/sda8/rc5 copy2ram ramsize=30% noauto guiexec=Prolog/pmx.sh cliexec=mount~--bind~/home/guest/p9/tmp~/tmp;chown~guest:users~/home/guest extramod=/dev/sda10/tmp/iso/rc4/tst/mods changes=EXIT:/dev/sda6/sav/savgbg.dat
      
      However do get Cinnamon multi-line notification which disappears before one can manage to read the first line.
  • Date & Time Probably also comes with the territory, as had no cause to notice this before when running with simple changes
    • Time remains stuck on utc. Setting to Network Time has no effect, and

      Code: Select all

      sudo ln -sf /usr/share/zoneinfo/Europe/London  /etc/localtime
      also no effect, although works perfectly well when running without changes.
    • Fixed by setting system time from h/w clock, as noticed h/w clock on local time:

      Code: Select all

      guest@porteus:~$ sudo /sbin/hwclock
      Fri 19 Aug 2016 10:07:31 AM BST  .892266 seconds
      guest@porteus:~$ sudo /sbin/hwclock -s
      guest@porteus:~$ date
      Fri Aug 19 10:07:51 BST 2016
      
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Post Reply