Google Earth 7.1.5 for Porteus

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Google Earth 7.1.5 for Porteus

Post#1 by wread » 07 Jun 2016, 11:36

Google Earth is a well known graphic application of satellital imagery of the planet, moon, mars and sky. This new version has enhanced 3D capabilities, among other interesting features. It seems to be a 64 bits app, although it may have some 32 bits files encapsulated in it. At any rate, it doesn't need a 32-bit compatibility package.

To make it work, you will need to make your Porteus LSB-3-compliant by making links ld-lsb-x86-64.so.3 to ld-2.22.so (and to ld-2.23.so in 05-devel).

I have tested it in my KDE5 Porteus current, but it is an X-application and should as well run in other Porteus versions.

Enjoy :)
Last edited by wread on 14 Jun 2016, 03:20, edited 1 time in total.
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
Ed_P
Contributor
Contributor
Posts: 3053
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Google Earth 7.1.5 for Porteus

Post#2 by Ed_P » 07 Jun 2016, 14:21

wread wrote:(and to ld-2.23.so in 05-devel).
Are you saying one needs the 05-devel module to run this?
Ed

User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Google Earth 7.1.5 for Porteus

Post#3 by wread » 08 Jun 2016, 00:05

Definitly no! GE runs without 05-devel.
Just if you have 05-devel in base it will crash with a segfault :%) . It took me a couple of hours to get this solution...

Regards!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

rchase
Samurai
Samurai
Posts: 154
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Google Earth 7.1.5 for Porteus

Post#4 by rchase » 27 Jul 2016, 01:00

wread wrote: ... you will need to make your Porteus LSB-3-compliant by making links ld-lsb-x86-64.so.3 to ld-2.22.so (and to ld-2.23.so in 05-devel).
Would you please elaborate? Do I understand correctly that the second link to which you refer is required if the development module is installed (and that GE then works)?

User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Google Earth 7.1.5 for Porteus

Post#5 by wread » 28 Jul 2016, 01:46

Yes, try it yourself!

Cheers!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Google Earth 7.1.5 for Porteus

Post#6 by francois » 07 Aug 2016, 02:34

@ed and rchase:
Here is the explanation, ld-lsb is missing for a functional google-earth:
https://bbs.archlinux.org/viewtopic.php?id=175598

A rpm version for lsb as there is no slackware version:
http://distrib-coffee.ipsl.jussieu.fr/p ... x86_64.rpm

Right-click on it and activate. Then:

Code: Select all

root@porteus:/lib64# ln -s ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3
Start google-earth. :)

Hum! It starts but then crashed. :(

Edited 160810.
From the following discussion with wread, I understand that his google earth module will work for slackware 14.2 or porteus 3.2 at the rc stage.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Google Earth 7.1.5 for Porteus

Post#7 by francois » 08 Aug 2016, 00:32

That maybe because I am working with kde fanthom 3.1. What do you think wread?
Voltaire: Le mieux est l'ennemi du bien.

User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Google Earth 7.1.5 for Porteus

Post#8 by wread » 09 Aug 2016, 01:57

@francois
For GE 7 you need xorg 17 at least. For 3.1 you should use GE 6. That's why! (GE 6 is 32 bits, use compatibility module)

Voila!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Google Earth 7.1.5 for Porteus

Post#9 by francois » 09 Aug 2016, 17:25

Would your Google earth module work on brokenman`s porteus 3.2 rc4?
Voltaire: Le mieux est l'ennemi du bien.

User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Google Earth 7.1.5 for Porteus

Post#10 by wread » 09 Aug 2016, 18:57

There is no reason why it shouldn't. Just make sure it is LSB compliant as I explained in the relevant post starting this thread :)
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Google Earth 7.1.5 for Porteus

Post#11 by francois » 09 Aug 2016, 23:17

I imagine that Ed will test it with pleasure, or I will as soon as I get enough time.
It would be nice that you specify in your first post that your module is good for porteus 3.2 rc.
:wink:

I have tested it with porteus 3.1. It does not work.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
wread
Module Guard
Module Guard
Posts: 1061
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Google Earth 7.1.5 for Porteus

Post#12 by wread » 10 Aug 2016, 11:48

@francois
The last paragraph of my first post states GE is an X application, so it should run on all other desktops.
As of today, it has been downloaded 49 times and I haven't received any complains that it doesn't work!

Just try it!

Regards!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

Post Reply