NVIDIA 361 Driver

Technical issues/questions of an intermediate or advanced nature.
fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#61 by fab1qaz » 06 Jun 2016, 06:42

From scratch installing the driver on boot in 3 copy2ram...

log.zip

Code: Select all

guest@porteus:~$ cat  /proc/cmdline
quiet \boot\syslinux\vmlinuz initrd=boot\syslinux\initrd.xz 3 copy2ram
guest@porteus:~$ df -h .
Filesystem      Size  Used Avail Use% Mounted on
aufs            9.4G  383M  9.0G   4% /
guest@porteus:~$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15952         309       13377         746        2266       14717
Swap:             0           0           0
guest@porteus:~$ cat /var/log/porteus-livedbg
# Recognized devices:
/dev/sda1: LABEL="Recovery" UUID="76D6481CD647DACF" TYPE="ntfs" 
/dev/sda2: UUID="DA48-C7CE" TYPE="vfat" 
/dev/sda4: UUID="C6744BD7744BC8BF" TYPE="ntfs" 
/dev/sdb2: LABEL="Data" UUID="F8BA6307BA62C22C" TYPE="ntfs" 
/dev/sdc1: LABEL="UUI" UUID="1B08-3076" TYPE="vfat" 

# Booting device:
/mnt/sdc1

# Porteus data found in:
/mnt/sdc1/porteus

# Changes are stored in:
memory

# Non standard /rootcopy dir:
none

# Modules activated during boot time:
/memory/copy2ram/000-kernel.xzm
/memory/copy2ram/001-core.xzm
/memory/copy2ram/002-xorg.xzm
/memory/copy2ram/003-xfce4.xzm
/memory/copy2ram/05-devel.xzm
/memory/copy2ram/blacklist.xzm
/memory/copy2ram/crippled_sources.xzm
guest@porteus:~$ cat  /etc/ld.so.conf
/lib64
/usr/lib64
/usr/local/lib64
/usr/x86_64-slackware-linux/lib64
/lib
/usr/lib
/usr/local/lib
guest@porteus:~$ dmesg -e | tail -n 60
[  +0.000768] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input6
[  +0.001987] asus_wmi: Number of fans: 1
[  +0.005144] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[  +0.000001] [drm] Driver supports precise vblank timestamp query.
[  +0.007682] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1.bin failed with error -2
[  +0.000003] [drm:0xffffffffa033d420] *ERROR* Failed to load DMC firmware, disabling rpm
[  +0.004229] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[  +0.008312] iwlwifi 0000:02:00.0: loaded firmware version 25.30.13.0 op_mode iwlmvm
[  +0.016031] intel_rapl: Found RAPL domain package
[  +0.000004] intel_rapl: Found RAPL domain core
[  +0.000002] intel_rapl: Found RAPL domain uncore
[  +0.000002] intel_rapl: Found RAPL domain dram
[  +0.010132] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[  +0.000328] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000600] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.037788] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[  +0.001905] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input7
[  +0.000047] ACPI Exception: AE_NOT_FOUND, Evaluating _DOD (20160108/video-1248)
[  +0.000003] ACPI: Video Device [PEGP] (multi-head: no  rom: yes  post: no)
[  +0.000039] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:01/input/input8
[  +0.031678] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[  +0.140155] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffffa03cc770)
[  +0.000022] [drm] Initialized i915 1.6.0 20151218 for 0000:00:02.0 on minor 0
[  +0.550477] fbcon: inteldrmfb (fb0) is primary device
[  +1.024813] [drm] RC6 on
[  +0.202859] Console: switching to colour frame buffer device 240x67
[  +0.137124] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[  +0.028838] snd_hda_codec_conexant hdaudioC0D0: CX20751/2: BIOS auto-probing.
[  +0.000463] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20751/2: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[  +0.000002] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x1a
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x18
[  +0.001324] snd_hda_codec_conexant hdaudioC0D0: Enable sync_write for stable communication
[  +0.007683] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9
[  +0.000056] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
[  +0.000050] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[  +0.000048] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[  +0.491842] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000933] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.064305] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000497] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.080783] r8169 0000:03:00.1 eth0: link down
[Jun 6 08:26] nvidia: module license 'NVIDIA' taints kernel.
[  +0.000003] Disabling lock debugging due to kernel taint
[  +0.004750] nvidia-nvlink: Nvlink Core is being initialized, major device number 251
[  +0.000058] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 1
[  +0.000003] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.45.11  Tue May 17 18:25:03 PDT 2016
[  +0.002762] nvidia-uvm: Loaded the UVM driver in lite mode, major device number 250
[  +0.000755] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  361.45.11  Tue May 17 17:49:04 PDT 2016
[  +0.003041] nvidia-modeset: Unloading
[  +0.008283] nvidia-uvm: Unloaded the UVM driver in lite mode
[  +0.008769] nvidia-nvlink: Unregistered the Nvlink Core, major device number 251
[  +0.000094] [drm] Module unloaded
[ +11.194320] nvidia-nvlink: Nvlink Core is being initialized, major device number 251
[  +0.000093] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 1
[  +0.000003] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.45.11  Tue May 17 18:25:03 PDT 2016
[ +20.425971] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
guest@porteus:~$ su
Password: 
root@porteus:/home/guest# lsmod > lsmod.txt
root@porteus:/home/guest# zip   log.zip   /var/log/*   lsmod.txt
  adding: var/log/ConsoleKit/ (stored 0%)
  adding: var/log/Xorg.0.log (deflated 79%)
  adding: var/log/btmp (stored 0%)
  adding: var/log/cron (deflated 8%)
  adding: var/log/debug (deflated 84%)
  adding: var/log/dmesg (deflated 74%)
  adding: var/log/faillog (stored 0%)
  adding: var/log/lastlog (deflated 100%)
  adding: var/log/maillog (stored 0%)
  adding: var/log/messages (deflated 81%)
  adding: var/log/nfsd/ (stored 0%)
  adding: var/log/nvidia-installer.log (deflated 84%)
  adding: var/log/packages/ (stored 0%)
  adding: var/log/pm-powersave.log (deflated 84%)
  adding: var/log/porteus-livedbg (deflated 50%)
  adding: var/log/removed_packages/ (stored 0%)
  adding: var/log/removed_scripts/ (stored 0%)
  adding: var/log/samba/ (stored 0%)
  adding: var/log/scripts/ (stored 0%)
  adding: var/log/secure (deflated 58%)
  adding: var/log/setup/ (stored 0%)
  adding: var/log/slim.log (deflated 2%)
  adding: var/log/spooler (stored 0%)
  adding: var/log/syslog (deflated 76%)
  adding: var/log/wpa_supplicant.log (deflated 45%)
  adding: var/log/wtmp (deflated 95%)
  adding: lsmod.txt (deflated 68%)
root@porteus:/home/guest# ls /mnt/live/memory/images/
000-kernel.xzm/  002-xorg.xzm/   05-devel.xzm/   crippled_sources.xzm/
001-core.xzm/    003-xfce4.xzm/  blacklist.xzm/
root@porteus:/home/guest# nvidia-settings
Xlib:  extension "GLX" missing on display ":0.0".

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (nvidia-settings:4521): WARNING **: AT-SPI: Could not obtain desktop path or name


** (nvidia-settings:4521): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (nvidia-settings:4521): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (nvidia-settings:4521): WARNING **: atk-bridge: get_device_events_reply: unknown signature
I activated and tried VirtualBox and 3d acceleration doesn't work. Starting to think it's just a hard GPU to get a driver working on, I mean it should work with their official installer. :shock:

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#62 by Bogomips » 06 Jun 2016, 12:23

fab1qaz wrote:I activated and tried VirtualBox and 3d acceleration doesn't work. Starting to think it's just a hard GPU to get a driver working on, I mean it should work with their official installer. :shock:
Was beginning to have a suspicion in that direction. :wink: Just had time to hava a quick look. Quick question, did GUI come up and able to change settings with nvidia-settings?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#63 by fab1qaz » 06 Jun 2016, 14:27

It came up, but no, I couldn't change any settings.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#64 by Bogomips » 06 Jun 2016, 19:43

Looks like installer's a bit flaky:

Code: Select all

    root@porteus:/home/guest# nvidia-settings
    Xlib:  extension "GLX" missing on display ":0.0".

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

    ** (nvidia-settings:4521): WARNING **: AT-SPI: Could not obtain desktop path or name


    ** (nvidia-settings:4521): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

    ** (nvidia-settings:4521): WARNING **: atk-bridge: get_device_events_reply: unknown signature

    ** (nvidia-settings:4521): WARNING **: atk-bridge: get_device_events_reply: unknown signature
With the last supplementary module test we did, able to get rid of the above error:
ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.
Indication that installer out of sync with settings module. i.e. not tested with it.

It seems that the nvidia driver is being rejected by your system, and in order to ascertain where this is happening, would like to conduct a further test:
  1. Replace in modules folder: nvd_rpm_1.xzm by nvd_rpm_2.xzm
  2. Do Steps 2. to 5., as in https://forum.porteus.org/viewtopic.php ... 979#p45979
Thanks.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Evan
Warlord
Warlord
Posts: 519
Joined: 11 Apr 2016, 09:00
Distribution: Anything Cinnamon
Location: London

Re: I can't boot please help!

Post#65 by Evan » 07 Jun 2016, 08:32

<removed>
Last edited by Evan on 24 Jun 2016, 12:53, edited 1 time in total.

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#66 by fab1qaz » 07 Jun 2016, 09:50

Bogomips wrote:Looks like installer's a bit flaky:

Code: Select all


It seems that the nvidia driver is being rejected by your system, and in order to ascertain where this is happening, would like to conduct a further test:[list=1][*]Replace in modules folder: nvd_rpm_1.xzm by [url=https://cloud.mail.ru/public/2Bbu/A5TzuugpL]nvd_rpm_2.xzm[/url][*]Do Steps 2. to 5., as in https://forum.porteus.org/viewtopic.php?f=81&t=5886&p=45979#p45979[/list]Thanks.[/quote]

Bogomips I get this when I boot with the nvd_rpm_2.xzm module. I can boot as normal without but then I can't do the test.  :sorry: 
[url]http://s33.postimg.org/lzze80r73/IMG_1543.jpg[/url]

Evan, thanks for that but it doesn't improve the 2d performance and I'd rather say away from betas.  :crazy:

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#67 by Bogomips » 07 Jun 2016, 17:25

fab1qaz wrote:Bogomips I get this when I boot with the nvd_rpm_2.xzm module. I can boot as normal without but then I can't do the test.
Well, that was quite unexpected! Let's see if it also happens when the installer creates the driver.
  • Place nvd_rpm_2.xzm in /mnt/sdc1/porteus/nvd
  • After installer finishes making driver

    Code: Select all

    cd   /home/guest
    mkdir x
    mount    /mnt/sdc1/porteus/nvd/nvd_rpm_2.xzm   x
    cd x         
    cp --parents usr/share/X11/xorg.conf.d/10-nvidia.conf   /   # It's a slash.
    cd ..
    sudo umount x
    
    ls -lh /usr/share/X11/xorg.conf.d/10-nvidia.conf
    cat /usr/share/X11/xorg.conf.d/10-nvidia.conf
  • Expect output of last 2 statements to be:

    Code: Select all

    -rw-r--r-- 1 root root 125 Jun  7 17:17 /usr/share/X11/xorg.conf.d/10-nvidia.conf
    
    Section "Device"
            Identifier "NVIDIA Card"
            VendorName "NVIDIA Corporation"
            Driver "nvidia"
    EndSection
    
  • Try for GUI

    Code: Select all

    init  4
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#68 by fab1qaz » 07 Jun 2016, 20:36

I get those exact results then when I enter GUI with "init 4" I get a load of error text the bottom of which:
http://s32.postimg.org/w8p55qeb9/IMG_1546.jpg
http://s32.postimg.org/uzjcki9rp/IMG_1547.jpg
is just like before.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: NVIDIA 361 Driver

Post#69 by Bogomips » 09 Jun 2016, 01:01

Topic Renamed and Moved here.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#70 by Bogomips » 10 Jun 2016, 23:08

@ fab1qaz
Thanks for confirming limitation of nvidia installer.
To recap:
It seems that the nvidia driver is being rejected by your system, and in order to ascertain where this is happening, would like to conduct a further test:
  1. Replace in modules folder: nvd_rpm_1.xzm by nvd_rpm_3.xzm (md5sum: 316fdf3e102eba2108a167f7bbebd056)
  2. Do Steps 2. to 5., as in https://forum.porteus.org/viewtopic.php ... 979#p45979
Let's hope we make it to the GUI this time.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: NVIDIA 361 Driver

Post#71 by fab1qaz » 16 Jun 2016, 11:02

Cheers Bogo, I missed your last reply!
Here is the log zip
log.zip

and code

Code: Select all

root@porteus:/home/guest# cat  /proc/cmdline
quiet \boot\syslinux\vmlinuz copy2ram initrd=boot\syslinux\initrd.xz
root@porteus:/home/guest# df -h .
Filesystem      Size  Used Avail Use% Mounted on
aufs            9.4G  3.8M  9.4G   1% /
root@porteus:/home/guest# free -m
              total        used        free      shared  buff/cache   available
Mem:          15952         315       14813         487         824       14967
Swap:             0           0           0
root@porteus:/home/guest# cat /var/log/porteus-livedbg
# Recognized devices:
/dev/sda1: LABEL="Recovery" UUID="76D6481CD647DACF" TYPE="ntfs" 
/dev/sda2: UUID="DA48-C7CE" TYPE="vfat" 
/dev/sda4: UUID="C6744BD7744BC8BF" TYPE="ntfs" 
/dev/sdb2: LABEL="Data" UUID="F8BA6307BA62C22C" TYPE="ntfs" 
/dev/sdc1: LABEL="UUI" UUID="1B08-3076" TYPE="vfat" 

# Booting device:
/mnt/sdc1

# Porteus data found in:
/mnt/sdc1/porteus

# Changes are stored in:
memory

# Non standard /rootcopy dir:
none

# Modules activated during boot time:
/memory/copy2ram/000-kernel.xzm
/memory/copy2ram/001-core.xzm
/memory/copy2ram/002-xorg.xzm
/memory/copy2ram/003-xfce4.xzm
/memory/copy2ram/05-devel.xzm
/memory/copy2ram/VeraCrypt.xzm
/memory/copy2ram/crippled_sources.xzm
/memory/copy2ram/nvd_rpm_3.xzm
/memory/copy2ram/nvidia-361.45.11-x86_64.xzm
/memory/copy2ram/torguard-latest-amd64.xzm
root@porteus:/home/guest# cat  /etc/ld.so.conf
/lib64
/usr/lib64
/usr/local/lib64
/usr/x86_64-slackware-linux/lib64
/lib
/usr/lib
/usr/local/lib
root@porteus:/home/guest# dmesg -e | tail -n 60
[  +0.000231] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[  +0.000330] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000447] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.002320] asus_wmi: Initialization: 0x1
[  +0.000099] asus_wmi: BIOS WMI version: 7.9
[  +0.000088] asus_wmi: SFUN value: 0xa0077
[  +0.001313] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input6
[  +0.000002] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[  +0.003403] asus_wmi: Number of fans: 1
[  +0.000257] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input7
[  +0.001697] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
[  +0.000007] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
[  +0.000003] pcieport 0000:00:1c.0:   device [8086:a112] error status/mask=00000001/00000000
[  +0.000002] pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
[  +0.000584] ACPI Exception: AE_NOT_FOUND, Evaluating _DOD (20160108/video-1248)
[  +0.000004] ACPI: Video Device [PEGP] (multi-head: no  rom: yes  post: no)
[  +0.000043] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:01/input/input8
[  +0.000079] [drm] Initialized i915 1.6.0 20151218 for 0000:00:02.0 on minor 0
[  +0.014532] ACPI Warning: SystemIO range 0x000000000000F040-0x000000000000F05F conflicts with OpRegion 0x000000000000F040-0x000000000000F04F (\SMB0) (20160108/utaddress-255)
[  +0.000007] ACPI Warning: SystemIO range 0x000000000000F040-0x000000000000F05F conflicts with OpRegion 0x000000000000F040-0x000000000000F04F (\_SB.PCI0.SBUS.SMBI) (20160108/utaddress-255)
[  +0.000004] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[  +0.022369] intel_rapl: Found RAPL domain package
[  +0.000003] intel_rapl: Found RAPL domain core
[  +0.000002] intel_rapl: Found RAPL domain uncore
[  +0.000002] intel_rapl: Found RAPL domain dram
[  +0.034725] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[  +0.099632] pmd_set_huge: Cannot satisfy [mem 0xb0000000-0xb0200000] with a huge-page mapping due to MTRR override.
[  +0.000057] fbcon: inteldrmfb (fb0) is primary device
[  +0.078587] nvidia: module license 'NVIDIA' taints kernel.
[  +0.000001] Disabling lock debugging due to kernel taint
[  +0.004584] nvidia-nvlink: Nvlink Core is being initialized, major device number 251
[  +0.000139] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 1
[  +0.000002] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.45.11  Tue May 17 18:25:03 PDT 2016
[  +0.953139] Console: switching to colour frame buffer device 240x67
[  +0.231812] [drm] RC6 on
[  +0.122891] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffffa0146770)
[  +0.025631] snd_hda_codec_conexant hdaudioC0D0: CX20751/2: BIOS auto-probing.
[  +0.000317] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20751/2: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[  +0.000000] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x1a
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x18
[  +0.000890] snd_hda_codec_conexant hdaudioC0D0: Enable sync_write for stable communication
[  +0.006234] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9
[  +0.000039] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
[  +0.000039] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[  +0.000033] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[  +0.112315] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[  +0.571782] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000733] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.007295] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
[  +0.000039] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
[  +0.000002] pcieport 0000:00:1c.0:   device [8086:a112] error status/mask=00000001/00000000
[  +0.000002] pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
[  +0.056224] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.001285] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.056221] r8169 0000:03:00.1 eth0: link down
[  +3.090783] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.



oot@porteus:/home/guest# ls /mnt/live/memory/images/
000-kernel.xzm/  05-devel.xzm/          nvidia-361.45.11-x86_64.xzm/
001-core.xzm/    VeraCrypt.xzm/         torguard-latest-amd64.xzm/
002-xorg.xzm/    crippled_sources.xzm/
003-xfce4.xzm/   nvd_rpm_3.xzm/
root@porteus:/home/guest# nvidia-settings
Xlib:  extension "GLX" missing on display ":0.0".
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (nvidia-settings:1509): WARNING **: AT-SPI: Could not obtain desktop path or name


** (nvidia-settings:1509): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (nvidia-settings:1509): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (nvidia-settings:1509): WARNING **: atk-bridge: get_device_events_reply: unknown signature

The nVidia settings application pop up just says:

Code: Select all

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
We got to GUI though!
There's a newer driver out now too. http://www.nvidia.co.uk/download/driver ... 4314/en-uk :) Is it worth trying that one from scratch?

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: NVIDIA 361 Driver

Post#72 by Bogomips » 16 Jun 2016, 11:27

fab1qaz wrote:Cheers Bogo, I missed your last reply!
Thought you had moved on to greener pastures.
fab1qaz wrote:There's a newer driver out now too. http://www.nvidia.co.uk/download/driver ... 4314/en-uk :) Is it worth trying that one from scratch?
Give it a whirl!

P.S.
@donald @Blaze
Now collected as much data as I could think of. Now is needed brainstorming on your part. As far as I can see it looks like Intel and Nouveau need to be repressed. Tried to modprobe 3 nvidia modules, but only one shows.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: NVIDIA 361 Driver

Post#73 by fab1qaz » 17 Jun 2016, 12:33

It sounds like you're on to something! At least in Windows, the CPU has graphics capabilities and I can switch between running games on that or the 960M. Same problem with the new 367 driver, HW acceleration is not working.

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: NVIDIA 361 Driver

Post#74 by beny » 17 Jun 2016, 20:59

hi, the last 367,27 build well on porteus rc3 and the 4.6 kernel the other nvidia versions need a drm patch to build against it, so in a clean system build the driver and run the sh save-changes to make a good nvidia driver module,you need also crippled source.xzm and devel.xzm,

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: NVIDIA 361 Driver

Post#75 by Bogomips » 17 Jun 2016, 21:14

Thanks beny. That's good news.

@fab1qaz
In order to get the 367,27 driver working you need to move to rc3. Get crippled sources from here http://ftp.vim.org/ftp/os/Linux/distr/p ... 1-porteus/, 05-devel.xzm from here http://ftp.vim.org/ftp/os/Linux/distr/p ... 3/modules/. blacklist.xzm you already have. Keep out fingers crossed, and if it works then the module should be no trouble.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Post Reply