NVIDIA 361 Driver

Technical issues/questions of an intermediate or advanced nature.
Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#46 by Bogomips » 30 May 2016, 20:45

fab1qaz wrote:

Code: Select all

root@porteus:/home/guest# cp  -a  /var/log  ,
root@porteus:/home/guest# tar cjf  log.bz2  log
tar: log: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
This is mine

Code: Select all

oot@porteus:/home/guest# cp -a /var/log .
root@porteus:/home/guest# tar cjf log.bz2 log
root@porteus:/home/guest# ls log*
log.bz2

log:
ConsoleKit/  debug    messages          removed_packages/  setup/
Xorg.0.log   dmesg    nfsd/             removed_scripts/   slim.log
btmp         faillog  packages/         samba/             spooler 
cron         lastlog  pm-powersave.log  scripts/           syslog
cups/        maillog  porteus-livedbg   secure             wtmp
Real puzzling!
fab1qaz wrote:I noticed this part didn't work so I copied as su

Code: Select all

cp -a /var/log  /mnt/sdb2/varlog
and have the varlog folder on my external hard-drive.
Let's try this then:

Code: Select all

ls /mnt/sdb2/varlog
su
rm -r log
cp -a  /mnt/sdb2/varlog  log
ls  -lh  log
tar cjf log.bz2 log
Upload and post link.

Please also post output of:

Code: Select all

ls  -l  /usrlocal/bin
ldd /usr/local/bin/nvidia-settings  | grep found
nvidia-settings
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#47 by fab1qaz » 30 May 2016, 21:33

Code: Select all

guest@porteus:~$ ls /mnt/sdb2/varlog
ConsoleKit/  lastlog*           removed_packages/  spooler*
Xorg.0.log*  maillog*           removed_scripts/   syslog*
btmp*        messages*          samba/             wpa_supplicant.log*
cron*        nfsd/              scripts/           wtmp*
debug*       packages/          secure*
dmesg*       pm-powersave.log*  setup/
faillog*     porteus-livedbg*   slim.log*
guest@porteus:~$ su
Password: 
root@porteus:/home/guest# rm -r log
rm: cannot remove 'log': No such file or directory
root@porteus:/home/guest# cp -a  /mnt/sdb2/varlog  log
root@porteus:/home/guest# ls  -lh  log
total 224K
drwxrwxrwx 2 root root   60 May 30 18:15 ConsoleKit/
-rwxrwxrwx 1 root root  29K May 30 18:15 Xorg.0.log*
-rwxrwxrwx 1 root root    0 May  5 22:51 btmp*
-rwxrwxrwx 1 root root   98 May 30 18:15 cron*
-rwxrwxrwx 1 root root  17K May 30 18:16 debug*
-rwxrwxrwx 1 root root  56K May 30 18:15 dmesg*
-rwxrwxrwx 1 root root    0 Jul  2  2014 faillog*
-rwxrwxrwx 1 root root    0 Apr  8  2000 lastlog*
-rwxrwxrwx 1 root root    0 Dec 13 20:55 maillog*
-rwxrwxrwx 1 root root  69K May 30 18:18 messages*
drwxrwxrwx 2 root root   40 May 16  2001 nfsd/
drwxrwxrwx 2 root root  11K May  8 17:57 packages/
-rwxrwxrwx 1 root root 1.1K May 30 18:15 pm-powersave.log*
-rwxrwxrwx 1 root root  639 May 30 18:15 porteus-livedbg*
drwxrwxrwx 2 root root   40 May  8 17:56 removed_packages/
drwxrwxrwx 2 root root   40 May  8 17:56 removed_scripts/
drwxrwxrwx 2 root root   40 May  2 17:33 samba/
drwxrwxrwx 2 root root 1.8K May  8 17:57 scripts/
-rwxrwxrwx 1 root root  903 May 30 18:18 secure*
drwxrwxrwx 3 root root   80 Dec 31 17:23 setup/
-rwxrwxrwx 1 root root   61 May 30 18:15 slim.log*
-rwxrwxrwx 1 root root    0 Dec 13 20:55 spooler*
-rwxrwxrwx 1 root root 8.7K May 30 18:15 syslog*
-rwxrwxrwx 1 root root  268 May 30 18:18 wpa_supplicant.log*
-rwxrwxrwx 1 root root 7.2K May 30 18:15 wtmp*
root@porteus:/home/guest# tar cjf log.bz2 log
root@porteus:/home/guest# ls  -l  /usrlocal/bin
/bin/ls: cannot access '/usrlocal/bin': No such file or directory
root@porteus:/home/guest# ldd /usr/local/bin/nvidia-settings  | grep found
That seemed to work but what am I meant to be uploading? I counldn't see a log.bz2 anywhere. :%)

Code: Select all

root@porteus:/home/guest# nvidia-settings
Xlib:  extension "GLX" missing on display ":0.0".

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (nvidia-settings:1358): WARNING **: AT-SPI: Could not obtain desktop path or name


** (nvidia-settings:1358): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (nvidia-settings:1358): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (nvidia-settings:1358): WARNING **: atk-bridge: get_device_events_reply: unknown signature

I see this message in the nvidia application like with blaxklist.xzm:

Code: Select all

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#48 by Bogomips » 31 May 2016, 00:50

I see this message in the nvidia application like with blaxklist.xzm:
Which application?

Please just zip: /mnt/sdb2/varlog and upload it, for example:

Code: Select all

su
cd  /mnt/sdb2
zip  varlog.zip  varlog/*
# Also correction
ls -lh /usr/local/bin
This should work.

At the moment cannot tell what is going on without looking at all the logs. Do not know if settings is not working because of missing libs or because cannot connect to driver. (Bit like in fly by wire plane, where false instrument reading causes evasive action to be taken) leading to plane crashing.)The other way already mentioned being to run an intense graphical application.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3209
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: I can't boot please help!

Post#49 by Ed_P » 31 May 2016, 03:43

Bogomips wrote:
fab1qaz wrote:

Code: Select all

root@porteus:/home/guest# cp  -a  /var/log  ,
root@porteus:/home/guest# tar cjf  log.bz2  log
tar: log: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
This is mine

Code: Select all

oot@porteus:/home/guest# cp -a /var/log .
root@porteus:/home/guest# tar cjf log.bz2 log
root@porteus:/home/guest# ls log*
log.bz2

log:
ConsoleKit/  debug    messages          removed_packages/  setup/
Xorg.0.log   dmesg    nfsd/             removed_scripts/   slim.log
btmp         faillog  packages/         samba/             spooler 
cron         lastlog  pm-powersave.log  scripts/           syslog
cups/        maillog  porteus-livedbg   secure             wtmp
Real puzzling!
I could be wrong but I think I'm seeing two different characters at the end of the cp -a /var/log commands. fab1qaz has a comma, while you have a period.
Ed

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#50 by fab1qaz » 31 May 2016, 08:54

Code: Select all

root@porteus:/home/guest# nvidia-settings
The nvidia-settings application is the nvidia application I was referring to.
Here is the zip, I guess the driver is working since the fan is playing nice since you updated my crude xzm (which did not stop the fan going crazy). I want to see what you make of the logs, I have no games installed on linux yet, should be easier than driver installation though! :wink:
varlog.zip

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# cd  /mnt/sdb2
root@porteus:/mnt/sdb2# zip  varlog.zip  varlog/*
  adding: varlog/ConsoleKit/ (stored 0%)
  adding: varlog/Xorg.0.log (deflated 79%)
  adding: varlog/btmp (stored 0%)
  adding: varlog/cron (deflated 8%)
  adding: varlog/debug (deflated 84%)
  adding: varlog/dmesg (deflated 74%)
  adding: varlog/faillog (stored 0%)
  adding: varlog/lastlog (stored 0%)
  adding: varlog/maillog (stored 0%)
  adding: varlog/messages (deflated 80%)
  adding: varlog/nfsd/ (stored 0%)
  adding: varlog/packages/ (stored 0%)
  adding: varlog/pm-powersave.log (deflated 84%)
  adding: varlog/porteus-livedbg (deflated 47%)
  adding: varlog/removed_packages/ (stored 0%)
  adding: varlog/removed_scripts/ (stored 0%)
  adding: varlog/samba/ (stored 0%)
  adding: varlog/scripts/ (stored 0%)
  adding: varlog/secure (deflated 52%)
  adding: varlog/setup/ (stored 0%)
  adding: varlog/slim.log (deflated 2%)
  adding: varlog/spooler (stored 0%)
  adding: varlog/syslog (deflated 76%)
  adding: varlog/wpa_supplicant.log (deflated 45%)
  adding: varlog/wtmp (deflated 95%)
root@porteus:/mnt/sdb2# ls -lh /usr/local/bin
total 1.7M
-rwxr-xr-x 1 root root  13K Apr 21 11:20 getpkg*
-rwxr-xr-x 1 root root  311 May 13  2011 man*
-rwxrwxrwx 1 root root  24K May 28 22:05 nvidia-bug-report.sh*
-rwxrwxrwx 1 root root  52K May 28 22:05 nvidia-cuda-mps-control*
-rwxrwxrwx 1 root root  36K May 28 22:05 nvidia-cuda-mps-server*
-rwxrwxrwx 1 root root 205K May 28 22:05 nvidia-debugdump*
-rwxrwxrwx 1 root root 341K May 28 22:05 nvidia-installer*
-rwsrwxrwx 1 root root  29K May 28 22:05 nvidia-modprobe*
-rwxrwxrwx 1 root root  34K May 28 22:05 nvidia-persistenced*
-rwxrwxrwx 1 root root 278K May 28 22:05 nvidia-settings*
-rwxrwxrwx 1 root root 460K May 28 22:05 nvidia-smi*
lrwxrwxrwx 1 root root   16 May 28 22:05 nvidia-uninstall -> nvidia-installer*
-rwxrwxrwx 1 root root 184K May 28 22:05 nvidia-xconfig*
-rwxr-xr-x 1 root root   56 Jan  1  2008 pfilesearch*
Ed they are different! I copied what Bogomips put earlier, I have little idea what I'm doing lol :unknown:

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#51 by Bogomips » 02 Jun 2016, 00:34

Ed_P wrote: I could be wrong but I think I'm seeing two different characters at the end of the cp -a /var/log commands. fab1qaz has a comma, while you have a period.
Methinks you be right. Should have tested it before copying over, although mentioned it was a dot. :)

@ fab1qaz
Raided rpm of the same name, so now have couple of extra files for a supplementary module which I wish to run in a diagnostic test. So when you have a moment:
  1. Clear everything out of modules folder, except for nvidia-361.45.11-x86_64.xzm
  2. Download and place in modules folder: nvd_rpm_0.xzm
  3. Reboot to text mode using options 3 copy2ram.
  4. Please print out or jot down the next text mode steps
  5. Log in as guest, and just jot down 1st line of output of each of following statements:

    Code: Select all

    lsmod | grep noubeau
    lsmod | grep nvidia
    
  6. Jot down output of

    Code: Select all

    cat  /etc/ld.so.conf
  7. Enter GUI

    Code: Select all

    su
    init  4
  8. Require output of:

    Code: Select all

    cat /proc/cmdline
    df -h .
    free -m
    cat /var/log/porteus-livedbg
    cp -a /var/log  /mnt/sdc1/porteus/nvd/varlog
    dmesg -e | tail -n40
    
  9. Please just zip: /var/log and upload it, for example:

    Code: Select all

    su
    cp -a /var/log  /mnt/sdb2
    cd  /mnt/sdb2
    zip  log_rpm_0.zip  log/*
    # Also output of:
    nvidia-settings
Thanks.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#52 by fab1qaz » 02 Jun 2016, 20:48

Aaah. Makes sense.
http://s33.postimg.org/u1pgutie7/IMG_1536.jpg

Code: Select all

guest@porteus:~$ cat /proc/cmdline
quiet \boot\syslinux\vmlinuz initrd=boot\syslinux\initrd.xz 3 copy2ram
guest@porteus:~$ df -h .
Filesystem      Size  Used Avail Use% Mounted on
aufs            9.4G  708K  9.4G   1% /
guest@porteus:~$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15952         310       14960         367         681       15106
Swap:             0           0           0
guest@porteus:~$ cat /var/log/porteus-livedbg
# Recognized devices:
/dev/sda1: LABEL="Recovery" UUID="76D6481CD647DACF" TYPE="ntfs" 
/dev/sda2: UUID="DA48-C7CE" TYPE="vfat" 
/dev/sda4: UUID="C6744BD7744BC8BF" TYPE="ntfs" 
/dev/sdb2: LABEL="Data" UUID="F8BA6307BA62C22C" TYPE="ntfs" 
/dev/sdc1: LABEL="UUI" UUID="1BFE-1D65" TYPE="vfat" 

# Booting device:
/mnt/sdc1

# Porteus data found in:
/mnt/sdc1/porteus

# Changes are stored in:
memory

# Non standard /rootcopy dir:
none

# Modules activated during boot time:
/memory/copy2ram/000-kernel.xzm
/memory/copy2ram/001-core.xzm
/memory/copy2ram/002-xorg.xzm
/memory/copy2ram/003-xfce4.xzm
/memory/copy2ram/nvd_rpm_0.xzm
/memory/copy2ram/nvidia-361.45.11-x86_64.xzm
guest@porteus:~$ cp -a /var/log /mnt/sdb2/varlog
cp: cannot open '/var/log/messages' for reading: Permission denied
cp: cannot open '/var/log/syslog' for reading: Permission denied
cp: cannot open '/var/log/debug' for reading: Permission denied
cp: cannot open '/var/log/secure' for reading: Permission denied
cp: cannot open '/var/log/cron' for reading: Permission denied
cp: cannot open '/var/log/maillog' for reading: Permission denied
cp: cannot open '/var/log/spooler' for reading: Permission denied
cp: cannot access '/var/log/setup/tmp': Permission denied
cp: cannot open '/var/log/btmp' for reading: Permission denied
guest@porteus:~$ dmesg -e | tail -n40
[  +0.000045] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:01/input/input8
[  +0.000123] [drm] Initialized i915 1.6.0 20151218 for 0000:00:02.0 on minor 0
[  +0.062425] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[  +0.103922] nvidia: module license 'NVIDIA' taints kernel.
[  +0.000003] Disabling lock debugging due to kernel taint
[  +0.004352] nvidia-nvlink: Nvlink Core is being initialized, major device number 251
[  +0.000053] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffffa0233770)
[  +0.000031] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 1
[  +0.000004] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.45.11  Tue May 17 18:25:03 PDT 2016
[  +0.023471] snd_hda_codec_conexant hdaudioC0D0: CX20751/2: BIOS auto-probing.
[  +0.000358] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20751/2: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[  +0.000002] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x1a
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x18
[  +0.000929] snd_hda_codec_conexant hdaudioC0D0: Enable sync_write for stable communication
[  +0.005322] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9
[  +0.000042] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
[  +0.000037] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[  +0.000037] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[  +0.528021] fbcon: inteldrmfb (fb0) is primary device
[  +0.487052] [drm] RC6 on
[  +0.740892] Console: switching to colour frame buffer device 240x67
[  +0.137751] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[  +0.538897] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.001231] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.007312] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
[  +0.000040] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
[  +0.000001] pcieport 0000:00:1c.0:   device [8086:a112] error status/mask=00000001/00002000
[  +0.000002] pcieport 0000:00:1c.0:    [ 0] Receiver Error        
[  +0.054514] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000807] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.007270] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
[  +0.000004] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
[  +0.000002] pcieport 0000:00:1c.0:   device [8086:a112] error status/mask=00000001/00002000
[  +0.000001] pcieport 0000:00:1c.0:    [ 0] Receiver Error        
[  +0.050108] r8169 0000:03:00.1 eth0: link down
[Jun 2 22:15] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
guest@porteus:~$ nvidia-settings
Xlib:  extension "GLX" missing on display ":0.0".

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation.
       The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and
       descriptions.

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (nvidia-settings:1441): WARNING **: AT-SPI: Could not obtain desktop path or name


** (nvidia-settings:1441): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (nvidia-settings:1441): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (nvidia-settings:1441): WARNING **: atk-bridge: get_device_events_reply: unknown signature

log

Code: Select all

http://www.filedropper.com/log_12
Thanks Bogo!

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#53 by Bogomips » 04 Jun 2016, 00:44

fab1qaz wrote:

Code: Select all

guest@porteus:~$ nvidia-settings
Xlib:  extension "GLX" missing on display ":0.0".

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation.
       The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and
       descriptions.

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
** (nvidia-settings:1441): WARNING **: AT-SPI: Could not obtain desktop path or name
** (nvidia-settings:1441): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature
** (nvidia-settings:1441): WARNING **: atk-bridge: get_device_events_reply: unknown signature
** (nvidia-settings:1441): WARNING **: atk-bridge: get_device_events_reply: unknown signature
On running in terminal as above, did gui come up at all, and if it did, able to display anything?
fab1qaz wrote:log

Code: Select all

http://www.filedropper.com/log_12
would have been easier if link between url tags. Anyway no joy with filedropper: 3 x captcha + (2 x allow filedropper.com cookies + captcha), and nothing! Wikisend much better. :wall:
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#54 by fab1qaz » 04 Jun 2016, 08:09

Yeah the nvidia settings gui came up but didn't have any info on it!

http://www.filedropper.com/log_12

works for me! Click "download this file" then after the captcha click it again.

donald
Full of knowledge
Full of knowledge
Posts: 1175
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: I can't boot please help!

Post#55 by donald » 04 Jun 2016, 08:40

^ -- click on the button (after Captcha), does not work -- press "enter" does.

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#56 by fab1qaz » 05 Jun 2016, 10:12

The driver is almost there and the fan doesn't spin up like in my crude one, but even running Bogo's xzm with the supplementry module in modules folder too I still don't have 3d acceleration working so the screen is choppy. :cry:

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: I can't boot please help!

Post#57 by Bogomips » 05 Jun 2016, 11:11

fab1qaz wrote:The driver is almost there and the fan doesn't spin up like in my crude one, but even running Bogo's xzm with the supplementry module in modules folder too I still don't have 3d acceleration working so the screen is choppy. :cry:
@ fab1qaz
I asked you before to run something graphically demanding, and there has been no feedback until now, You complained before of not being able to use the nvidia settings, but I had to ask you again if you could use them. It is difficcult to help if one is not provided with as much information as possible. It is frustrating as I cannot see your screen.

It would be helpful if you said you were trying to get 3d working as you wished to run application X, which results in choppy screen. Also when you get something to try out, to report whether nvidia settings is working or not. i.e. anything not working before is still not working, or working now. Apart form which I still cannot see your logs as Filedropper is bad news. The two previous sites worked ok.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#58 by fab1qaz » 05 Jun 2016, 13:00

That's because I was having problems with VirtualBox until today. I've never used linux before and VirtualBox tells me specifically the 3d acceleration isn't working. Effectively the driver modules does the same as blacklist.xzm (not making my fan go crazy) but either of them still don't give me any nVidia features of my card so I couldn't say there's been any improvement since or I'd be lying. :wink:

Here's that log zip on wikisend, no captchas! :good:
log.zip

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Further Test

Post#59 by Bogomips » 05 Jun 2016, 18:08

fab1qaz wrote:That's because I was having problems with VirtualBox until today. I've never used linux before and VirtualBox tells me specifically the 3d acceleration isn't working.
No need to lie, just say: tried virual box, virtual box needs 3d accel, informs not working, and screen choppy. As I said before just say working or not working, then we know where we stand. The supplementary module was a test to collect data, and not a solution.
fab1qaz wrote:Here's that log zip on wikisend, no captchas! :good:
log.zip
Thanks. No problem downloading. :)

Further Test
  1. Replace in modules folder, nvd_rpm_0.xzm by nvd_rpm_1.xzm
  2. Reboot using option copy2ram.
  3. Require output of:

    Code: Select all

    cat  /proc/cmdline
    df -h .
    free -m
    cat /var/log/porteus-livedbg
    cat  /etc/ld.so.conf
    dmesg -e | tail -n 60
    
  4. Please just zip: /var/log and upload it, for example:

    Code: Select all

    su
    lsmod > lsmod.txt
    zip   log.zip   /var/log/*   lsmod.txt
  5. Also output of:

    Code: Select all

    ls /mnt/live/memory/images/
    nvidia-settings
BTW there is nothing to stop you from installing the driver anew whenever you wish to run VirtualBox:
  1. Clear modules out of modules folder
  2. Place in modules folder: 06-devel.xzm, crippled_sources.xzm, blacklist.xzm, and any other modules required to run VirtualBox.
  3. Reboot to test mode with options 3 copy2ram
  4. In text mode cd to extracted directory (no need to extract again)

    Code: Select all

    su
    ./nvidia-installler
  5. Enter GUI

    Code: Select all

    init  4
  6. In GUI would be helpful if data could be collected as requested in #3, #4, #5 above for the Further Test.
  7. Test out VirtualBox, etc.
Last edited by Bogomips on 06 Jun 2016, 19:07, edited 1 time in total.
Reason: Further Test
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fab1qaz
Black ninja
Black ninja
Posts: 65
Joined: 26 May 2016, 13:32
Distribution: Desktop 3.1
Location: England

Re: I can't boot please help!

Post#60 by fab1qaz » 05 Jun 2016, 21:07

log.zip

Code: Select all

guest@porteus:~$ cat  /proc/cmdline
quiet \boot\syslinux\vmlinuz copy2ram initrd=boot\syslinux\initrd.xz
guest@porteus:~$ df -h .
Filesystem      Size  Used Avail Use% Mounted on
aufs            9.4G  6.4M  9.4G   1% /
guest@porteus:~$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15952         331       14586         607        1035       14823
Swap:             0           0           0
guest@porteus:~$ cat /var/log/porteus-livedbg
# Recognized devices:
/dev/sda1: LABEL="Recovery" UUID="76D6481CD647DACF" TYPE="ntfs" 
/dev/sda2: UUID="DA48-C7CE" TYPE="vfat" 
/dev/sda4: UUID="C6744BD7744BC8BF" TYPE="ntfs" 
/dev/sdb2: LABEL="Data" UUID="F8BA6307BA62C22C" TYPE="ntfs" 
/dev/sdc1: LABEL="UUI" UUID="1B08-3076" TYPE="vfat" 

# Booting device:
/mnt/sdc1

# Porteus data found in:
/mnt/sdc1/porteus

# Changes are stored in:
memory

# Non standard /rootcopy dir:
none

# Modules activated during boot time:
/memory/copy2ram/000-kernel.xzm
/memory/copy2ram/001-core.xzm
/memory/copy2ram/002-xorg.xzm
/memory/copy2ram/003-xfce4.xzm
/memory/copy2ram/05-devel.xzm
/memory/copy2ram/VeraCrypt.xzm
/memory/copy2ram/VirtualBox-5.0.20-porteus-v3.2-x86_64-1prt.xzm
/memory/copy2ram/crippled_sources.xzm
/memory/copy2ram/google-chrome-50.0.2661.94-x86_64-1.xzm
/memory/copy2ram/nvd_rpm_1.xzm
/memory/copy2ram/nvidia-361.45.11-x86_64.xzm
/memory/copy2ram/torguard-latest-amd64.xzm
guest@porteus:~$ cat  /etc/ld.so.conf
/lib64
/usr/lib64
/usr/local/lib64
/usr/x86_64-slackware-linux/lib64
/lib
/usr/lib
/usr/local/lib
guest@porteus:~$ dmesg -e | tail -n 60
[  +0.000353] asus_wmi: Initialization: 0x1
[  +0.000018] asus_wmi: BIOS WMI version: 7.9
[  +0.000017] asus_wmi: SFUN value: 0xa0077
[  +0.000456] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input6
[  +0.000468] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[  +0.002130] asus_wmi: Number of fans: 1
[  +0.000238] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.001487] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.018524] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
[  +0.000008] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
[  +0.000002] pcieport 0000:00:1c.0:   device [8086:a112] error status/mask=00000001/00002000
[  +0.000002] pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
[  +0.047146] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[  +0.001864] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input7
[  +0.000104] ACPI Exception: AE_NOT_FOUND, Evaluating _DOD (20160108/video-1248)
[  +0.000003] ACPI: Video Device [PEGP] (multi-head: no  rom: yes  post: no)
[  +0.000071] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:01/input/input8
[  +0.009807] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[  +0.161470] pmd_set_huge: Cannot satisfy [mem 0xb0000000-0xb0200000] with a huge-page mapping due to MTRR override.
[  +0.000127] fbcon: inteldrmfb (fb0) is primary device
[  +0.012137] nvidia: module license 'NVIDIA' taints kernel.
[  +0.000001] Disabling lock debugging due to kernel taint
[  +0.004147] nvidia-nvlink: Nvlink Core is being initialized, major device number 251
[  +1.420813] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffffa0426770)
[  +0.000009] [drm] Initialized i915 1.6.0 20151218 for 0000:00:02.0 on minor 0
[  +0.000107] Console: switching to colour frame buffer device 240x67
[  +0.000147] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 1
[  +0.000008] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.45.11  Tue May 17 18:25:03 PDT 2016
[  +0.021977] snd_hda_codec_conexant hdaudioC0D0: CX20751/2: BIOS auto-probing.
[  +0.000298] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20751/2: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[  +0.000000] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x1a
[  +0.000001] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x18
[  +0.000906] snd_hda_codec_conexant hdaudioC0D0: Enable sync_write for stable communication
[  +0.005664] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9
[  +0.000069] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
[  +0.000047] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[  +0.000045] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[  +0.022777] [drm] RC6 on
[  +0.100093] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[  +0.098155] vboxdrv: Found 8 processor cores
[  +0.015567] vboxdrv: TSC mode is Invariant, tentative frequency 2591998669 Hz
[  +0.000002] vboxdrv: Successfully loaded version 5.0.20 (interface 0x00240000)
[  +0.202598] VBoxNetFlt: Successfully started.
[  +0.001124] VBoxNetAdp: Successfully started.
[  +0.000964] VBoxPciLinuxInit
[  +0.000878] vboxpci: IOMMU not found (not registered)
[  +0.214637] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000444] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.060878] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.000446] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  +0.007397] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
[  +0.000007] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
[  +0.000002] pcieport 0000:00:1c.0:   device [8086:a112] error status/mask=00000001/00002000
[  +0.000002] pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
[  +0.052626] r8169 0000:03:00.1 eth0: link down
[  +3.435303] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
guest@porteus:~$ su
Password: 
root@porteus:/home/guest# lsmod > lsmod.txt
root@porteus:/home/guest# zip log.zip /var/log/* lsmod.txt
  adding: var/log/ConsoleKit/ (stored 0%)
  adding: var/log/Xorg.0.log (deflated 79%)
  adding: var/log/btmp (stored 0%)
  adding: var/log/cron (deflated 9%)
  adding: var/log/debug (deflated 84%)
  adding: var/log/dmesg (deflated 74%)
  adding: var/log/faillog (stored 0%)
  adding: var/log/lastlog (stored 0%)
  adding: var/log/maillog (stored 0%)
  adding: var/log/messages (deflated 81%)
  adding: var/log/nfsd/ (stored 0%)
  adding: var/log/packages/ (stored 0%)
  adding: var/log/pm-powersave.log (deflated 84%)
  adding: var/log/porteus-livedbg (deflated 53%)
  adding: var/log/removed_packages/ (stored 0%)
  adding: var/log/removed_scripts/ (stored 0%)
  adding: var/log/samba/ (stored 0%)
  adding: var/log/scripts/ (stored 0%)
  adding: var/log/secure (deflated 54%)
  adding: var/log/setup/ (stored 0%)
  adding: var/log/slim.log (deflated 2%)
  adding: var/log/spooler (stored 0%)
  adding: var/log/syslog (deflated 76%)
  adding: var/log/wpa_supplicant.log (deflated 70%)
  adding: var/log/wtmp (deflated 95%)
  adding: lsmod.txt (deflated 68%)

root@porteus:/home/guest# ls /mnt/live/memory/images/
000-kernel.xzm/  VirtualBox-5.0.20-porteus-v3.2-x86_64-1prt.xzm/
001-core.xzm/    crippled_sources.xzm/
002-xorg.xzm/    google-chrome-50.0.2661.94-x86_64-1.xzm/
003-xfce4.xzm/   nvd_rpm_1.xzm/
05-devel.xzm/    nvidia-361.45.11-x86_64.xzm/
VeraCrypt.xzm/   torguard-latest-amd64.xzm/
root@porteus:/home/guest# nvidia-settings
Xlib:  extension "GLX" missing on display ":0.0".
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (nvidia-settings:1634): WARNING **: AT-SPI: Could not obtain desktop path or name


** (nvidia-settings:1634): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (nvidia-settings:1634): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (nvidia-settings:1634): WARNING **: atk-bridge: get_device_events_reply: unknown signature
Aah I deleted that nvidia folder, will try from scratch tomorrow.

Post Reply