Mein erster Eindruck (und Fragen)

Willkommen!
fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Mein erster Eindruck (und Fragen)

Post#1 by fred08155 » 10 May 2016, 10:51

Nach einigen Jahren ganz ohne Linux wollte ich es mal wieder probieren. Für den Anfang dachte ich an was kleines schnelles das vom USB-Stick läuft.
Die Bedingungen erfüllt Porteus schonmal. Nur mit einigen Dingen komme ich noch nicht so ganz klar.
Zum Beispiel mit der Installation neuer Software... ich habe mir einige Pakete aus dem Internet geladen, diese funktionieren alle auch ganz odentlich.
Einziges Manko ist dass wohl die Lokalisierungen oder Sprachdateien weggelassen wurden, sodaß die Software ausschließlich auf englisch läuft.
Für mich persönlich ist das nicht so tragisch. Allerdings hat mein Bruder mich mal nach Linux gefragt - ich soll ihm da was auf den Laptop knallen, damit er das Programm Darktable und andere Programme benutzen kann.

Ausprobiert hab ich erstmal das 3.1 Release mit KDE Desktop.
Was leider nur sehr schlecht funktioniert ist das hinzufügen von Software über den Paketmanager. Man kann damit wohl grundsätzlich nur Dateien herunterladen und ggf gleich in XZM Module verwandeln. Und selbst da hakt es ziemlich.
Ich habe schon mehrfach versucht Gimp drauf zu bringen. Also Pakete runtergladen und zu einem großen XZM Modul mergen lassen. Bzw zu zwei, nach dem Mergen war da ein Gimp xzm und ein Gimp_Bundle.xzm.
Versuche ich das Bundle zu aktivieren kommt eine Fehlermeldung dass ein Modul auf XZM enden muss. Das tut es aber schon, was soll die Meldung?
Von drei so erstellten Modulen funktioniert gerade mal ein einziges. Habe es noch mit Darktable versucht (hat geklappt, spricht aber wieder nur englisch) und mit Rawtherapee (gleiche Meldung wie bei Gimp).

Was mache ich falsch? Wieso funktionieren nur die Module, die ich fertig runtergeladen habe? Mach ich überhaupt was falsch oder ist das System noch so unausgegoren?

Gleiches mit Installation von Slackware Paketen. Slackware-Paket für Gimp runtergeladen, rechte Maustaste, installieren lassen. Es kommt sofort ein Fenster "installation complete" oder ähnlich.
Im Startmenü ins Suchfeld Gimp eingegeben - es wird nur das Slackware Paket, meine selbsterstellten XZMs und mein selbsterstellter Ordner namens Gimp angezeigt.
Muss ich nach dem installieren noch was frickeln um das Programm starten zu können?
Mit dem fertig runtergeladenen Gimp hat es funktioniert. Modul vorher ins module Verzeichnis gepackt und nach dem booten Ins Suchfeld Gimp eingegeben, kommt sofort eine Option "Run Gimp". Draufgeklickt und Programm wird geladen - nur halt komplett auf englisch und ohne Möglichkeit es auf Deutsch umzustellen (Menüpunkt fehlt komplett).

Alternativ hab ich die Tage mit PCLinuxOS gespielt. Das ist nicht so klein und schnell, dafür funktioniert alles auf Anhieb.
System einmal auf Deutsch umgestellt - so gut wie alles deutsch.
Software über den Paketmanager heruntergeladen - klappt. Wird sofort installiert.
Darktable funzt, Ratherapee funzt, Gimp funzt, zudem gibt es noch fast ein Gigabyte Plugins für Gimp. Alles was ich bisher nachinstalliert habe läuft auf Anhieb und spricht Deutsch.
Und das alles läuft in akzeptabler Geschwindigkeit direkt vom USB-Stick. Und das alles obwohl es sich bei dem ganzen um das Pre-Release mit KDE5 Desktop handelt.
Hab aber auch das normale Release mit XFCE statt KDE probiert. Auch hier läuft alles problemlos.

Ganz aufgegeben habe ich Porteus aber noch nicht. Ich schau mir mal die neue RC an und vielleicht noch Porteus Nemesis.
Vielleicht habt ihr auch noch den einen oder anderen Tipp für mich.

donald
Full of knowledge
Full of knowledge
Posts: 1158
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#2 by donald » 10 May 2016, 16:58

Hallo Fred

Jo jo..malen nach Zahlen...äh..basteln mit Linux.

Ne, im Ernst, du hast ja 'ne Menge geschrieben, leider mit wenig konkreten Informationen,ne.
als da wären:
32 Bit oder 64 Bit?
Ist Porteus selbst schon in deutsch?
welches modul hast du runter geladen, dieses?.. für 32 Bit !
viewtopic.php?f=51&t=5361&sid=58d208eb0 ... fec#p40496
Wenn ja, schau mal in dem kleinen Fenster unter:
Edit > preferences > interface > language

mit 64 Bit Software / System kann ich dir nich' behilflich sein, hab ich nich'.

Porteus ist / war gedacht als kleines portables System (zum mitnehmen), obwohl
es wohl auch von vielen Usern "stationär" eingesetzt wird.
Na wie auch immer, das Konzept mit den (Software) Modulen ist schon (fast) einzigartig
und erfordert sicherlich eine gewisse Einarbeitungszeit und / oder Umdenken; da
Software eben nicht installiert (im herkömmlichen Sinne), sondern in Module
verpackt und nur bei tatsächlichem Bedarf aktiviert / deaktiviert wird.

So, erstmal genug geschwafelt, Ich will dich ja nicht vergraulen... :)
Last edited by donald on 16 May 2016, 16:03, edited 1 time in total.

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#3 by fred08155 » 11 May 2016, 07:26

Hatte ich doch glatt ein paar Details vergessen. Ich hab die 64 Bit Variante genommen, das ganz normale Release. Ein deutsches gibts ja nur als Community Release.
Porteus habe ich nachträglich eingedeutscht mit einem KDE locales Modul und dann in den Einstellungen die neue Sprache aktiviert.
Ne, Gimp hab ich mir woanders gezogen. Im englischen Forum gibts da ein Thema Module für Porteus 3.1. Dort widerum verlinkt jemand auf sein Yandex Drive. Dort hab ich unter anderem das Gimp Modul gezogen.

Ist die Unterstützung bei der 32bit-Version besser als bei 64bit??
Da mein Prozessor 64bit kann und ich 4GB RAM verschraubt habe dachte ich ich wär mit der 64-bittigen Variante besser bedient.

Was mich auch etwas wundert ist dass es für Firefox locales Module gibt, auch ein deutsches, ich nachher nach dem aktivieren aber nirgends ne Möglichkeit sehe Firefox auf deutsch umzustellen. Letztendlich hab ich mir das "normale" Language addon für deutsch installiert und aktiviert. Das funzt jetzt.

donald
Full of knowledge
Full of knowledge
Posts: 1158
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#4 by donald » 11 May 2016, 16:20

Hallo Fred

Ist dein GIMP jetzt in deutsch oder nich'?

Warum ich frage?
Nun, ich hab mir den Spaß gegönnt und schnell mal ein KDE-64 Bit auf einem alten
usb-stick installiert und dann folgende Module geholt:

gimp-2.8.16-x86_64-1_all.xzm -- von dem yandisk link (ztrapl)
07-printing.xzm -- braucht man wohl wegen "Python"
--------------------------------------------------------------------------------------------------------
man kann sich "Python" auch anderweitig ins System holen, aber so weit wollte ich
nun doch nicht gehen, so war's am einfachsten.
Brauchen tut man es schon -- wenn man GIMP im Terminal startet, sieht man jede Menge
Error Meldungen ohne Python, mit Python keine.
--------------------------------------------------------------------------------------------------------
ach ja, und den nvidia Treiber; aber den brauche wohl nur ich, weil 3.1 sonst hier nicht bootet.

Alles im Modules folder (= Ordner,wir sprechen hier ja deutsch,ne) > Netz eingerichtet > Porteus settings center aufgerufen,
"language setup" > angekreuzt das ich aussuchen möchte, Kde Printing und devel gewählt >
Hat ein weilchen rumgerödelt und am Ende hatte ich ein "locales-de_DE.utf8-x86_64-1prt.xzm"
im Modules Ordner liegen. > Neustart uuuunnnd BINGO

Image
draufklicken zum vergrößern.. :wink:

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#5 by fred08155 » 11 May 2016, 17:12

Bisher iss mein Gimp noch englisch.
Beim eindeutschen von Porteus is wohl was falsch gelaufen. Ich hab ein fertiges Modul vom Porteus Server geladen - kde-l10n-de-4.14.3-noarch-1alien.xzm
Mal schauen ob ichs auch so hinbringe wie dus beschrieben hast.
Wenn dann noch das basteln von Modulen mal ordentlich funktioniert iss Porteus gekauft. Praktischerweise isses gratis. :P

Hast auch ma probiert ein eigenes Gimp oder Rawtherapee Modul zu backen? ;)

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#6 by fred08155 » 15 May 2016, 10:57

Umstellung auf deutsch hat jetzt funktioniert. Hab auf die schnelle nur den einen Stick gefunden auf den ich das custom build aufgespielt habe.
Scheinbar wird hier aber Gnome gestartet obwohl ich auf der Porteus Seite KDE ausgewählt hatte...
Die Erstellung von XZM Modulen funktioniert auf dem custom build offensichtlich überhaupt nicht.
Hab alle drei Module die ich vorher schon probiert hatte zu erstellen nochmal probiert neu zu machen, da diese auf dem Stick nicht drauf sind.
Ergebnis:
Gimp startet nicht - keine Fehlermeldung gar nüscht
Rawtherapee startet nicht - dito
Darktable läuft ebensowenig - das selbe in grün

Zumindest Darktable hat auf dem anderen Stick mit dem "normalen" Release funktioniert.
Einziger Wehrmutstropfen ist dass jetzt tatsächlich die Sprachauswahl bei Gimp funktioniert. Wo vorher nur "System Language" und Englisch stand ist jetzt eine lange Liste an Sprachen auswählbar.

Ein weiteres Modul hab ich noch geschnürt und das hat sogar ausnahmsweise funktioniert. Hab mir den Krusader Dateimanager gezogen, da dieses Ding wohl auch ISO Dateien öffnen kann. Beim nackten Porteus Custom Build habe ich nichts gefunden um ISO Dateien zu öffnen oder zu extrahieren. Die ISO konnte lediglich gemountet werden was jedoch fehlschlug. Es kam eine Meldung, dass die ISO unter /mnt/loop/ eingehängt wäre - da war aber nüscht!

Mit Krusader konnte ich dann endlich mein Vorhaben beenden - die Porteus 3.2 RC2 auf einen anderen Stick zu hauen und bootfähig zu machen.
Leider ist die RC noch sehr unfertig und es gehen weder Spracheinstellungen noch das erstellen von XZM Modulen. Versuche ich ein XZM zu erstellen gehen zunächst alle Downloads in sekundenschnelle, danach wird fleißig merging... angezeigt und am Ende habe ich nur eine einzige Datei die nicht funktioniert und auch nur 4kB groß ist.

Ich kämpfe mich mal weiter durch aber der Eindruck von Porteus hat sich nicht wesentlich verbessert. Scheinbar funktioniert in jedem Release / Build irgendwas nicht, ist falsch voreingestellt oder ähnliches.

Funktioniert das erstellen von XZM Modulen bei der 32bit Version besser oder verwendet ihr alle nur vorgefertigte XZMs???
Warum ist eigentlich die aktuellste verfügbare Firefox Version so steinalt?
Unter PCLinuxOS hab ich sofort das aktuellste Update da, momentan die 46.0.1, bei Porteus ist das neueste was mir von USM angeboten wird ne uralte 30er Version (wars v33 oder v35?).

Bogomips
Full of knowledge
Full of knowledge
Posts: 2539
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Mein erster Eindruck (und Fragen)

Post#7 by Bogomips » 15 May 2016, 14:12

fred08155 wrote:Beim nackten Porteus Custom Build habe ich nichts gefunden um ISO Dateien zu öffnen oder zu extrahieren. Die ISO konnte lediglich gemountet werden was jedoch fehlschlug. Es kam eine Meldung, dass die ISO unter /mnt/loop/ eingehängt wäre - da war aber nüscht!
Bei mir kommt eine andere Meldung:

Code: Select all

guest@porteus:~$ mkdir z
guest@porteus:~$ sudo mount p10/tmp/iso/rc2/x86_64/Porteus-KDE-v3.2rc2-x86_64.iso zmount: /dev/loop8 is write-protected, mounting read-only                           
guest@porteus:~$ tree -d z
z                                                                                  
|-- EFI                                                                            
|   `-- BOOT                                                                       
|       |-- drivers_x64                                                            
|       `-- icons                                                                  
|-- boot                                                                           
|   |-- docs                                                                       
|   `-- syslinux                                                                   
`-- porteus                                                                        
    |-- base                                                                       
    |-- modules                                                                    
    |-- optional                                                                   
    `-- rootcopy                                                                   
                                                                                   
12 directories                      
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#8 by fred08155 » 15 May 2016, 15:28

So kann das ja jeder, wenn man mit irgendwelchen Kommandozeilentools rumtrickst.
Ich hab die ISO über rechte Maustaste gemountet - und da kam diese Meldung. Trotzdem war im Dateimanager unter besagter Adresse nichts zu finden!!!
Wenn mir die GUI von Porteus ein mounten anbietet, es aber nicht korrekt ausführt, ist hier eindeutig Porteus der Schuldige.
Als Linux-Anfänger hab ich von dem ganzen Kommandozeilen-Zeug keine Ahnung. ;)

Bogomips
Full of knowledge
Full of knowledge
Posts: 2539
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Mein erster Eindruck (und Fragen)

Post#9 by Bogomips » 15 May 2016, 15:36

fred08155 wrote:Als Linux-Anfänger hab ich von dem ganzen Kommandozeilen-Zeug keine Ahnung. ;)
Dann wissen wir es bescheid. :)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

donald
Full of knowledge
Full of knowledge
Posts: 1158
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#10 by donald » 15 May 2016, 16:54

@ Fred

was für ein Kuddelmuddel...
Bleib mal bei 3.1 und 64 Bit
so, die Umstellung auf deutsch + gimp hatten wir ja schon..
Hast du jetzt das richtige gimp module = gimp-2.8.16-x86_64-1_all.xzm..von ztrapl..??
also brauchst du noch rawtherapee + darktable.
HOWTO:
mit dem netz verbinden > USM aufrufen > updates = update all > wenn fertig USM schliessen.
USM wieder aufmachen > darktable eingeben, keyword anklicken > search.
gewünschte version auswählen > download, nach und nach werden die Abhängigkeiten
aufgelistet.Wenn USM damit durch ist siehst du noch mal eine Zusammenfassung.
Bestätigen und los geht's,
ach ja, nicht vergessen die umwandlung in Module anzuhaken und die Merge module
option, sofern man es denn will.
Das selbe gilt für rawtherapee.

Darktable
Image

rawtherapee
Image

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#11 by fred08155 » 15 May 2016, 17:54

Genau so hab ich es auch gemacht. Zuerst hab ich das USM Programm upgedatet, dann die Paketquellen, danach den entsprechenden Begriff in die Suche eingegeben und die ganzen Abfragen mit OK bestätigt, alle drei Optionshaken rein und ab dafür. Rausgekommen sind funktionsunfähige Module - bis auf Krusader.
Alles unter 3.1 64bit.
Irgendnen Bug muss auch das USM haben denn jedes Mal wenn ich einen Download starte kommt eine Meldung dass Updates durchgeführt werden sollen obwohl ich gerade vorher erst alle Quellen aktualisieren lassen habe!

Die RC hab ich nur kurz angetestet und festgestellt dass die Modulerstellung überhaupt nicht geht. Es wird offensichtlich nichts heruntergeladen.

Vielleicht mach ich als nächstes mal den Stick platt und setz alles neu auf. Bei Windows hilfts ja manchmal, wenns rumzickt. ^^

donald
Full of knowledge
Full of knowledge
Posts: 1158
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#12 by donald » 15 May 2016, 21:10

Krusader kannste vergessen.
Ich kann es zwar starten..ABER..es zerschießt sofort das KDE (start) menü und mehr.
-- alle Anwendungen (Programme) sind nicht mehr zu sehen und wenn man Krusader
im terminal startet, gibt es bergeweise fehlermeldungen..no, thanks. :bad:

Noch'n tipp, um mir nicht mein gut laufendes system durch solche Experimente
zu versauen, baue (USM) und teste ich neue module auf ihre Funktion / Tauglichkeit
ausschließlich im "always fresh" boot modus, dann kann nix passieren. :D

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#13 by fred08155 » 16 May 2016, 09:28

Hab nochmal nen Fehler gefunden. bei genauerer Betrachtung ist der Stick mit dem custom build mit der Oberflaeche XFCE ausgestattet. Deshalb laedt da wohl gnome. Hier funktioniert das heruntergeladene Gimp Paket.
Auf dem anderen Stick mit KDE bekomme ich kein Gimp zum laufen.
Dafuer laufen hier Darktable und nach drei weiteren Versuchen der XZM Erstellung nun auch Rawtherapee.
Kopiere ich diese funktionierenden Module auf den Stick mit XFCE laufen diese dort leider nicht.

Muessen die Pakete fuer jede Oberflaeche neu gebastelt werden?

Beide Sticks wurden mit Porteus 3.1 64bit bespielt. Nur einmal als FAT32 mit YUMI (custom build XFCE) und einmal ext3 unter Linux vom anderen Porteus Stick aus erzeugt (Release KDE).

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#14 by fred08155 » 16 May 2016, 09:50

Ich glaub jetzt hab ichs soweit repariert. :)
Hab mir die Module der anderen Oberflächen und deren locales Module runtergeladen und in den module Ordner gepackt.
Siehe da - auf meinem custom build XFCE Stick laufen jetzt Gimp, Darktable und auch Rawtherapee.
Im Menü sind wesentlich mehr Programme verfügbar. Die GUI hat sich auch verändert, auch farblich (warum auch immer). Firefox wurde in der Taskleisste durch Opera verdrängt etc.. Aber damit kann ich leben.
Werde das System jetzt auf nem größeren Stick neu aufsetzen und die ganzen Module rüberkopieren. Mit den ganzen Oberflächen ist der Stick jetzt fast am Limit, is ja auch ein oller 2GB Stick.
Nur schade dass die Software teilweise so steinalt ist (z.B. Firefox 33.0, Update auf 38.3 verfügbar - das ist auch schon gut ein dreiviertel Jahr alt).

fred08155
Black ninja
Black ninja
Posts: 56
Joined: 22 Apr 2016, 07:11
Distribution: Porteus 3.2.2 xfce
Location: Germany

Re: Mein erster Eindruck (und Fragen)

Post#15 by fred08155 » 16 May 2016, 10:32

Beim XFCE Stick hats funktioniert, beim KDE Stick bin ich mit dem Ergebnis nicht zufrieden.
Hab das gleiche oben beschriebene Verfahren angewendet.

Zum einen laeuft Gimp immer noch nicht und andererseits startet das System ploetzlich mit XFCE statt KDE.
Habe bisher auch noch keine Moeglichkeit gefunden da was umzustellen.
Ich wuerde gerne bei KDE bleiben. Und Gimp haett ich auch gern.
Das Gimp Modul das auf dem XFCE Stick laeuft ist hier auch drauf und es kommt keine Fehlermeldung beim booten. Bei nem Doppelklick auf das Modul kommt der Standardtext dass dieses Modul bereits aktiviert ist und ob man es deaktivieren moechte. Im Grafik Menue ist aber kein Gimp und wenn ich es ins Suchfeld im Startmenue eingebe wird auch kein Gimp gefunden. Is doch echt zum Haare raufen mit Porteus.

Post Reply