After install no reconfiguration

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
lemon
White ninja
White ninja
Posts: 9
Joined: 02 Dec 2015, 13:46
Distribution: Slackware
Location: ITALY

After install no reconfiguration

Post#1 by lemon » 08 Mar 2016, 15:41

Hi everybody,

I've already set up a few weeks ago PK on a computer that was connected directly to the internet, no problem there.
No I've tried to install PK on a computer that is connected through a proxy. When I set the proxy during the installation everything works fine, Firefox is being downloaded, configuration is loaded from a web server and ISO is being written.
After rebooting I I can see on the web server that the configuration is being read, but the PK computer just says "performing system reconfiguration" and then instantly "porteus-kiosk.org is not accessible" and opens Firefox with a proxy error. Very strange. Proxy settings are correct.
The thing I cannot understand is why PK does not reconfigure after having loaded the configuration file from webserver. When I try to type the URL in the address bar I have configured on the webserver's file I can reach it without problems, so proxy configuration seems to be ok.
Any idea?

Thank you very much!


EDIT: after having set the "homepage" parameter during installation the correct website is loaded by PK, but no reconfiguration has been initiated. Anyway, before showing the correct website the two messages ("system performs reconfiguration..." and "porteus-kiosk is not accessible") are still showed but no restart has been done.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: After install no reconfiguration

Post#2 by fanthom » 08 Mar 2016, 16:29

Please send me an URL to your remote kiosk config on support@porteus-kiosk.org and i'll try to recreate your issue.

Thank you.
Please add [Solved] to your thread title if the solution was found.

lemon
White ninja
White ninja
Posts: 9
Joined: 02 Dec 2015, 13:46
Distribution: Slackware
Location: ITALY

Re: After install no reconfiguration

Post#3 by lemon » 08 Mar 2016, 16:38

Hi fanthom,

I'll send you the configuration file here as you cannot access to original one on our intranet:

Code: Select all

# NETWORK
connection=wired
network_interface=eth0
dhcp=yes
kiosk_config=http://100.1.18.49/porteus-test.txt
allow_icmp_protocol=yes
primary_keyboard_layout=de:nodeadkeys
proxy=**username**:**password**@proxy:3128
wake_on_lan=yes
# BROWSER
browser=firefox
homepage=http://www.google.com
disable_address_bar=yes
#disable_navigation_bar=yes
#disable_private_mode=yes
#persistence=session
# GENERAL
#hide_mouse=yes
right_mouse_click=yes
timezone=Europe/Rome
additional_components=uefi.zip 09-x11vnc.xzm 08-ssh.xzm
vnc_password=somepass
primary_keyboard_layout=de
# SSH
root_password=some_password
ssh_port=22
Obviously I have set the correct user and password for the proxy.

Thank you very much!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: After install no reconfiguration

Post#4 by fanthom » 08 Mar 2016, 20:55

Please send me it as .txt as it could be a formatting issue (kiosk does not support unicode).

Thank you.
Please add [Solved] to your thread title if the solution was found.

lemon
White ninja
White ninja
Posts: 9
Joined: 02 Dec 2015, 13:46
Distribution: Slackware
Location: ITALY

Re: After install no reconfiguration

Post#5 by lemon » 09 Mar 2016, 11:19

Hi fanthom,

this is exactly the same txt-file I've used for another test installation (the one with direct internet access), I only added the proxy parameter.
Here you can find this file: http://www.filedropper.com/porteus-conf

But I still cannot understand why PK wants to open porteus-kiosk.org and not the homepage I've set (www.google.com). When I type the URL in the address bar Google is loaded, but first I get that error with the porteus-kiosk.org-website (and the configuration is not being updated).

Thank you very much!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: After install no reconfiguration

Post#6 by fanthom » 09 Mar 2016, 18:20

I guess its about incorrect formatting of the config. See this screenshot and note first character which is not alphanumeric:

Code: Select all

http://porteus-kiosk.org/public/files/bad_config_formatting.png
Please remove this character and try again. let me know if that helped.

Thank you.
Please add [Solved] to your thread title if the solution was found.

lemon
White ninja
White ninja
Posts: 9
Joined: 02 Dec 2015, 13:46
Distribution: Slackware
Location: ITALY

Re: After install no reconfiguration

Post#7 by lemon » 09 Mar 2016, 18:38

Well, this character is not present in my config. I've also tried to download the file I indicated you but I cannot see any "." at the beginning.
If I connect that computer directly to the internet and remove the "proxy" parameter everything works fine, so I don't think it is a conf-file issue.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4617
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: After install no reconfiguration

Post#8 by fanthom » 10 Mar 2016, 16:38

I have just tested your config and it works fine with my own proxy.

System must contact porteus-kiosk.org in order to download additional modules: 08-ssh.xzm and 09-x11vnc.xzm.
Perhaps your proxy is blocking these modules and thats why reconfiguration fails?
As you noted already - its definitely your proxy filtering fault.

Thank you.
Please add [Solved] to your thread title if the solution was found.

lemon
White ninja
White ninja
Posts: 9
Joined: 02 Dec 2015, 13:46
Distribution: Slackware
Location: ITALY

Re: After install no reconfiguration

Post#9 by lemon » 10 Mar 2016, 16:45

Ok, now I understand why PK wants to contact that site.

Thank you very much!!!

Post Reply