Problems installing new package using USM

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
pacosoeda
Ronin
Ronin
Posts: 3
Joined: 18 Feb 2016, 21:08
Distribution: Porteus xfce 32 bits
Location: Spain

Problems installing new package using USM

Post#1 by pacosoeda » 18 Feb 2016, 21:14

Hi,

I have been trying to install a new package with the USM . I don't know why but everytime I try I get the same error message , This is a paste of the complete process :

root@porteus:/home/guest# usm -g timidity

The following items were found.
Choose an number to confirm.
ctrl+c to quit

1) TiMidity++-2.14.0-i486-3ponce.txz
#? 1

Processing: TiMidity++-2.14.0-i486-3ponce.txz
Ignored libraries:

Libraries required: 76
Libraries found in system: 73
Libraries to resolve: 3

Processing library: libXm.so.2
Processing library: libtcl.so
Processing library: libtk.so


Processing: lesstif-0.95.2-i486-1.txz
Ignored libraries:

Libraries required: 18
Libraries found in system: 16
Libraries to resolve: 2

Processing library: libMrm.so.2
Processing library: libXm.so.2


Processing: brlcad-7.24.2-i486-2_slack.txz


==============================================================================
WARNING! WARNING! WARNING! WARNING! WARNING!
==============================================================================
One or more errors occurred while usm was running:

FATAL ERROR!
resolve_deps 390
Please wait 6 hours for the next database update. Could not find: LIBS.TXT


So , As you can see there is always fatal error concerning resolve_deps 390 which I don't have any clue what is about and besides it cannot find the libs.txt and again I have no clues what it is talking about.

Could you please give me any tips on how to resolve this?

Thx in advance.

Regards

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Problems installing new package using USM

Post#2 by brokenman » 18 Feb 2016, 21:17

Could you please give me any tips on how to resolve this
Please wait 6 hours for the next database update. Could not find: LIBS.TXT

If it persists after one day please post again. The database is automated. Updated daily.
How do i become super user?
Wear your underpants on the outside and put on a cape.

pacosoeda
Ronin
Ronin
Posts: 3
Joined: 18 Feb 2016, 21:08
Distribution: Porteus xfce 32 bits
Location: Spain

Re: Problems installing new package using USM

Post#3 by pacosoeda » 18 Feb 2016, 21:41

Hi again ,

First of all , thanks for the fast reply!

I will wait as you say and post with the updates but in the mean time could you explain what is this libs.txt file that is mentioning? Because It has happened to me with other packages as well and a few days ago.

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Problems installing new package using USM

Post#4 by francois » 19 Feb 2016, 02:01

The database was not well updated. :)
Voltaire: Le mieux est l'ennemi du bien.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Problems installing new package using USM

Post#5 by brokenman » 19 Feb 2016, 15:32

In order to have USM resolve dependencies across 5 repositories we have to generate a file containing every library that a package needs, and every library that a package wants. This is stored in a file called LIBS.TXT. Occasionally a repository changes their content before the server runs its daily update. In this case you get the error message you saw. If the error persists, then it could be that the server didn't process the updates for some reason in which case I need to look further into it. I hope this clears things up for you.
How do i become super user?
Wear your underpants on the outside and put on a cape.

pacosoeda
Ronin
Ronin
Posts: 3
Joined: 18 Feb 2016, 21:08
Distribution: Porteus xfce 32 bits
Location: Spain

Re: Problems installing new package using USM

Post#6 by pacosoeda » 22 Feb 2016, 16:36

Yes!! Absolutely! Thanks again for the reply .

Let me tell you that as an update of the issue , it seems its solved so I haven't met the error message concerning the libs.txt file anymore.

Anyway I am still getting familiar with the environment , so it wouldn't be surprising if I come across with another issue soon ( I hope not :D )

Regards.

Post Reply