Porteus Kiosk on Trekstore MiniPC W2

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
drweb
White ninja
White ninja
Posts: 4
Joined: 15 Feb 2016, 10:18
Distribution: slax
Location: germany

Porteus Kiosk on Trekstore MiniPC W2

Post#1 by drweb » 15 Feb 2016, 11:56

Hi there,

i have installes Porteus Kiosk on a Trekstore MiniPC W2. This is a new device released in 2015 and its based on tablet hardware (Intel Atom CPU).

Details: http://www.trekstor.de/detail-minipc-de ... pc-w2.html

My problem ist, that porteus does not recognize the soundcard.
ALSA device list:
No soundcards found.
Even the performance for video playback is very poor. when i try to watch videos from youtube or other platforms, the picture is lacking. Is it possible to fix this by choosing another driver?

if you need any additional infos for helping me, please inform me.

many thanks

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk on Trekstore MiniPC W2

Post#2 by fanthom » 15 Feb 2016, 12:51

Hello drweb,

Latest kernel (4.4.x) should resolve GPU issues. For the soundcard you could use preconfigured Alsa settings:
https://github.com/AdamWill/baytrail-m/ ... 00_B.state
More info:
https://www.happyassassin.net/fedlet-a- ... l-tablets/

It worked for following tablets:
http://www.microcenter.com/product/4374 ... et_-_Black
http://www.microcenter.com/product/4397 ... et_-_Black

but i had no luck with:
http://azulletech.com/product/quantum-byte/
where i could not get the soundcard to work no matter what i did.

If you are willing to buy a custom kiosk build with latest kernel and soundcard tweak then please contact me through customized builds:
http://porteus-kiosk.org/builds.html

Thank you.
Please add [Solved] to your thread title if the solution was found.

drweb
White ninja
White ninja
Posts: 4
Joined: 15 Feb 2016, 10:18
Distribution: slax
Location: germany

Re: Porteus Kiosk on Trekstore MiniPC W2

Post#3 by drweb » 17 Feb 2016, 08:03

thanx for your reply.

when the soundcard is not detectet in general, then the alsa state file should not have any effect. Or i'am wrong with that? I only have to copy the file to asound.state in /var/lib/alsa/?

The Porteus Kiosk Version with Kernel 4.4.x will be released in a few weeks?

best regards

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk on Trekstore MiniPC W2

Post#4 by fanthom » 17 Feb 2016, 08:30

"when the soundcard is not detectet in general, then the alsa state file should not have any effect. Or i'am wrong with that?"
The kernel message you quoted is meaningless as alsa drivers are compiled as modules and loaded later by udev.
Please run 'aplay -l' command and check if any soundcards are listed - if yes then there is a hope.

"I only have to copy the file to asound.state in /var/lib/alsa/?"
You need to add 'alsactl' utility to kiosk ISO and run following command during startup:
'alsactl -f /etc/t100_B.state restore'
alsa config file is placed in /etc.

More info:
http://porteus-kiosk.org/faq.html#9
Please add [Solved] to your thread title if the solution was found.

drweb
White ninja
White ninja
Posts: 4
Joined: 15 Feb 2016, 10:18
Distribution: slax
Location: germany

Re: Porteus Kiosk on Trekstore MiniPC W2

Post#5 by drweb » 17 Feb 2016, 16:26

alsactl: load_state:1729: No soundcards found...
so that means there is no hope :/

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus Kiosk on Trekstore MiniPC W2

Post#6 by fanthom » 17 Feb 2016, 16:55

Please generate debug report in the wizard and send to me on support@porteus-kiosk.org.
We will be sure then.
Please add [Solved] to your thread title if the solution was found.

Post Reply