login=root does not work

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
yys2000
Ronin
Ronin
Posts: 3
Joined: 14 Jan 2016, 20:24
Distribution: slax
Location: canada

login=root does not work

Post#1 by yys2000 » 15 Jan 2016, 15:46

Hi,

I add this cheatcode to script, but when I type the command: whoami. I still get the guest.
How to enable the auto root login?

Thanks :roll:

User avatar
brokenman
Site Admin
Site Admin
Posts: 5517
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: login=root does not work

Post#2 by brokenman » 15 Jan 2016, 20:10

I add this cheatcode to script
What exactly do you mean by this? What script and where?

Please answer the above question and we can start helping you. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Cobai
Ronin
Ronin
Posts: 3
Joined: 22 Jan 2016, 23:09
Distribution: Porteus
Location: UK

Re: login=root does not work

Post#3 by Cobai » 22 Jan 2016, 23:18

yys2000 wrote:Hi,

I add this cheatcode to script, but when I type the command: whoami. I still get the guest.
How to enable the auto root login?

Thanks :roll:
You shouldn't need a 'script' to do this - it's simply added to the porteus.cfg file located in /boot/syslinux/porteus.cfg.

Mine looks like this for the GUI option i use: (Note the APPEND line)

Code: Select all

LABEL KDE4
MENU LABEL Graphics mode (KDE4)
KERNEL vmlinuz
APPEND initrd=initrd.xz changes=/mnt/sda1/porteussave.dat volume=60% kmap=gb copy2ram noeject login=root
TEXT HELP
    Run Porteus the best way we can.
    Try to autoconfigure graphics
    card and use the maximum
    allowed resolution
ENDTEXT
Add the "login=root" to this or whichever mode you boot into and voila, root access on startup.

Also, i'm a complete linux newbie, literally learning as i go and this is my first post, woop :)

Post Reply