graphic card issues for VIA VX855 [Solved]

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
JP16
White ninja
White ninja
Posts: 7
Joined: 11 Jan 2016, 10:56
Distribution: -
Location: Germany

graphic card issues for VIA VX855 [Solved]

Post#1 by JP16 » 11 Jan 2016, 11:05

Hello,

following problem, I am trying to run Porteus on a system with following graphics card: VIA VX855

Textmode works great but as soon as the system try to switch into graphics mode, the screen goes blank.
Any workaround for this?

thx
Last edited by JP16 on 10 Mar 2016, 07:50, edited 1 time in total.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Screen Blank after Init 4 - Thinclient

Post#2 by brokenman » 11 Jan 2016, 23:52

Have you tried the proprietry VIA drivers?

http://download.viatech.com/en/support/ ... Select.jsp
How do i become super user?
Wear your underpants on the outside and put on a cape.

JP16
White ninja
White ninja
Posts: 7
Joined: 11 Jan 2016, 10:56
Distribution: -
Location: Germany

Re: Screen Blank after Init 4 - Thinclient

Post#3 by JP16 » 25 Jan 2016, 09:42

I have used the driver: "xf86-video-openchrome-0.2.904-i486-2.xzm"
From this thread: https://forum.porteus.org/viewtopic.php ... =484#p3702

And it worked just fine, the only problem is that I can´t set the resolution to the desired settings. It seems to be some sort of "generic" driver?

I would appreciate it, if you could point me in the right direction how to download and build a driver from this site: http://download.viatech.com/en/support/ ... Select.jsp
As I am unsure which Linux type etc. to choose for the Porteus Kiosk.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Screen Blank after Init 4 - Thinclient

Post#4 by brokenman » 25 Jan 2016, 21:14

Moving this thread to the kiosk section. (tutorials)
How do i become super user?
Wear your underpants on the outside and put on a cape.

aus9

Re: graphic card issues for VIA VX855

Post#5 by aus9 » 26 Jan 2016, 07:12

moved again out of tutorials as its not solved and made a bug as there does not appear to be a general help section

2) I used the link to get to legacy as I think Kiosk is based on compiling as a Gentoo base and if you can see it here is link
http://download.viatech.com/DriverDownloadSubmitAjaxSvl

nope I can't link here is what I chose from brokenman's link
linux-legacy
source packages
integrated graphics
vx855

should give you download
https://d34vhvz8ul1ifj.cloudfront.net/D ... 83_src.tgz

I have never used kiosk so compiling instructions may need others to help

JP16
White ninja
White ninja
Posts: 7
Joined: 11 Jan 2016, 10:56
Distribution: -
Location: Germany

Re: graphic card issues for VIA VX855

Post#6 by JP16 » 26 Jan 2016, 08:07

Compiled with the Package Tools in Porteus Desktop

-- didn´t work. Unsure if because of wrong driver or failed compiling attempt

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: graphic card issues for VIA VX855

Post#7 by fanthom » 26 Jan 2016, 08:28

Hello JP16,

Porteus Kiosk has latest version of openchrome driver included (looks like its not developed anymore). It still does not cover all GPUs and you need to use VESA driver. Please remaster kiosk ISO and copy 003-settings.xzm/etc/X11/xorg.conf-vesa as 003-settings.xzm/etc/X11/xorg.conf.

That should give you working desktop. Image quality wont be the best and no hardware acceleration available.

Thank you.
Please add [Solved] to your thread title if the solution was found.

JP16
White ninja
White ninja
Posts: 7
Joined: 11 Jan 2016, 10:56
Distribution: -
Location: Germany

Re: graphic card issues for VIA VX855 [Solved]

Post#8 by JP16 » 10 Mar 2016, 07:48

Solved after the update to Porteus Kiosk 3.7.0
Switched to VESA Mode - and it works without any additional modules.

Thanks

faheem5
Ronin
Ronin
Posts: 2
Joined: 20 Apr 2016, 07:18
Distribution: Kiosk
Location: CDT

Re: graphic card issues for VIA VX855 [Solved]

Post#9 by faheem5 » 20 Apr 2016, 07:49

I just wanted to say THANK YOU as I was having issues booting up the OS on a Dell Wyse C90LEW which uses that same chip.
I am hopeful that building an ISO using the VESA driver will work.

C90LEW - VIA C7 1GHz, VIA VX855, 2GB Flash, 1GB RAM, Gigabit Ethernet, WLAN 802.11 b/g/n, Windows Embedded Standard Wyse Edition

faheem5
Ronin
Ronin
Posts: 2
Joined: 20 Apr 2016, 07:18
Distribution: Kiosk
Location: CDT

Re: graphic card issues for VIA VX855 [Solved]

Post#10 by faheem5 » 20 Apr 2016, 08:09

Looks like i spoke too soon.

I see the file mentioned in the comment above, but not un-sure to modify it or what to rename it to. (I can open the file in notepad)

Image

Post Reply