Atom X5-Z8500 Xorg fails to start

Post here if you are a new Porteus member and you're looking for some help.
User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Atom X5-Z8500 Xorg fails to start

Post#16 by brokenman » 24 Jan 2016, 21:57

supposing instead that the developers here would have a good sense of whether Porteus supports it or what might be done to make it if it doesn't.
Feel free to send me one and I will get Porteus working on it. I am going to Australia in July so I may pick one up. They look pretty cool.

Looking at your logs my first recommendation would be to use Nemesis with this machine. It is very new hardware. The system seems to identify your flash memory (eMMC) but then spews some nasty errors about it.

Code: Select all

mmc1: Got data interrupt 0x00000002 even though no data operation was in progress.
[    5.570995] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[    5.744416] EXT4-fs (mmcblk0p5): recovery complete
Can you post the output of: lspci -k
How do i become super user?
Wear your underpants on the outside and put on a cape.

rchase
Samurai
Samurai
Posts: 154
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#17 by rchase » 25 Jan 2016, 00:26

brokenman wrote:I am going to Australia in July so I may pick one up. They look pretty cool.
To geeks of a certain age (including me) they do -- upon reflection, a computer somewhat larger and heavier than a smartphone in a case with no screen, no data entry, and needing a tangle of wires connected to other devices in order to do much isn't likely to be perceived as all that cool by the general public; smartphones, after all, are computers with a bunch of peripherals built-in. I discovered to my chagrin that the internal battery can't power devices connected to the dock, even with a micro-USB charger plugged into the body of the Kangaroo; one must use the included power adapter that plugs into the dock. No legacy (CSM) booting allowed.

So far as I know, the only association with Australia is the name of the device; the company has its headquarters in Irvine, California. I believe Foxconn is assembling them; dismayed to see that this company has had many suicides among its workforce. Mine orginated from Newegg.

Mint complained about the eMMC too, but it installed and seems to function. It takes too long to boot (installed to a 32GB micro SDHC card).

Code: Select all

lspci -k
returns

Code: Select all

lspci: Unable to load libkmod resources: error -12
.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2522
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Atom X5-Z8500 Xorg fails to start

Post#18 by Bogomips » 25 Jan 2016, 21:42

rchase wrote:even with a micro-USB charger plugged into the body of the Kangaroo; one must use the included power adapter that plugs into the dock. No legacy (CSM) booting allowed.

So far as I know, the only association with Australia is the name of the device; the company has its headquarters in Irvine, California.
At last cleared up a source of confusion! All those references to Kangarob, that I happened upon, thought were references to our antipodean moderator, with avatar in mind. :D
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

kultex
White ninja
White ninja
Posts: 9
Joined: 30 Dec 2015, 12:11
Distribution: fluxflux
Location: Austria

Re: Atom X5-Z8500 Xorg fails to start

Post#19 by kultex » 27 Jan 2016, 14:23

it reminds me a lot to my Cenovo https://forum.porteus.org/viewtopic.php?f=61&t=5364
it really wounld be great, if porteus will support thos new Atom CPUs

maybe those links help:

https://wiki.debian.org/InstallingDebianOn/Asus/T100TA
http://www.jfwhome.com/2016/01/04/lates ... us-t100ta/

and the guy, who is most in this field - Ian Morrison

https://plus.google.com/+IanMORRISON/posts/C4rXwrYXvB9

kultex
White ninja
White ninja
Posts: 9
Joined: 30 Dec 2015, 12:11
Distribution: fluxflux
Location: Austria

Re: Atom X5-Z8500 Xorg fails to start

Post#20 by kultex » 27 Jan 2016, 17:46

@rchase - looking to your pastbin:

first xorg - I think you started xorg as root - this does not work

Code: Select all

[   387.908] (EE) Server terminated with error (1). Closing log file.
xauth:  file /root/.serverauth.1786 does not exist
xauth:  file /root/.Xauthority does not exist
xauth:  file /root/.Xauthority does not exist
@brokenman - why there is no module fbdev? - in the meantime fbdev is more useful than vesa

then

Code: Select all

[    2.118847] mmc0: BKOPS_EN bit is not set
this is a firmware problem - you will not be able to write to internal harddisk - https://www.raspberrypi.org/forums/view ... f&start=25

rchase
Samurai
Samurai
Posts: 154
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#21 by rchase » 01 Feb 2016, 02:52

kultex, doesn't that error relate to one of the Windows partitions (to which I do not want to write anyway)? Thanks for the links; I'll check them out. By booting to text mode and issuing "startx", I can start the desktop (with an error message), but certain letters are invisible (see Nemesis 3.5 bug reports).

Post Reply