Atom X5-Z8500 Xorg fails to start

Post here if you are a new Porteus member and you're looking for some help.
rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Atom X5-Z8500 Xorg fails to start

Post#1 by rchase » 11 Jan 2016, 01:54

By way of introduction, I have a long acquaintance with computers, but only the slightest familiarity with the nuts and bolts of Linux. I am trying to get Porteus working on two computers of interest, especially my new Kangaroo (Intel X5-Z8500 with integrated Intel HD graphics, Broadwell GPU); when I boot Porteus (3.1 XFCE 64-bit), Xorg fails to start and declares its intention to use a modesetting driver next time, removes an invalid xorg.conf file, then repeats. I've collected the requested files from booting in text mode, but when I tried to include them in this post, I received an error message saying that the maximum number of characters is 60000 -- please advise me what to post and how for guidance.
Last edited by rchase on 12 Jan 2016, 09:49, edited 2 times in total.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Graphical Problems

Post#2 by Bogomips » 11 Jan 2016, 02:12

Welcome to Porteus!
Text file output exceeding 60000 chars would have to be placed at pastebin.com, with a link to this being inserted in a follow up post. :)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Graphical Problems

Post#3 by rchase » 12 Jan 2016, 04:17

Thanks! The contents of fstab, blkid, dmesg, messages, and porteus-livedbg, collected upon booting into text mode on my Kangaroo, are at: http://pastebin.com/BkTxEe2k.

I see how to get Porteus to boot in UEFI mode, but Linux Mint/Ubuntu apparently ignore my choice of where to put the bootloader, modify the EFI partition on the eMMC without any authorization or notice, and fail to boot -- it's off-topic, but I would also appreciate any clue as to how to put such an installation (UEFI Linux Mint) onto a USB drive -- only -- and get it to boot.

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Graphical Problems

Post#4 by rchase » 12 Jan 2016, 04:51

aus9, thanks for the information and suggestions; I can edit xorg.conf, but what do I do with the S3 driver and the extant Porteus base to replace its xorg? The Celeron M is running Windows XP (WEPOS hack); the maximum resolution the S3 supports is 1600x1200 (16-bit color, 60Hz).

P.S.
rchase wrote:... I also have an old Celeron M with a 32GB [sic] S3 Graphics ProSavageDDR on the motherboard
Make that "... 32MB S3 Graphics ..."
Last edited by rchase on 12 Jan 2016, 09:19, edited 1 time in total.

aus9

Re: Graphical Problems

Post#5 by aus9 » 12 Jan 2016, 09:14

post split between threads by OP so this post amended
other post is here but its a different PC
https://forum.porteus.org/viewtopic.php ... 905#p40905
Last edited by aus9 on 12 Jan 2016, 12:30, edited 2 times in total.

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Graphical Problems

Post#6 by rchase » 12 Jan 2016, 09:40

OK.

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#7 by rchase » 12 Jan 2016, 19:10

I neglected to include the results of "lspci -vnn" in my pastebin posting:

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b0] (rev 20) (prog-if 00 [VGA controller])
Subsystem: Foxconn International, Inc. Device [105b:0e6a]
Flags: bus master, fast devsel, latency 0, IRQ 318
Memory at 90000000 (64-bit, non-prefetchable)
Memory at 80000000 (64-bit, prefetchable)
I/O ports at 1000
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915_bpo

I wondered whether this might be a controller unknown to Linux, but Mint boots and seems to function correctly.

aus9

Re: Atom X5-Z8500 Xorg fails to start

Post#8 by aus9 » 12 Jan 2016, 22:23

hmm apparently bpo means backported so someone has attempted to fix the intel driver with stuff from (allegedly) a more recent version.

this suggests you might be better off on a more recent kernel. What is the kernel version for Mint?
While your Porteus is 3.17.4-porteus

and I have never used it as I don't need it for my hardware, but you could update to a more kernel
https://forum.porteus.org/viewtopic.php ... hilit=neko

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#9 by rchase » 23 Jan 2016, 05:41

Brokenman supplied me with a 4.4 kernel, but xorg still fails to start. I suppose this leaves troubleshooting Nemesis the only option -- or does it? I'll see whether I can get the desktop up in Nemesis 3.5 and use textmode to issue "startx"; as it is very much still a work in progress, I'd much prefer to fix Porteus with the v4.4 kernel.

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#10 by rchase » 23 Jan 2016, 06:56

I hadn't realized that Nemesis 3.5 was so far from a fully functional distribution yet -- what can I do to troubleshoot xorg not starting in Porteus with the new v4.4 kernel?

roadie
Full of knowledge
Full of knowledge
Posts: 205
Joined: 02 Jan 2011, 18:41
Distribution: Porteus 3.5...with a twist
Location: In a hayfield

Re: Atom X5-Z8500 Xorg fails to start

Post#11 by roadie » 23 Jan 2016, 18:57

rchase wrote:I hadn't realized that Nemesis 3.5 was so far from a fully functional distribution yet -- what can I do to troubleshoot xorg not starting in Porteus with the new v4.4 kernel?
I've not found Nemesis to be 'so far from a fully functional distribution'....it works very well for me on anything I've tried.

It is, in a way, an experimental distro in that brokenman is basing it on a completely different distro, ( Arch ) as compared to what Porteus has always used as a base, ( Slackware ). Having delved into this myself, I can assure you it's no small task....and brokenman does it all for free.

A very casual search seems to reveal that support for the Atom X5-Z8500 was introduced into the kernel only recently....I think it's unrealistic to expect everything to be hunky dorey....there are always bugs.

Have you found the same with your searches?

Troubleshooting your problem involves the same things it always has....look at the logs...learn basic commands for Linux....search the internet...try different cheatcodes. With a long aquaintance with computers, I'm sure this is nothing new for you.

Have you tried the 'nomodest' cheatcode on the kernel command line?

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#12 by rchase » 23 Jan 2016, 19:03

roadie wrote:Have you tried the 'nomodest' cheatcode on the kernel command line?
No, thanks for reminding me; I'll try it now.

I'm not complaining, I just want to get Porteus working on a range of hardware; I understand why it has problems with some of the newest and oldest and is working well on the stuff in the middle. I do not have a good sense of the specifics of the move from slackware to mandriva (terminology?), but I understand that this involves much work. I hadn't searched for information about support for Kangaroo's processor, supposing instead that the developers here would have a good sense of whether Porteus supports it or what might be done to make it if it doesn't.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5542
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Atom X5-Z8500 Xorg fails to start

Post#13 by brokenman » 23 Jan 2016, 21:26

The way I would trouble shoot is to boot into text mode and issue:

Code: Select all

startx 2>/tmp/out
Then after it fails you can post the contents of:

Code: Select all

cat  /var/log/Xorg.0.log ~/.xsession-errors /tmp/out > /tmp/mylog.txt
dmesg >> /tmp/mylog.txt
onto pastebin and make a link to it here.

If startx leaves you at a blank screen with no way to exit then start it with a script:
startx 2>/tmp/out &
sleep 10
killall X

Using startx will depend on which desktop you are using. For example if you are using lxde:

Code: Select all

echo "ck-launch-session dbus-launch startlxde" > ~/.xinitrc
startx
How do i become super user?
Wear your underpants on the outside and put on a cape.

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#14 by rchase » 24 Jan 2016, 02:08

I am issuing commands from Porteus on a flash drive -- I can't post anything I transfer to /tmp, because that is in RAM. This is exactly the same situation as diagnosing my other computer; I have to transfer files onto a flash drive and take that to a working Porteus installation. I believe I can manage that now.

rchase
Samurai
Samurai
Posts: 158
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 3.2.2 xfce x64
Location: Denver, Colorado

Re: Atom X5-Z8500 Xorg fails to start

Post#15 by rchase » 24 Jan 2016, 21:20

Done! http://pastebin.com/PmcGU78d

"cat" flagged non-existence of .xsession-errors. I will use 64-bit, Porteus 4.4 XFCE on this machine, if I can.

Post Reply