Porteus Nemesis v3.5 BUG REPORTS

Arch based Porteus community project
aus9

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#181 by aus9 » 28 Jan 2016, 23:37

abiword part two

I no longer have any graphic issues .......a kind of new left scroll bar to left for a part of the screen and a horizontal scroll bar at top of screen that flashes on and off.
I solved it by installing too many optional dependencies... won't report back until I have remove each extra and retested

don't try this unless you have lots of bandwith please

Code: Select all

pacman -S texlive-core openmpi openjpeg2 
resolving dependencies...
looking for conflicting packages...

Packages (10) gd-2.1.1-3  harfbuzz-icu-1.1.3-1  hwloc-1.11.2-2  libsigsegv-2.10-2  potrace-1.12-1  texlive-bin-2015.37497-9
              zziplib-0.13.62-2  openjpeg2-2.1.0-1  openmpi-1.10.1-3  texlive-core-2015.38835-1

Total Download Size:   147.01 MiB
Total Installed Size:  388.50 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 gd-2.1.1-3-x86_64                                        153.6 KiB   345K/s 00:00 [################################################] 100%
 libsigsegv-2.10-2-x86_64                                   7.9 KiB   566K/s 00:00 [################################################] 100%
 zziplib-0.13.62-2-x86_64                                  96.4 KiB   505K/s 00:00 [################################################] 100%
 harfbuzz-icu-1.1.3-1-x86_64                                5.5 KiB   686K/s 00:00 [################################################] 100%
 potrace-1.12-1-x86_64                                     81.7 KiB   508K/s 00:00 [################################################] 100%
 texlive-bin-2015.37497-9-x86_64                           23.7 MiB   487K/s 00:50 [################################################] 100%
 texlive-core-2015.38835-1-any                            115.5 MiB   500K/s 03:57 [################################################] 100%
 hwloc-1.11.2-2-x86_64                                    356.8 KiB   502K/s 00:01 [################################################] 100%
 openmpi-1.10.1-3-x86_64                                    6.9 MiB   500K/s 00:14 [################################################] 100%
 openjpeg2-2.1.0-1-x86_64                                 165.6 KiB   503K/s 00:00 [################################################] 100%
(10/10) checking keys in keyring                                                   [################################################] 100%
(10/10) checking package integrity                                                 [################################################] 100%
(10/10) loading package files                                                      [################################################] 100%
(10/10) checking for file conflicts                                                [################################################] 100%
(10/10) checking available disk space                                              [################################################] 100%
( 1/10) installing gd                                                              [################################################] 100%
Optional dependencies for gd
    perl: bdftogd script [installed]
( 2/10) installing libsigsegv                                                      [################################################] 100%
( 3/10) installing zziplib                                                         [################################################] 100%
( 4/10) installing harfbuzz-icu                                                    [################################################] 100%
( 5/10) installing potrace                                                         [################################################] 100%
( 6/10) installing texlive-bin                                                     [################################################] 100%
>>> texlive: updating the filename database...
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/bin:/usr/bin/share/texmf-local/web2c:/usr/bin/share/texmf-dist/web2c:/usr/bin/share/texmf/web2c:/usr/bin/texmf-local/web2c:/usr/bin/texmf-dist/web2c:/usr/bin/texmf/web2c:/usr:/usr/share/texmf-local/web2c:/usr/share/texmf-dist/web2c:/usr/share/texmf/web2c:/usr/texmf-local/web2c:/usr/texmf-dist/web2c:/usr/texmf/web2c://texmf-local/web2c:/://share/texmf-local/web2c://share/texmf-dist/web2c://share/texmf/web2c://texmf-local/web2c://texmf-dist/web2c://texmf/web2c.
mktexlsr: Done.
Optional dependencies for texlive-bin
    ed: for texconfig
( 7/10) installing texlive-core                                                    [################################################] 100%
>>> texlive: saving updmap.cfg as /tmp/tmp.EKQEbbCbE5...
>>> texlive: regenerating updmap.cfg (custom additions should go
             into /etc/texmf/web2c/updmap-local.cfg
>>> texlive: updating the filename database...
mktexlsr: Updating /etc/texmf/ls-R... 
mktexlsr: Updating /usr/share/texmf-dist/ls-R... 
mktexlsr: Updating /var/lib/texmf/ls-R... 
mktexlsr: Done.
removed ‘var/lib/texmf/luatex-cache/context/0399a8df3aef8d154781d0a9c2b8e28d/trees/5058f1af8388633f609cadb75a75dc9d.lua’
removed ‘var/lib/texmf/luatex-cache/context/0399a8df3aef8d154781d0a9c2b8e28d/trees/5058f1af8388633f609cadb75a75dc9d.luc’
>>> texlive: updating the fontmap files with updmap...
 done.
creating all formats...fmtutil [WARNING]: inifile eptex.ini for eptex/eptex not found.
fmtutil [WARNING]: inifile uptex.ini for uptex/uptex not found.
fmtutil [WARNING]: inifile aleph.ini for aleph/aleph not found.
fmtutil [WARNING]: inifile euptex.ini for euptex/euptex not found.
fmtutil [WARNING]: inifile ptex.ini for ptex/ptex not found.
fmtutil [WARNING]: inifile pdfjadetex.ini for pdfjadetex/pdftex not found.
fmtutil [WARNING]: inifile xmltex.ini for xmltex/pdftex not found.
fmtutil [WARNING]: inifile texsis.ini for texsis/pdftex not found.
fmtutil [WARNING]: inifile eplain.ini for eplain/pdftex not found.
fmtutil [WARNING]: inifile uplatex.ini for uplatex/euptex not found.
fmtutil [WARNING]: inifile platex.ini for platex/eptex not found.
fmtutil [WARNING]: inifile lollipop.ini for lollipop/pdftex not found.
fmtutil [WARNING]: inifile jadetex.ini for jadetex/pdftex not found.
fmtutil [WARNING]: inifile xelollipop.ini for xelollipop/xetex not found.
fmtutil [WARNING]: inifile pdfxmltex.ini for pdfxmltex/pdftex not found.
fmtutil [WARNING]: inifile mltex.ini for mltex/pdftex not found.
fmtutil [WARNING]: inifile lambda.ini for lamed/aleph not found.
fmtutil [WARNING]: inifile lualollipop.ini for lualollipop/luatex not found.
 done.
 (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)
NB: To setup ConTeXt and the lua(la)tex font db,
    see http://wiki.archlinux.org/index.php/TeX_Live
Optional dependencies for texlive-core
    dialog: for texconfig [installed]
    ghostscript: for epstopdf, epspdf and other ConTeXt tools [installed]
    java-runtime: for utilities like arara
    perl-tk: for texdoctk
    psutils: to manipulate the output of dvips
    python: for pythontex [installed]
    python2: for dviasm [installed]
    ruby: for old ConTeXT MkII and epspdf
    t1utils: can be useful when installing Type1 fonts
( 8/10) installing hwloc                                                           [################################################] 100%
( 9/10) installing openmpi                                                         [################################################] 100%
Optional dependencies for openmpi
    gcc-fortran: fortran support
(10/10) installing openjpeg2 
no reboot needed for graphic issues to disappear for me but not tested reboot yet either

edit .....must type text as well......when I remove packages

aus9

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#182 by aus9 » 28 Jan 2016, 23:58

abiword part three

when abiword starts....I am in print view mode which is why I described a graphic issue with a virtual left scroll bar as that appears in the left ruler area.

by changing away from that view, normal or web...ruler disappers and that gremlin is hidden. Its not a solution but a quick work a round

aus9

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#183 by aus9 » 29 Jan 2016, 00:07

abiword part 4

its an old issue that has resurfaced for at least one other this year
https://bbs.archlinux.org/viewtopic.php?id=203666

offtopic
I now enjoy necrobumping by Arch users as it provides useful info

Ok just built it using makepkg system....it needed a few build dependencies and only if brokenman doesn't solve the graphics issues
(no pressure :D ) I will then take his advice on whether to upload the XZ package to him etc

xz is only 3.6M but
depends=('fribidi' 'wv' 'librsvg' 'enchant' 'desktop-file-utils' 'gtk2' 'libxslt')
makedepends=('pkgconfig' 'boost')
running it....I have no graphic issues so far....touch wood

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#184 by brokenman » 29 Jan 2016, 01:47

Thanks for sorting that out. Much appreciated.
depends=('fribidi' 'wv' 'librsvg' 'enchant' 'desktop-file-utils' 'gtk2' 'libxslt')
This is no problem. gtk2 and librsvg are in the 002 module. I can put desktop-file-utils there too.
I will then take his advice on whether to upload the XZ package to him etc
Is the intention to have it included in the ISO?
How do i become super user?
Wear your underpants on the outside and put on a cape.

datruche
Black ninja
Black ninja
Posts: 95
Joined: 20 Sep 2015, 21:02
Distribution: Arch, Porteus-Nemesis 3.5
Location: London > . < Paris

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#185 by datruche » 29 Jan 2016, 03:16

Err does it mean that install from the latest iso is the single way to upgrade to Nemesis alpha new and hard worked releases?

ingosia
White ninja
White ninja
Posts: 7
Joined: 27 Jan 2016, 22:46
Distribution: Nemesis 3.5, Mint 17.2 Xfce
Location: Slovakia

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#186 by ingosia » 29 Jan 2016, 10:14

aus9 wrote:abiword part 4

running it....I have no graphic issues so far....touch wood

Thank You for the solution aus9.
Is the intention to have it included in the ISO?
If I can say something to this, if Abiword will be working out of the box it will be nice. But I think You want to keep the ISO as small as possible, right?
I will be also fine to make post install of it, no issue. :D

Thanks one more time for solving this.

Another topic:

My hardware buttons for display brightness adjustment does not work, but it does in Porteus 3.1 (Mate, also Xfce). I have no clue if this is Ach related or not. As I said it is LED display that i use, not LCD one.
What can I do please?

aus9

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#187 by aus9 » 29 Jan 2016, 10:52

regarding abiword....until repo is fixed. Note this will happen from time to time with a rolling release. I don't use abiword so I leave it to users to report when its safe to use the Official version.

@ingosia and other interested users who have graphic issues at time of writing.
download link
https://www.dropbox.com/s/28ti70sm9fyxk ... ar.xz?dl=0

Temporary fix
use root powers to move your abiword module out of modules. If you used pacman use a command like

Code: Select all

pacman -R abiword
Use root powers to place in /var/lib/pacman/local/ then use your "normal login" filemanager to click on it and "install" it.
Note that I have dependencies on my system already so if it does not start for a member....open a terminal and try to run it to see what is missing

@brokenman
No not the iso I thought you might spot something funny with a graphics software like libxslt or harfbuzz etc

I don't have time at the moment but I have kept abiword source so will look at modding the build script to see if gtk3 makes it nicer or crashes it

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#188 by brokenman » 29 Jan 2016, 17:17

As I said it is LED display that i use, not LCD one.
What can I do please?
Let's start with the model of the monitor.
How do i become super user?
Wear your underpants on the outside and put on a cape.

datruche
Black ninja
Black ninja
Posts: 95
Joined: 20 Sep 2015, 21:02
Distribution: Arch, Porteus-Nemesis 3.5
Location: London > . < Paris

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#189 by datruche » 29 Jan 2016, 17:24

brokenman wrote:
What is systemdless equivalent to `journalctl -b -N` for boot -N logs?
What does that extract exactly? I ran Nemesis with systemd for a couple of weeks, but I haven't yet memorized all the journalctl switches.
Shows (and pipe to $logfile) the boot -N log, e.g. upon system freeze and reboot I'd run

Code: Select all

journalctl -b -1
brokenman wrote:
BTW where do you guys put your rc.local for its content to be run upon boot? /etc/rc.d/ didn't work.
/etc/rc.local
chmod +x /etc/rc.local <--- make it executable
OK. I made 'CHANGE/etc/rc.local' executable and didn't notice /etc/rc.local didn't inherit that upon next boot. Thank you brokenman.
I'lll test and see if I have to read again all you guys said on the boot customization subject, à la mode OpenRC as well as aus9's [tutorial] rc.local

datruche
Black ninja
Black ninja
Posts: 95
Joined: 20 Sep 2015, 21:02
Distribution: Arch, Porteus-Nemesis 3.5
Location: London > . < Paris

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#190 by datruche » 29 Jan 2016, 17:42

Here how I upgraded Nemesis 3.4 -> 3.5 lxde. Might well be the wrong way. Please note I couldn't find that bit of information nor did my question receive attention atm.

0. mount -o loop nemesis lxde v3.5 iso
1. replace $MODDIR base modules with v3.5's, and copy the new initrd.xz to $BOOTDEV/boot/syslinux/.
2. update the config files as per the v3.5 ones
3. boot with v3.5 xinitrd.xz

Then
# pacman -Syyu

Code: Select all

:: Starting full system upgrade...
error: duplicated database entry 'xorg-server-common'
error: duplicated database entry 'pacman-mirrorlist'
error: duplicated database entry 'cdrtools'
error: duplicated database entry 'pacman'
error: duplicated database entry 'openvpn-openrc'
error: duplicated database entry 'xf86-input-evdev'
error: duplicated database entry 'networkmanager-openrc'
error: duplicated database entry 'haveged-openrc'
error: duplicated database entry 'mesa'
error: duplicated database entry 'p7zip'
error: duplicated database entry 'openssh-openrc'
error: duplicated database entry 'xf86-video-r128'
error: duplicated database entry 'ntp-openrc'
error: duplicated database entry 'libpng'
error: duplicated database entry 'xorg-server'
error: duplicated database entry 'libsecret'
error: duplicated database entry 'iptables-openrc'
error: duplicated database entry 'syslog-ng-openrc'
warning: archlinux-keyring: local (20160123-1) is newer than core (20151220-1)
warning: autofs-openrc: local (20160106-1) is newer than community (20151014-1)
warning: dhclient: local (4.3.3.p1-1) is newer than extra (4.3.3-2)
warning: dhcpcd: local (6.10.1-1) is newer than core (6.10.0-1)
warning: fuse-openrc: local (20160125-1) is newer than community (20151014-1)
warning: haveged-openrc: local (20160125-1) is newer than community (20151014-1)
warning: hdparm-openrc: local (20160125-1) is newer than community (20151014-1)
warning: iptables-openrc: local (20160106-1) is newer than community (20151014-1)
warning: libinput: local (1.1.5-1) is newer than extra (1.1.4-1)
warning: libvpx: local (1.5.0-4) is newer than extra (1.5.0-3)
:: Replace mesa-libgl with core/mhwd? [Y/n]
n
(saved /var/log/pacman/pkg on the disk then

Code: Select all

# pacman -Scc
# pacman-db-upgrade
# pacman -Syyu
just gave the same error & warning.

Found related pacman/pman errors in the following reports though I couldn't find a fix, as the posts below went in many directions at a time

Re: Porteus Nemesis v3.4 BUG REPORTS
Re: Porteus Nemesis v3.3 BUG REPORTS
Re: Porteus/Arch aka Sensei (Porteus w/pacman package manage

Why is that? Is it due to the way I upgraded from v3.4 to 3.5? How to handle it?

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#191 by brokenman » 29 Jan 2016, 21:30

0. mount -o loop nemesis lxde v3.5 iso
1. replace $MODDIR base modules with v3.5's, and copy the new initrd.xz to $BOOTDEV/boot/syslinux/.
2. update the config files as per the v3.5 ones
3. boot with v3.5 xinitrd.xz
Did you also replace vmlinuz with the one from v3.5? The 000-kernel module follows the kernel. If you replaced the one in v3.4 with the one from v3.5 you should also replace the kernel (vmlinuz).
How do i become super user?
Wear your underpants on the outside and put on a cape.

datruche
Black ninja
Black ninja
Posts: 95
Joined: 20 Sep 2015, 21:02
Distribution: Arch, Porteus-Nemesis 3.5
Location: London > . < Paris

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#192 by datruche » 29 Jan 2016, 23:34

Thank you, so that's apropriate way to upgrade betwen two alpha releases with less fussle, ok then.

No i didn't: both kernel files having the same date and size i thought you kept the kernel itself unchanged from v 3.4 to 3.5 but seems I was wrong (though I don't get the link between the kernel and the packages mngr errors - and that would hav been mentionned in the previous posts, wouldn't it?).

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#193 by brokenman » 30 Jan 2016, 00:13

Thank you, so that's apropriate way to upgrade betwen two alpha releases with less fussle, ok then.
In another thread I answered that you shouldn't upgrade at this time. Since we are in the heavy experimental stages at the moment there are major changes between versions. Such as a shift from arch to manjaro, or a change of init systems. V3.5 moved from arch to manjaro (from memory) so you are best to download the new iso. When we settle down incremental upgrades will be possible.

For the kernel it would be best to do: md5sum vmlinuz or file vmlinuz
to check if it has changed.

There is no link between the kernel and the upgrade errors/warnings. No doubt it is due to the base change.
How do i become super user?
Wear your underpants on the outside and put on a cape.

aus9

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#194 by aus9 » 30 Jan 2016, 08:27

@brokenman

Probable bug missing kernel module on 32 bit Nemesis

on behalf of datruche who is responding to the wifi tutorial that I have amended and shorted and still needs some improvements etc

Poster reports he is on the 32 bit distro of Nemesis = porteus-nemesis-v3.5-lxde-i486.iso

I downloaded and unpacked it to look for wl.ko and I can't find it either.

first command against unpacked kernel module is to prove I have done the unpack...being lazy I used the unsquashfs command as I can remember it well

Code: Select all

 find . -name airo.ko
./squashfs-root/usr/lib/modules/4.3.3-porteus/kernel/drivers/net/wireless/airo.ko
find . -name wl.ko
(nothing)
####################################################################################

part 2 poster has the 486 iso but I can only see the 686 dev module?
http://brokenman.porteus.org/porteus/i686/modules/

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.5 BUG REPORTS

Post#195 by brokenman » 30 Jan 2016, 10:24

I downloaded and unpacked it to look for wl.ko and I can't find it either
When I read that post I went in and checked too. I didn't compile it for the last kernel. I have now put a note in my kernel folder on what I need to remember when upgrading the kernel. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply