Porteus-v1.0-rc2-x86 "So close to the FINAL..."

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Problems in language selection tool

Post#16 by Hamza » 29 May 2011, 10:14

Could you post the output of ps-info ?
NjVFQzY2Rg==

User avatar
Syntux
White ninja
White ninja
Posts: 24
Joined: 24 May 2011, 06:01
Location: Germany

Re: Problems in language selection tool

Post#17 by Syntux » 29 May 2011, 12:14

What do you mean with ps-info? Output of ps?

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Problems in language selection tool

Post#18 by Hamza » 29 May 2011, 12:27

In Porteus, You have a tool named ps-info (Porteus System Info) , this tool is very useful if you have an issue with Porteus.

And , post more information about your issue (porteus version , hardware infos, ...)
We cannot help you without more information.
4. Include logs and tell us commands executed. Most wanted are: /var/log/dmesg and /var/log/messages. Use pastebin.com for long and multiple files. Jayflood's 'Porteus System Info' tool can be also very helpful - you can launch it from Kmenu/Lxde menu and receive a lot of useful info about your system straight on the desktop.
Remember: nobody can help you if they don't know what's wrong, or what you did to get the error you received. Providing this information will greatly aid others in assisting you, and will allow us to diagnose your problem easier and sooner.
NjVFQzY2Rg==

User avatar
Syntux
White ninja
White ninja
Posts: 24
Joined: 24 May 2011, 06:01
Location: Germany

Re: Problems in language selection tool

Post#19 by Syntux » 29 May 2011, 12:39

Thanks Hamza,

have just found it. The tool name is psinfo on the command line and I was always looking for ps-info ;) ... Here is my output, but I wonder if you can see anything regarding the 2 problems.
First is simply a path-problem and second one I don't know yet?

Code: Select all

----------------------
Output from psinfo
----------------------
script by jayflood
.
.

====== USER INFO =====
User is: guest
.
===== MACHINE INFO =====
Platform: i686
Kernel: 2.6.38.7-porteus
Processor: Intel(R) Core(TM)2 CPU         T7600  @ 2.33GHz
Base Board Information
	Manufacturer: Dell Inc.
	Product Name: 0JF242
MemTotal:        3337632 kB
MemFree:          226372 kB
Bootparam: root=/dev/ram0 ramdisk_size=6666 rw initrd=/boot/initrd.xz vga=791 load=nVidia-270.41.19-porteus-v1.0_rc2-i486-1beny.xzm autoexec=xconf;telinit~4 BOOT_IMAGE=/boot/vmlinuz 
.
===== SOUND INFO =====
Sound card:  0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xefffc000 irq 45
Sound driver: Advanced Linux Sound Architecture Driver Version 1.0.23.
.
===== PARTITION INFO =====
Porteus is on: /mnt/sdb1
.
Partitions: 
sda
sda1
sda2
sda3
sda4
sdb
sdb1
.
Mounted: 
/dev/sda1      vfat     126M  3.4M  122M   3% /mnt/sda1
/dev/sda2      fuseblk   35G   30G  5.2G  86% /mnt/sda2
/dev/sda3      fuseblk   40G   37G  2.5G  94% /mnt/sda3
/dev/sda4      fuseblk   20G  7.3G   13G  37% /mnt/sda4
/dev/sdb1      vfat     3.7G  3.2G  586M  85% /mnt/sdb1
.
===== OPTICAl DRIVE =====
sr0
.
===== USB INFO =====
Removables: USB
Removable status: sd0:0:0:0:[sda]Protect
sd2:0:0:0:[sdb]Protect
.
lsusb: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 058f:6387 Alcor Micro Corp. Transcend JetFlash Flash Drive
Bus 002 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
Bus 003 Device 002: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 002 Device 003: ID 413c:8103 Dell Computer Corp. Wireless 350 Bluetooth
Bus 003 Device 003: ID 0b97:7762 O2 Micro, Inc. Oz776 SmartCard Reader
.
===== SCREEN INFO =====
Screen 0: minimum 320 x 240, current 1920 x 1200, maximum 1920 x 1200
.
===== MODULES LOADED =====
000-kernel.xzm
001-core.xzm
002-xorg.xzm
003-lxde.xzm
004-kde.xzm
005-kdeapps.xzm
006-koffice.xzm
007-devel.xzm
008-firefox.xzm
009-locales-de_DE.utf8.xzm
010-fixes.xzm
VMwareTools-7.1.4-8.4.6.xzm
apache_tomcat-6.0.29-2.xzm
atma-1.2.xzm
change-5.2.0.4.05.oslc_rqc-0.xzm
compat-gcc-32-3.2.3-47.3.i386.xzm
compat-gcc-32-c++-3.2.3-47.3.i386.xzm
compat-libstdc++-33-3.2.3-47.3.i386.xzm
crippled_sources-porteus-v1.0_rc2-i486-1ftm.xzm
curl-7.19.2-0.xzm
ed-0.9-2.xzm
figlet-2.2.2.xzm
jdk-6u25-i586-1.xzm
krusader-1.90.0.xzm
ksh93.xzm
libaio-0.3.106-1.xzm
libapr1-1.4.2-3_i386.xzm
libaprutil1_1.3.9+dfsg-3_i386.xzm
linux-pam-0.99.10.0-i486.xzm
nVidia-270.41.19-porteus-v1.0_rc2-i486-1beny.xzm
netwatch-1.3.0-i486-1.xzm
p7zip-9.04.xzm
rationalix-ps1.0-2.xzm
rds-5.1.1.02_ads-1.5.5-9.xzm
rds_db-5.1.1.02_users-2.xzm
rls-2.0_7.1-3.xzm
rls_lc-20110816-rationalix.xzm
rss-1.4.0-12.xzm
sshd-activate.xzm
sux-1.0.1-1.xzm
synergy-7.2-3.xzm
synergy_db-7.2_rationalix-2.xzm
sysvshow-1.0.2.xzm
tuxdroid-3.1.4-2.xzm
webshell-0.9.6-1.xzm
wlan_config-muc_lim-0.3.xzm
wpa_supplicant-0.7.1-0.xzm
.
===== NETWORK INFO =====
eth0      Link encap:Ethernet  HWaddr 00:19:B9:5C:B3:AE  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16840 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16840 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4012856 (3.8 Mb)  TX bytes:4012856 (3.8 Mb)

wlan0     Link encap:Ethernet  HWaddr 00:19:D2:C9:5F:89  
          inet addr:192.168.178.30  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fe80::219:d2ff:fec9:5f89/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7188 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5801 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7325774 (6.9 Mb)  TX bytes:825664 (806.3 Kb)
.
# Generated by dhcpcd from wlan0
# /etc/resolv.conf.head can replace this line
domain fritz.box
nameserver 192.168.178.1
# /etc/resolv.conf.tail can replace this line
.
===== PCI INFO =====
lspci: 00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1)
03:01.0 CardBus bridge: O2 Micro, Inc. Cardbus bridge (rev 21)
03:01.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
.
.
===== LOGS INFO =====
dmesg | tail 
.
[  101.217253] wlan0: authenticated
[  101.218495] wlan0: associate with 00:1f:3f:d2:38:fc (try 1)
[  101.221631] wlan0: RX AssocResp from 00:1f:3f:d2:38:fc (capab=0x431 status=0 aid=3)
[  101.221635] wlan0: associated
[  101.222965] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  111.498012] wlan0: no IPv6 routers present
[  150.863029] CE: hpet increased min_delta_ns to 20113 nsec
[  156.322177] start_kdeinit (4279): /proc/4281/oom_adj is deprecated, please use /proc/4281/oom_score_adj instead.
[  163.663824] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[  212.266852] aufs may_rename_srcdir:487:firefox-bin[4486]: renaming dir who has child(ren) on multiple branches, is not supported
.
.
cat /var/log/messages | tail
.
May 29 14:12:03 (none) acpid: 1 client rule loaded
May 29 14:12:03 (none) acpid: client connected from 5298[0:0]
May 29 14:12:03 (none) acpid: 1 client rule loaded
May 29 14:13:17 (none) acpid: client 5298[0:0] has disconnected
May 29 14:13:17 (none) acpid: client 5298[0:0] has disconnected
May 29 14:13:17 (none) acpid: client connected from 5498[0:0]
May 29 14:13:17 (none) acpid: 1 client rule loaded
May 29 14:13:18 (none) acpid: client connected from 5498[0:0]
May 29 14:13:18 (none) acpid: 1 client rule loaded
May 29 14:34:35 (none) -- MARK --
..

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Problems in language selection tool

Post#20 by Hamza » 29 May 2011, 12:49

One thing,

It can be an issue with your perm's. Try to reboot with toroot cheatcode.

And , what's the version ? development version or stable version ?

If you're in development , you're in wrong place for report your bug.
If you're in stable , you're in right place for report your bug.

Normally , if I understand your issue , you're in developement version.
NjVFQzY2Rg==

User avatar
Syntux
White ninja
White ninja
Posts: 24
Joined: 24 May 2011, 06:01
Location: Germany

Re: Problems in language selection tool

Post#21 by Syntux » 29 May 2011, 13:38

I am using the latest testing version porteus 1.0_RC2 together with my own modules.

Sorry, I thought this forum would be for any bug report? Where can I place bugs for testing versions then?

Anyways as far as I can see the path is wrong in the language-selection-tool, since it has changed from /usr/bin to /opt/porteus-scripts. See for yourself ...

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Problems in language selection tool

Post#22 by Ahau » 29 May 2011, 14:49

Hi Syntux,

Yes, the porteus scripts were all moved to /opt/porteus-scripts, as of RC2.

Bugs about testing releases (alpha, beta, and RC) should be posted to their relevant thread in the Development section. I'm going to merge this thread with that one.

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
andre5775
Ronin
Ronin
Posts: 3
Joined: 18 Jan 2011, 18:20
Location: Leipzig

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#23 by andre5775 » 29 May 2011, 16:05

crashman wrote:@ andre5775
no boot on Intel Celeron M processor 1400Mhz is incompatible
In my toshiba-satellite L20 is the same procesor intel celeron M 1400Mhz and work fine ,
please tell me how do you boot porteus, from cd or pendrive ? and what you see ?
from cd and usb

Loading /boot/vmlinuz....
Loading /boot/initrd.xz....ready

This kernel requires the following features not present on the CPU: pae

Unable to boot - please use a kernel appropriate for your CPU.

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#24 by Hamza » 29 May 2011, 16:07

If I understand your issue.

You have 4 GB or more, and you have a computer with a CPU without PAE function.

I think , it is an hardware issue.
NjVFQzY2Rg==

User avatar
andre5775
Ronin
Ronin
Posts: 3
Joined: 18 Jan 2011, 18:20
Location: Leipzig

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#25 by andre5775 » 29 May 2011, 16:29

Porteus-v1.0-rc1 is OK

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#26 by Ahau » 29 May 2011, 16:36

I agree with Hamza -- how much RAM do you have installed?

I don't think PAE was enabled in the kernel in RC1. Try copying 'vmlinuz' from the RC1 /boot/ folder and overwrite it on your RC2 /boot/ folder, to see if RC2 will boot from that older kernel.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#27 by Hamza » 29 May 2011, 16:40

Because , the kernel was recompiled with another config , try to recompile the kernel with Porteus' v1 rc1 x86 config and let us know.
NjVFQzY2Rg==

crashman
Contributor
Contributor
Posts: 118
Joined: 28 Dec 2010, 17:03
Location: Poland

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#28 by crashman » 29 May 2011, 18:03

Syntux
crashman wrote:Language-Selection-Tool not work, create only 4 KB .xzm file :%)
brokenman wrote:The LST is not in place for any of the rc versions. I am sure it will work OK for official release though.
http://porteus.org/forum/viewtopic.php? ... 0&start=90

Hamza
Hamza wrote:Because , the kernel was recompiled with another config , try to recompile the kernel with Porteus' v1 rc1 x86 config and let us know.
where the find config for compile kernel ?

@andre5775
If you want porteus-v1.0rc2 you can copy from porteus-v1.0rc1 /boot/vmlinuz, /boot/initrd.xz and /base/000-kernel.xzm to porteus-v1.0rc2 but better idea is wait for final version.

Cheers

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#29 by Hamza » 29 May 2011, 18:13

where the find config for compile kernel ?
You can use this command,

Code: Select all

modprobe configs && zcat /proc/config.gz > porteus.config
NjVFQzY2Rg==

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-v1.0-rc2-x86 "So close to the FINAL..."

Post#30 by Ahau » 29 May 2011, 18:14

@crashman-- good point, he probably needs the RC1 initrd and kernel modules, too.

Kernel configs are compiled as a module. load them with:

modprobe configs
Please take a look at our online documentation, here. Suggestions are welcome!

Post Reply