BCM4321 connected but no internet

Here you can post about your various experiences with PC hardware. You can also post about hardware that is not compatible with the linux kernel or not recommended for use with Porteus.
aus9

Re: BCM4321 connected but no internet

Post#46 by aus9 » 03 Jan 2016, 23:48

hi

some suggestions

1)
Interface is showing but not allowing connections, Append the following kernel parameter: b43.allhwsupport=1
ref
https://wiki.archlinux.org/index.php/Broadcom_wireless

modify suggestion to cheatcode wl.allhwsupport=1

2) If that fails next
ndiswrapper
ref
https://wiki.archlinux.org/index.php/Wi ... diswrapper

http://sourceforge.net/p/ndiswrapper/nd ... er/HowTos/

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: BCM4321 connected but no internet

Post#47 by brokenman » 04 Jan 2016, 02:37

They do not have one for my chipset listed
The -sta driver supports BCM4321.
How do i become super user?
Wear your underpants on the outside and put on a cape.

aus9

Re: BCM4321 connected but no internet

Post#48 by aus9 » 04 Jan 2016, 02:58

not according to my eyesight but I am looking at a different link to you
https://www.broadcom.com/support/802.11

and the other link has
14e4:4329 partially BCM4321 b/g/n N (r1) wl
https://wireless.wiki.kernel.org/en/users/drivers/b43

Meaning partial support using module b43

knixter
White ninja
White ninja
Posts: 25
Joined: 23 Dec 2015, 17:35
Distribution: Portues
Location: United States

Re: BCM4321 connected but no internet

Post#49 by knixter » 04 Jan 2016, 11:54

I am at a loss.
I borrowed a wifi extender form a friend so I could use use direct cable hook up and try the last suggestions without having to dual boot between porteus and win7. It would allow me to use a cable from it to my onboard nic as I have a 6ft cable
Just for grins i tried to connect to the wifi signal from the extender before I hooked up the cable and it connected to the i'net and is letting me through. I am writing this directly from Porteus.
It's is connecting to the i'net through the Cisco6329 signal, the signal is stronger but not by much.
I give up, why can I connect through the extender but not the router it self?

aus9

Re: BCM4321 connected but no internet

Post#50 by aus9 » 04 Jan 2016, 12:32

actually I can think of at least one reason.

some wireless devices are crappy and work off a certain frequency and can't work of others.

eg I had my router set to broadcast auto but a netbook I borrowed off someone....sorry did not install Porteus but did install a Linux, did not detect my SSID until I forced the channel number.
You may have the same issue?

I have good success of 2.4 band channel 6 and no luck with any 5 GHz for the netbook.

I also used my Android phone to see what was appearing around 8 pm local time when all the teenagers are playing on the net and channel 6 was less frequent in my area YMMV

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: BCM4321 connected but no internet

Post#51 by brokenman » 04 Jan 2016, 21:54

not according to my eyesight but I am looking at a different link to you
https://www.broadcom.com/support/802.11
Yes that's the link I am looking at. Just for future reference, click the little plus button next to the driver and read the full list of supported hardware. As for your problem knixter, it seems it is down to your router so I have little idea what it could be. Some kind of filtering perhaps.
How do i become super user?
Wear your underpants on the outside and put on a cape.

aus9

Re: BCM4321 connected but no internet

Post#52 by aus9 » 04 Jan 2016, 23:25

well I cover my ass by alluding to my eyesight when I meant my 6 brain cells :D

I clicked the readme and the make:product id shows up as supported.

Post Reply