how to disable pinch to zoom with chrome

Share your opinion about Porteus Kiosk Edition.
Post Reply
radu
Ronin
Ronin
Posts: 2
Joined: 03 Dec 2015, 22:17
Distribution: 3.6.0
Location: Bucharest

how to disable pinch to zoom with chrome

Post#1 by radu » 03 Dec 2015, 22:20

everything working great.

one issue i need to figure out: when using chrome as the browser, the pinch to zoom feature is enabled, which is bad for a kiosk...

the chrome startup switch is --disable-pinch , but I am not sure how i could add this to the configuration...

thank you.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: how to disable pinch to zoom with chrome

Post#2 by fanthom » 04 Dec 2015, 10:23

You need to follow customization doc:
http://porteus-kiosk.org/kiosk-customization.html

edit 003-settings.xzm/etc/xdg/openbox/autostart and comment out this line:

Code: Select all

# Activate touch gestures for Chrome:
[ "$chrome" ] && { id=`xinput_calibrator --list | head -n1 | cut -s -d= -f2-`; [ "$id" ] && echo -e "--touch-devices=$id\n--enable-pinch" >> $chflags; }
or just change '--enable-pinch' to '--disable-pinch' flag.

Good luck.
Please add [Solved] to your thread title if the solution was found.

Post Reply