System clock - [Solved]

Arch based Porteus community project
User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - not solved

Post#31 by Ed_P » 05 Dec 2015, 04:31

brokenman wrote:From what I can see, Porteus v3.1 checks /etc/hardwareclock for the string 'UTC' upon boot. If found then it sets the system clock as UTC. If not it sets the system clock as localtime. On shutdown there is nothing written to the hardware clock.
My Porteus 3.0 file.

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# cat /etc/hardwareclock
# /etc/hardwareclock
#
# Tells how the hardware clock time is stored.
# You should run timeconfig to edit this file.

localtime
root@porteus:/home/guest# 
My Porteus 3.1 file.

Code: Select all

guest@porteus:~$ cat /etc/harewareclock
cat: /etc/harewareclock: No such file or directory
guest@porteus:~$ su
Password: 
root@porteus:/home/guest# cat /etc/hardwareclock
# /etc/hardwareclock
#
# Tells how the hardware clock time is stored.
# You should run timeconfig to edit this file.

localtime
root@porteus:/home/guest# 
Which sounds better?

1a) Set Porteus to localtime by default
1b) Set Porteus to UTC by default

2a) Only update hardware clock on shutdown when booting Porteus from fixed drive.
2b) Never update hardware clock
IMO Personally I like 1.a :) especially if Porteus is hoping to appeal to Windows users, which I think it does an excellent job of doing. With 2 I recommend 2b unless booting from a fixed disk install.

Basically if booting from an ISO don't change the machine regardless if booting from a USB drive or a hard drive/fixed drive. An ISO boot is a temporary "install" regardless of media. But support a user's need/desire/wish to set a timezone and remember it if booting from an ISO or a USB drive.

Ok?
Ed

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: System clock - not solved

Post#32 by Ahau » 05 Dec 2015, 07:07

Well, I looked back at the timeconfig app and turns out I'm about as confused as usual, and taking so much time off didn't help. I did write it such that you couldn't select localtime and a timezone, and then we found out that it messed with a couple apps (seamonkey mail and an astronomy program that plotted the location of the sun), so I changed it up to allow localtime with a timezone. However, on my end if I select localtime and set a timezone, the clock still displays the current local time, at least in Porteus 3.0 (which I'm in now).

My biased (and, presently, slightly inebriated) opinion is that we should stick with the Slackware default, that is to say we should have localtime by default. As Ed_P mentions, this would be friendlier to Windows converts, and those with more Unix background should be more comfortable setting their time based on UTC and a timezone. I also agree with item 2a, and would suggest there be a cheatcode to force it either way.
Please take a look at our online documentation, here. Suggestions are welcome!

beny
Full of knowledge
Full of knowledge
Posts: 733
Joined: 02 Jan 2011, 11:33
Location: italy

Re: System clock - not solved

Post#33 by beny » 05 Dec 2015, 17:36

well this is that i have done for time: cli:timedatectl ,that show me the date and time
timedatectl list-timezones, you can see the local time zone of your country
timedatectl set-timezone yours Zone/Subzone
after this if you want set local time:timedatectl set-local-rtc 1, or if you want the UTC mode rtc 0
this set your time, work, after reboot we need to see if this set remain active,tested on nemesys

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - not solved

Post#34 by Ed_P » 05 Dec 2015, 19:49

Thanks beny.

This is what I see.

Code: Select all

guest ~ $ timedatectl
      Local time: Sat 2015-12-05 14:31:57 EST
  Universal time: Sat 2015-12-05 19:31:57 UTC
        RTC time: Sat 2015-12-05 19:31:57
       Time zone: America/New_York (EST, -0500)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no
guest ~ $ 
The time zone is being set via a .profile file. And I suspect the update of the system clock is being done by the NTP sync setting.
Ed

beny
Full of knowledge
Full of knowledge
Posts: 733
Joined: 02 Jan 2011, 11:33
Location: italy

Re: System clock - not solved

Post#35 by beny » 05 Dec 2015, 20:38

is unstable, at reboot i have my time zone tagged on brasil san paulo,sorry and procedure now not work:
timedatectl
Local time: sab 2015-12-05 21:39:35 CET
Universal time: sab 2015-12-05 20:39:35 UTC
RTC time: sab 2015-12-05 21:39:36
Time zone: Europe/Rome (CET, +0100)
Network time on: no
NTP synchronized: no
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode can not be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
'timedatectl set-local-rtc 0'.

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - not solved

Post#36 by Ed_P » 05 Dec 2015, 21:05

Code: Select all

root /home/guest # timedatectl set-local-rtc 1
root /home/guest # timedatectl 
      Local time: Sat 2015-12-05 15:56:14 EST
  Universal time: Sat 2015-12-05 20:56:14 UTC
        RTC time: Sat 2015-12-05 15:56:14
       Time zone: America/New_York (EST, -0500)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode can not be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.
root /home/guest # 
What do RTC & NTP stand for? Real Time Clock? & ? Time ? :unknown:

- edit -

Oh! Just saw your update.

Going to reboot 3.1 and test this.
Ed

donald
Full of knowledge
Full of knowledge
Posts: 1243
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: System clock - not solved

Post#37 by donald » 05 Dec 2015, 21:20

@Ed
The Network Time Protocol (NTP) is used to synchronize the time of a computer to a reference time source.

beny
Full of knowledge
Full of knowledge
Posts: 733
Joined: 02 Jan 2011, 11:33
Location: italy

Re: System clock - not solved

Post#38 by beny » 05 Dec 2015, 21:36

hi again at reboot i have this:
timedatectl
Local time: sab 2015-12-05 16:34:13 BRST
Universal time: sab 2015-12-05 18:34:13 UTC
RTC time: sab 2015-12-05 16:34:13
Time zone: America/Sao_Paulo (BRST, -0200)
Network time on: no
NTP synchronized: no
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode can not be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
'timedatectl set-local-rtc 0'.

beny
Full of knowledge
Full of knowledge
Posts: 733
Joined: 02 Jan 2011, 11:33
Location: italy

Re: System clock - not solved

Post#39 by beny » 05 Dec 2015, 21:41

hi in /usr/local/bin/ there is a script please want to try the setup-time and reboot if the changes are ok for me now working but i have xfce4 now not lxde reboot and see if work or..... ok seem the time is my time also in reboot mode.

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - not solved

Post#40 by Ed_P » 05 Dec 2015, 23:49

Ok, when I rebooted into 3.1 I had to set the clock again. But when I rebooted into 3.3 I saw a boot msg about RTC and something about setting something -300. (60 min x -5 hrs = -300 :) )

And I see that NTP has been set to No now.

Code: Select all

guest ~ $ timedatectl
      Local time: Sat 2015-12-05 18:36:30 EST
  Universal time: Sat 2015-12-05 23:36:30 UTC
        RTC time: Sat 2015-12-05 18:36:24
       Time zone: America/New_York (EST, -0500)
 Network time on: yes
NTP synchronized: no
 RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode can not be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.
guest ~ $ 
It will be interesting to see when I reboot if 3.1 shows the correct time on my system beny.
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - not solved

Post#41 by Ed_P » 06 Dec 2015, 00:56

Back in 3.1 and the clock is OK. :Yahoo!:

Thank you Image beny.

BTW The boot msg was about the RTC setting and "Applying delta of -300 to system timer." Image
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - not solved

Post#42 by Ed_P » 06 Dec 2015, 01:42

Now, if I could get the Digital Clock's Clock Format to be in a 12 hr format.....

But mainly the system clock problem is resolved for me.

Thank you guys for all your help. :friends:

- update -

Digial Clock > change Clock Format from %R to %I:%M %p
https://help.ubuntu.com/community/Lubun ... ngTheClock

-edit-
hmmmm This emoticon shows in Firefox on 3.0 & 3.1 but not in 3.3.
Image
http://www.911cd.net/forums/style_emoti ... bounce.gif
Don't like that.
Last edited by Ed_P on 07 Dec 2015, 16:12, edited 3 times in total.
Ed

aus9

Re: System clock - [Solved]

Post#43 by aus9 » 07 Dec 2015, 09:01

So is this now solved?

if not what does date show in a terminal please?
And does that matter?

User avatar
Ed_P
Contributor
Contributor
Posts: 3398
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: System clock - [Solved]

Post#44 by Ed_P » 07 Dec 2015, 15:59

aus9 wrote:So is this now solved?
Yes. I am happy. :)

Date in terminal:

Code: Select all

guest ~ $ date
Mon Dec  7 10:50:01 EST 2015
And in the Clock applet in the task bar:
Monday 12/07/2015 <---- This with the mouse over the applet
10:50 AM
:good:
Ed

Post Reply