Porteus Nemesis v3.3 BUG REPORTS

Arch based Porteus community project
beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#31 by beny » 26 Nov 2015, 12:42

hi brokenman only the vbox script do not make an usable package only 4kb, the other things all ok no freeze for me i have downgraded the kernel to 4.1.12 version and build nvidia driver, i have left lxde for now work well too
pman can do the vbox package but it need the 4.2.5 kernel and isn't good for me the vbox package want this kernel and downloads it too.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#32 by brokenman » 26 Nov 2015, 13:22

If you open /usr/local/bin/vbox-build you can add this at line 85:

Code: Select all

sh $TMPDIR/commands
Should run ok now. After building this again last night I am not getting runway process after starting vbox.

@Ed_P
The advice given was referring to using the config file at /mnt/sdXy/config/network to set up your network. It uses nmcli to configure the network at boot time. It works for both wifi and wired. Are you mixing modules from the last nemesis with this one?
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ed_P
Contributor
Contributor
Posts: 3058
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#33 by Ed_P » 26 Nov 2015, 16:08

brokenman wrote:@Ed_P
The advice given was referring to using the config file at /mnt/sdXy/config/network to set up your network. It uses nmcli to configure the network at boot time. It works for both wifi and wired. Are you mixing modules from the last nemesis with this one?
No, I'm booting the ISOs with no change= or extramods= cheatcodes at this point.

I'll look at the config/network file and try that. If I make changes to it how to I invoke the changes without rebooting? Enable/Disable Networking sufficient to do?
Ed

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#34 by brokenman » 26 Nov 2015, 16:16

Ah, ok. If you're booting ISOs then you can't edit the file inside. I will need to setup booting from an ISO to check out why networkmanager is not starting. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ed_P
Contributor
Contributor
Posts: 3058
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#35 by Ed_P » 26 Nov 2015, 17:06

NetworkManager is starting, it shows Wired as being active. It just doesn't show anything for WiFi.

FYI

grub2

Code: Select all

menuentry "Porteus Nemesis ISO" --class slackware   --class icon-linux  {
     echo Boot disk address is  $root
     echo Prefix is             $prefix
     echo The boot mode is      $grub2win_bootmode

     set iso=/ISOs/porteus-nemesis-v3.3-x86_64.iso

     search -f $iso --set=root 
     echo ISO root is           $root
     echo ISO is                $iso
     echo
     loopback loop $iso
     sleep -v -i 7 
     echo "Loading Linux" 
     linux (loop)/boot/syslinux/vmlinuz from=$iso volume=33 reboot=cold
     echo "Loading initrd"
     initrd (loop)/boot/syslinux/initrd.xz
}
grub4dos

Code: Select all

set ISOx=Porteus-LXQT-v3.1-x86_64-nu.iso
set ISOy=porteus-nemesis-v3.3-x86_64.iso

# menu entries
title Porteus 3.3 nemesis ISO     \n198MB\n %ISOy% 
find --set-root                       /ISOs/%ISOy%
map --heads=0 --sectors-per-track=0   /ISOs/%ISOy% (0xff) 
map --hook
root (0xff)
kernel /boot/syslinux/vmlinuz    from=/ISOs/%ISOy%   volume=40 reboot=cold ramsize=80%
initrd /boot/syslinux/initrd.xz
Ed

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#36 by francois » 26 Nov 2015, 17:30

@ed:
You need to change eth0 to wlan0 in the /config/network file. Or you do it on the iso or you use the changes= cheatcode.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Blaze
Moderator
Moderator
Posts: 1337
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#37 by Blaze » 26 Nov 2015, 17:31

Hi brokenman.
I fix USB Mouse sleeping after 5 seconds :)

First find the ID of you device (it sould look like 0458:003a):

Code: Select all

lsusb
Bus 003 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems) NetScroll+ Mini Traveler / Genius NetScroll 120
Open /etc/laptop-mode/conf.d/runtime-pm.conf and find

Code: Select all

# The list of Device IDs that should not use autosuspend. Use system commands or
# look into sysfs to find out the IDs of your devices.
# Example: AUTOSUSPEND_DEVID_BLACKLIST="046d:c025 0123:abcd"
AUTOSUSPEND_RUNTIME_DEVID_BLACKLIST="" 
add ID 0458:003a of usb mouse to

Code: Select all

# The list of Device IDs that should not use autosuspend. Use system commands or
# look into sysfs to find out the IDs of your devices.
# Example: AUTOSUSPEND_DEVID_BLACKLIST="046d:c025 0123:abcd"
AUTOSUSPEND_RUNTIME_DEVID_BLACKLIST="0458:003a" 
after reboot Porteus Nemesis. Done. Freezes of USB mouse is gone.
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#38 by francois » 26 Nov 2015, 17:53

Thanks blaze.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Blaze
Moderator
Moderator
Posts: 1337
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#39 by Blaze » 26 Nov 2015, 18:03

I think it's trouble with freezes of USB mouse in xf86-input-* packages.

I install Xorg-server

Code: Select all

root ~ # pacman -S xorg-server
resolving dependencies...
looking for conflicting packages...
:: xorg-server and xf86-input-joystick are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-joystick? [y/N] y
:: xorg-server and xf86-input-keyboard are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-keyboard? [y/N] y
:: xorg-server and xf86-input-libinput are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-libinput? [y/N] y
:: xorg-server and xf86-input-mouse are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-mouse? [y/N] y
:: xorg-server and xf86-input-vmmouse are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-vmmouse? [y/N] y
:: xorg-server and xf86-input-void are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-void? [y/N] y
:: xorg-server and xf86-video-ark are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-ark? [y/N] y
:: xorg-server and xf86-video-ati are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-ati? [y/N] y
:: xorg-server and xf86-video-dummy are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-dummy? [y/N] y
:: xorg-server and xf86-video-fbdev are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-fbdev? [y/N] y
:: xorg-server and xf86-video-glint are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-glint? [y/N] y
:: xorg-server and xf86-video-i128 are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-i128? [y/N] y
:: xorg-server and xf86-video-intel are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-intel? [y/N] y
:: xorg-server and xf86-video-mach64 are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-mach64? [y/N] y
:: xorg-server and xf86-video-neomagic are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-neomagic? [y/N] y
:: xorg-server and xf86-video-nouveau are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-nouveau? [y/N] y
:: xorg-server and xf86-video-nv are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-nv? [y/N] y
:: xorg-server and xf86-video-openchrome are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-openchrome? [y/N] y
:: xorg-server and xf86-video-r128 are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-r128? [y/N] y
:: xorg-server and xf86-video-savage are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-savage? [y/N] y
:: xorg-server and xf86-video-siliconmotion are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-siliconmotion? [y/N] y
:: xorg-server and xf86-video-sis are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-sis? [y/N] y
:: xorg-server and xf86-video-tdfx are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-tdfx? [y/N] y
:: xorg-server and xf86-video-trident are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-trident? [y/N] y
:: xorg-server and xf86-video-vesa are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-vesa? [y/N] y
:: xorg-server and xf86-video-vmware are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-vmware? [y/N] y
:: xorg-server and xf86-video-voodoo are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-voodoo? [y/N] y

Packages (29) xf86-input-evdev-2.10.0-2  xf86-input-joystick-1.6.2-5 [removal]
              xf86-input-keyboard-1.8.1-1 [removal]
              xf86-input-libinput-0.15.0-1 [removal]
              xf86-input-mouse-1.9.1-1 [removal]
              xf86-input-vmmouse-13.1.0-1 [removal]
              xf86-input-void-1.4.1-1 [removal]
              xf86-video-ark-0.7.5-6 [removal]
              xf86-video-ati-1:7.5.0-2 [removal]
              xf86-video-dummy-0.3.7-4 [removal]
              xf86-video-fbdev-0.4.4-4 [removal]
              xf86-video-glint-1.2.8-6 [removal]
              xf86-video-i128-1.3.6-6 [removal]
              xf86-video-intel-1:2.99.917+478+gdf72bc5-2 [removal]
              xf86-video-mach64-6.9.5-1 [removal]
              xf86-video-neomagic-1.2.9-1 [removal]
              xf86-video-nouveau-1.0.11-3 [removal]
              xf86-video-nv-2.1.20-6 [removal]
              xf86-video-openchrome-0.3.3-5 [removal]
              xf86-video-r128-6.10.0-1 [removal]
              xf86-video-savage-2.3.8-1 [removal]
              xf86-video-siliconmotion-1.7.8-1 [removal]
              xf86-video-sis-0.10.8-1 [removal]
              xf86-video-tdfx-1.4.5-6 [removal]
              xf86-video-trident-1.3.7-1 [removal]
              xf86-video-vesa-2.3.4-1 [removal]
              xf86-video-vmware-13.1.0-2 [removal]
              xf86-video-voodoo-1.2.5-6 [removal]  xorg-server-1.18.0-3

Total Download Size:    1.28 MiB
Total Installed Size:   3.51 MiB
Net Upgrade Size:      -6.07 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages ...
 xf86-input-evdev-2....    29.7 KiB   413K/s 00:00 [######################] 100%
 xorg-server-1.18.0-...  1279.4 KiB  1469K/s 00:01 [######################] 100%
(2/2) checking keys in keyring                     [######################] 100%
(2/2) checking package integrity                   [######################] 100%
(2/2) loading package files                        [######################] 100%
(2/2) checking for file conflicts                  [######################] 100%
(29/29) checking available disk space              [######################] 100%
( 1/27) removing xf86-video-voodoo                 [######################] 100%
( 2/27) removing xf86-video-vmware                 [######################] 100%
( 3/27) removing xf86-video-vesa                   [######################] 100%
( 4/27) removing xf86-video-trident                [######################] 100%
( 5/27) removing xf86-video-tdfx                   [######################] 100%
( 6/27) removing xf86-video-sis                    [######################] 100%
( 7/27) removing xf86-video-siliconmotion          [######################] 100%
( 8/27) removing xf86-video-savage                 [######################] 100%
( 9/27) removing xf86-video-r128                   [######################] 100%
(10/27) removing xf86-video-openchrome             [######################] 100%
(11/27) removing xf86-video-nv                     [######################] 100%
(12/27) removing xf86-video-nouveau                [######################] 100%
(13/27) removing xf86-video-neomagic               [######################] 100%
(14/27) removing xf86-video-mach64                 [######################] 100%
(15/27) removing xf86-video-intel                  [######################] 100%
(16/27) removing xf86-video-i128                   [######################] 100%
(17/27) removing xf86-video-glint                  [######################] 100%
(18/27) removing xf86-video-fbdev                  [######################] 100%
(19/27) removing xf86-video-dummy                  [######################] 100%
(20/27) removing xf86-video-ati                    [######################] 100%
(21/27) removing xf86-video-ark                    [######################] 100%
(22/27) removing xf86-input-void                   [######################] 100%
(23/27) removing xf86-input-vmmouse                [######################] 100%
(24/27) removing xf86-input-mouse                  [######################] 100%
(25/27) removing xf86-input-libinput               [######################] 100%
(26/27) removing xf86-input-keyboard               [######################] 100%
(27/27) removing xf86-input-joystick               [######################] 100%
(1/2) upgrading xf86-input-evdev                   [######################] 100%
(2/2) upgrading xorg-server                        [######################] 100%
root ~ #
and recived this log from /var/log/Xorg.0.log

Code: Select all

[   161.540] (**) Option "xkb_rules" "evdev"
[   161.541] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event3)
[   161.541] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall"
[   161.541] (II) Using input driver 'evdev' for 'Genius Optical Mouse'
[   161.541] (**) Genius Optical Mouse: always reports core events
[   161.541] (**) evdev: Genius Optical Mouse: Device: "/dev/input/event3"
[   161.592] (--) evdev: Genius Optical Mouse: Vendor 0x458 Product 0x3a
[   161.592] (--) evdev: Genius Optical Mouse: Found 3 mouse buttons
[   161.592] (--) evdev: Genius Optical Mouse: Found scroll wheel(s)
[   161.592] (--) evdev: Genius Optical Mouse: Found relative axes
[   161.592] (--) evdev: Genius Optical Mouse: Found x and y relative axes
[   161.592] (II) evdev: Genius Optical Mouse: Configuring as mouse
[   161.592] (II) evdev: Genius Optical Mouse: Adding scrollwheel support
[   161.592] (**) evdev: Genius Optical Mouse: YAxisMapping: buttons 4 and 5
[   161.592] (**) evdev: Genius Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   161.592] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2:1.0/0003:0458:003A.0001/input/input3/event3"
[   161.592] (II) XINPUT: Adding extended input device "Genius Optical Mouse" (type: MOUSE, id 8)
[   161.592] (II) evdev: Genius Optical Mouse: initialized for relative axes.
[   161.592] (**) Genius Optical Mouse: (accel) keeping acceleration scheme 1
[   161.592] (**) Genius Optical Mouse: (accel) acceleration profile 0
[   161.592] (**) Genius Optical Mouse: (accel) acceleration factor: 2.000
[   161.592] (**) Genius Optical Mouse: (accel) acceleration threshold: 4
[   161.593] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[   161.593] (II) No input driver specified, ignoring this device.
[   161.593] (II) This device may have been added with another device file.
BTW after install xorg-server i can't to login how root via Logout > Switch User - again, I'm staying as guest and

Code: Select all

guest ~ $ su
Password: 
Failed to connect to bus: Operation not permitted
root /home/guest # 
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 785
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#40 by ncmprhnsbl » 26 Nov 2015, 22:01

hey Blaze, welcome to the rolling repo, you just upgraded xorg-server to version 1.18.0-3 from 1.17.-- ... therefore the conflicts..
and i believe with xorg 1.18 no longer allows root graphical logins?(read somewhere..)

:Yahoo!: good find on the mouse, works for me..
i wonder if using a whitelist instead would be better..

@aus9
remember experience may not equal knowledge...
re: /etc/arch-release >what brokenman said,, never noticed it meself

re: wicd >>> i have wicd on my void install.. has been a bit troublsome at times...but this could be a void thing..havnt dug too deeply yet..
it needs python2 tho, which is quite large..

network applets go a bit like this:
nm-applet >>. gtk3 (older gtk2 in AUR)
wicd-gtk >>> gtk2, python2
connman >>guis in the AUR
=not many choices without building..

@Ahau welcome back :)
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 785
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#41 by ncmprhnsbl » 26 Nov 2015, 22:03

ok test run on laptop > i7 amd-radeon/intel(buitin) video ... started up ok ... then deadbeef froze ... opnbox still worked but no apps or lxpanel..
tried to kill deadbeef via ob nope >tty2 root login > tty1 no change > tty 2 systemctl stop/start lxdm > nope > systemctl poweroff > endless 4 stopjob looping > hit the power button

not pleasant :(
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

aus9

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#42 by aus9 » 26 Nov 2015, 22:48

EDIT see below post. I am leaving other comment so ncmprhnsbl is not replying to an empty post

@ncmprhnsbl
Please see if this solves your kb issue.
Also as I know you know more than me, drop by and give me any suggestions on the best Arch chroot that you care to share.
Or anyone else I hope too.
viewtopic.php?f=137&t=5249

8)
Last edited by aus9 on 26 Nov 2015, 23:41, edited 1 time in total.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 785
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#43 by ncmprhnsbl » 26 Nov 2015, 23:26

aus9 wrote:Please see if this solves your kb issue.
not me... my kb is fine..(except being serial and very old )

maybe something in the 'mouse' config file to set laptop=yes/no that sets CONTROL_RUNTIME_AUTOSUSPEND=0/1

altho looking at /etc/laptop-mode/laptop-mode.conf

Code: Select all

ENABLE_LAPTOP_MODE_ON_AC=0
shouldnt this detect and disable laptop mode when on AC (tower(which im also using))??
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

aus9

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#44 by aus9 » 26 Nov 2015, 23:48

ncmprhnsbl
I have edit above post but appreciate you looking into new file

@brokenman @ncmprhnsbl
New post I think now solved my USB mouse kb issues. As prevously reported, mouse was frozen on first boot up.
It still is when I have a cheatcode without changes= (And some keyboard presses were not being accepted)

Based on ncmprhnsbl post I have deleted my earlier stuff and looked for TOWER or non-laptop users at this config file
/etc/laptop-mode/laptop-mode.conf

I made one admendment and rebooted to test.....so far it works
Newbies may spot that there is a new red error message on bootup because my change causes
laptop-mode.service to be disabled on bootup

Use root powers to edit file so config line reads
ENABLE_LAPTOP_MODE_TOOLS=0
reboot to test.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 785
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: Porteus Nemesis v3.3 BUG REPORTS

Post#45 by ncmprhnsbl » 27 Nov 2015, 00:04

my only issue with disabling laptop mode is it handles cpu frequency scaling..
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

Locked