[SOLVED] pacman/pman --feedback do not attempt

Arch based Porteus community project
aus9

[SOLVED] pacman/pman --feedback do not attempt

Post#1 by aus9 » 08 Nov 2015, 06:08

EDIT subject to remove pamac

WARNING I do not know what I am doing so do not attempt.
I am aware that we may have some modules built for us etc and am aware that ArchLinux is normally a rolling release.

I started with trying to find pamac (and mtpaint) as mentioned by francois. here is my journey

feel free to comment or not...commands are root

Code: Select all

pacman -Sy
pacman -Qk
pacman -Su  ( not proceeded---abort)
#####################################################################
pacman -S mtpaint 
resolving dependencies...
looking for conflicting packages...

Packages (1) mtpaint-3.40-15

Total Download Size:   0.47 MiB
Total Installed Size:  1.56 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 mtpaint-3.40-15-x86_64                                   480.5 KiB   312K/s 00:02 [################################################] 100%
(1/1) checking keys in keyring                                                     [################################################] 100%
warning: Public keyring not found; have you run 'pacman-key --init'?
downloading required keys...
error: key "FCF3C8CB5CF9C8D4" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (could not find or read file)
Errors occurred, no packages were upgraded.
#########################################################################################
pacman-key --init
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
gpg: migration succeeded
gpg: Generating pacman keyring master key...
gpg: key 4DCACEFC marked as ultimately trusted
gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
gpg: Done
==> Updating trust database...
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
######################################################################
pacman -S pamac  
error: target not found: pamac
#######################################################################
pacman -S mtpaint 
resolving dependencies...
looking for conflicting packages...

Packages (1) mtpaint-3.40-15

Total Download Size:   0.47 MiB
Total Installed Size:  1.56 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 mtpaint-3.40-15-x86_64                                   480.5 KiB   312K/s 00:02 [################################################] 100%
(1/1) checking keys in keyring                                                     [################################################] 100%
warning: Public keyring not found; have you run 'pacman-key --init'?
downloading required keys...
error: key "FCF3C8CB5CF9C8D4" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (could not find or read file)
Errors occurred, no packages were upgraded.
####################################################################################3
# pacman-key --init
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
gpg: migration succeeded
gpg: Generating pacman keyring master key...
gpg: key 4DCACEFC marked as ultimately trusted
gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
gpg: Done
==> Updating trust database...
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
Last edited by aus9 on 10 Nov 2015, 09:28, edited 2 times in total.

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: pacman/pamac --feedback do not attempt

Post#2 by francois » 09 Nov 2015, 05:34

1.0 The story seems to say that you installed mpaint, is it the case?

2,0 Concerning pamac I have tried to do it thru pacaur which is a wrapper for pacman and for aur but was not able to get it thru. pamac is a package build available in AUR with the name pamac-aur. You have to build it:
https://wiki.archlinux.org/index.php/AUR_helpers

Pacman manages official binaries, whereas pacaur will manage both binaries of pacman and of package build of AUR. AUR are packages maintained by the community and not already accepted as binaries. yaourt is another way of building AUR packages.

You can try to buil a gui interface for pacman if you want:
https://aur.archlinux.org/packages/tkpacman/

Code: Select all

yaourt -S tkpacman 
Make sure you have the prerequisite libraries. :wink:
Carpe diem.

aus9

Re: pacman/pamac --feedback do not attempt

Post#3 by aus9 » 09 Nov 2015, 07:20

The story seems to say that you installed mpaint, is it the case?
No it failed see the gpg errors.

However, under /var/cache/pacman/pkg I do have a mtpaint * .tar.xz download.
I am reluctant to try and move the bits into a xzm until I resolve the gpg error.

to my eyesight, my first attempt to download it says run the pacman-key --init command
then when I repeat the mtpaint command it keeps on borking the

downloading required keys...
error: key "FCF3C8CB5CF9C8D4" could not be looked up remotely

what is misleading you that mtpaint is installed is the message that
Errors occurred, no packages were upgraded.
tricking you into thinking its installed and not upgrading whereas, its not installed to begin with.

2) so going to etc/pacman.d/gnupg
I deleted all the keys and was able to start again and repeat all the commands and end up with the same error.

aus9

Re: pacman/pamac --feedback do not attempt

Post#4 by aus9 » 09 Nov 2015, 09:24

OK I forgot I disabled my router filter for port 11371 for keys now lets try again

Code: Select all

pacman -S mtpaint
(snip)downloading required keys...
:: Import PGP key 2048R/962855F072C7A01846405864FCF3C8CB5CF9C8D4, "Alexander R��dseth <rodseth@gmail.com>", created: 2011-09-29? [Y/n] y
File /var/cache/pacman/pkg/mtpaint-3.40-15-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded
OK lets try it manually

Code: Select all

gpg --keyserver hkp://pool.sks-keyservers.net --recv-key 962855F072C7A01846405864FCF3C8CB5CF9C8D4
gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: key 5CF9C8D4: public key "Alexander R�dseth <rodseth@gmail.com>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1
repeating mtpaint command still gives corrupt errors for the download.....OK manually delete /var/cache/pacman/pkg/mtpaint-3.40-15-x86_64.pkg.tar.xz
and lets start again.

Code: Select all

pacman -S mtpaint 
resolving dependencies...
looking for conflicting packages...

Packages (1) mtpaint-3.40-15

Total Download Size:   0.47 MiB
Total Installed Size:  1.56 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 mtpaint-3.40-15-x86_64                                   480.5 KiB   312K/s 00:02 [################################################] 100%
(1/1) checking keys in keyring                                                     [################################################] 100%
(1/1) checking package integrity                                                   [################################################] 100%
error: mtpaint: signature from "Alexander R��dseth <rodseth@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/mtpaint-3.40-15-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
I may be wrong but gpg does not seem to accept my import key command for mtpaint manually or thru pacman

I can't get past this error

error: failed to commit transaction (invalid or corrupted package (PGP signature))

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1027
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: pacman/pamac --feedback do not attempt

Post#5 by ncmprhnsbl » 09 Nov 2015, 12:29

run 'setup-pman' and that should sort all this(gpg keys) out for you (apart from the pacman-db-upgrade part) and make a module for you..
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

aus9

Re: pacman/pamac --feedback do not attempt

Post#6 by aus9 » 09 Nov 2015, 22:42

@ncmprhnsbl

Thankyou, that made a huge difference. If you have the time I just need to resolve the module issue before I can mark this as solved

Code: Select all

setup-pman
snip
/tmp/pacman-settings.xzm was moved to your modules directory
###############################################
pacman -S mtpaint
resolving dependencies...
looking for conflicting packages...
Packages (1) mtpaint-3.40-15
Total Download Size:   0.47 MiB
Total Installed Size:  1.56 MiB
:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 mtpaint-3.40-15-x86_64                                   480.5 KiB   315K/s 00:02 [################################################] 100%
(1/1) checking keys in keyring                                                     [################################################] 100%
(1/1) checking package integrity                                                   [################################################] 100%
(1/1) loading package files                                                        [################################################] 100%
(1/1) checking for file conflicts                                                  [################################################] 100%
(1/1) checking available disk space                                                [################################################] 100%
(1/1) installing mtpaint                                                           [################################################] 100%
Optional dependencies for mtpaint
    gifsicle: for exporting GIF files from mtPaint
Its not automaticaly moving any modules to my modules folder but my config/modules has there 2 lines
Move2ModuleDir=yes
ModuleDirectory=/mnt/sda3/nemesis/modules
When I did a search

Code: Select all

find / -name mtpaint*xzm
/mnt/sda3/porteus/modules/mtpaint-3.40-x86_64-bundle.xzm

find / -name mtpaint
/mnt/sda3/nemesis/changes/usr/bin/mtpaint
/mnt/live/memory/changes/usr/bin/mtpaint
/usr/bin/mtpaint
to my eyesight and understanding it appears to be doing a live injection AKA install and not creating a module?

##############################################

seeing your setup* suggestion I also ran

setup-config-pman

but that appears to be the same as the config/modules file

I did make one change and full reboot
RemovePkg=no

but no detected XZMs

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1027
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: pacman/pamac --feedback do not attempt

Post#7 by ncmprhnsbl » 10 Nov 2015, 00:32

this is because you have used pacman which doesnt make modules... (which would be ok if using changes)
use pman wrapper instead:

Code: Select all

pman -S mtpaint
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: pacman/pamac --feedback do not attempt

Post#8 by francois » 10 Nov 2015, 01:08

@aus9:
pamac is not available on AUR;

Code: Select all

guest /root $ yaourt -S pamac --insecure
[sudo] password for guest: 
error: target not found: pamac
guest /root $ 
octopi is an intersting alternative used on manjaro:
https://wiki.manjaro.org/index.php?title=Octopi

Code: Select all

guest /root $ yaourt -S octopi --insecure

==> Downloading octopi PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
x enable-kstatus.patch
x octopi-repoeditor.desktop
x octopi.install
acidicX commented on 2015-09-27 10:54 
aura also says octopi-notifier-kde and octopi-notifier are in conflict, is there a way to resolve this?

ImNtReal commented on 2015-09-28 13:47 
This is why I created octopi-notifier-qt4 as a separate package originally. I think I might try that, again.

kikadf commented on 2015-09-28 14:27 
@acidicX, after build, aura saves somewhere the builded binaries?
yaourt saved those in /tmp/yaourt-tmp-$USER/
After build, just cd /tmp/yaourt-tmp-$USER/  pacman -U "wanted binaries"
You can install only one octopi-notifier (default or kde version).

FiyreWyrkz commented on 2015-10-21 19:53 
It has been commented previously, however, I shall mention again. This package should likely only provide one of the octopi-notifier packages as there becomes a conflicting issue when trying to build and install the entire package.

Would seem logical to separate the plasma 4 stuff.

pkgname=('octopi' 'octopi-notifier' 'octopi-notifier-kde4' 'octopi-repoeditor' 'octopi-cachecleaner')

package_octopi-notifier() {...
conflicts=('octopi-notifier-qt4' 'octopi-notifier-kde' 'octopi-notifier-kde4')
...

package_octopi-notifier-kde4() ...
conflicts=('octopi-notifier' 'octopi-notifier-kde')
...

AnAkkk commented on 2015-10-28 00:02 
When using octopi-notifier on Plasma 5 and when there are updates available, plasmashell CPU usage keeps increasing over time and goes to 100% for some reason. Killing octopi-notifier solves it, and starting it again makes plasmashell goes back to 100%.

octopi 0.8.0-1  (2015-11-09 14:08)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> WARNING: This PKGBUILD describes a split package.
==> Specific package options are unknown
==> octopi dependencies:
 - qt5-declarative (already installed) [makedepend]
 - libnotify (already installed) [makedepend]
 - knotifications (package found) [makedepend]


==> Continue building octopi ? [Y/n]
==> --------------------------------
==> 
==> Building and installing package
==> Install or build missing dependencies for octopi:
[sudo] password for guest: 
resolving dependencies...
:: There are 2 providers available for phonon-qt5-backend:
:: Repository extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Enter a number (default=1): 1
looking for conflicting packages...

Packages (15) cdparanoia-10.2-5  gamin-0.1.10-8  gst-plugins-base-1.6.1-1
              gst-plugins-base-libs-1.6.1-1  gstreamer-1.6.1-1
              kcodecs-5.15.0-1  kconfig-5.15.0-1  kcoreaddons-5.15.0-1
              kwindowsystem-5.15.0-1  libdbusmenu-qt5-0.9.3+15.10.20150604-1
              libvisual-0.4.0-6  phonon-qt5-4.8.3-2
              phonon-qt5-gstreamer-4.8.2-1  qt5-x11extras-5.5.1-3
              knotifications-5.15.0-1

Total Download Size:    5.28 MiB
Total Installed Size:  36.13 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 gstreamer-1.6.1-1-x...  1776.5 KiB  2.36M/s 00:01 [######################] 100%
 gst-plugins-base-li...  1560.5 KiB  1680K/s 00:01 [######################] 100%
 cdparanoia-10.2-5-x...    64.9 KiB   618K/s 00:00 [######################] 100%
 libvisual-0.4.0-6-x...   121.8 KiB   771K/s 00:00 [######################] 100%
 gst-plugins-base-1....   170.0 KiB   881K/s 00:00 [######################] 100%
 phonon-qt5-gstreame...   103.7 KiB   757K/s 00:00 [######################] 100%
 phonon-qt5-4.8.3-2-...   256.6 KiB   812K/s 00:00 [######################] 100%
 libdbusmenu-qt5-0.9...   160.5 KiB   747K/s 00:00 [######################] 100%
 qt5-x11extras-5.5.1...    10.6 KiB  0.00B/s 00:00 [######################] 100%
 kwindowsystem-5.15....   172.9 KiB   924K/s 00:00 [######################] 100%
 kconfig-5.15.0-1-x86_64  306.3 KiB   738K/s 00:00 [######################] 100%
 kcodecs-5.15.0-1-x86_64  159.0 KiB   743K/s 00:00 [######################] 100%
 gamin-0.1.10-8-x86_64     43.1 KiB   756K/s 00:00 [######################] 100%
 kcoreaddons-5.15.0-...   362.9 KiB  1040K/s 00:00 [######################] 100%
 knotifications-5.15...   136.9 KiB   744K/s 00:00 [######################] 100%
(15/15) checking keys in keyring                   [######################] 100%
(15/15) checking package integrity                 [######################] 100%
(15/15) loading package files                      [######################] 100%
(15/15) checking for file conflicts                [######################] 100%
error: failed to commit transaction (conflicting files)
cdparanoia: /usr/bin/cdparanoia exists in filesystem
cdparanoia: /usr/lib/libcdda_interface.so exists in filesystem
cdparanoia: /usr/lib/libcdda_interface.so.0 exists in filesystem
cdparanoia: /usr/lib/libcdda_interface.so.0.10.2 exists in filesystem
cdparanoia: /usr/lib/libcdda_paranoia.so exists in filesystem
cdparanoia: /usr/lib/libcdda_paranoia.so.0 exists in filesystem
cdparanoia: /usr/lib/libcdda_paranoia.so.0.10.2 exists in filesystem
libvisual: /usr/lib/libvisual-0.4.so exists in filesystem
libvisual: /usr/lib/libvisual-0.4.so.0 exists in filesystem
libvisual: /usr/lib/libvisual-0.4.so.0.0.0 exists in filesystem
libvisual: /usr/lib/pkgconfig/libvisual-0.4.pc exists in filesystem
libvisual: /usr/share/locale/es_AR/LC_MESSAGES/libvisual-0.4.mo exists in filesystem
libvisual: /usr/share/locale/es_ES/LC_MESSAGES/libvisual-0.4.mo exists in filesystem
Errors occurred, no packages were upgraded.
==> Restart building octopi ? [y/N]
==> -------------------------------
==> 
guest /root $ yaourt -S pamac --insecure
[sudo] password for guest: 
error: target not 
There isa problem with conflicting packages.
Carpe diem.

aus9

Re: pacman/pamac --feedback do not attempt

Post#9 by aus9 » 10 Nov 2015, 02:22

@francois
OK I will still pursue a gui maybe in a separate post. This one is still not resolved

@ncmprhnsbl
So I tried this ...all root commands

Code: Select all

pman -S mtpaint
warning: mtpaint-3.40-15 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) mtpaint-3.40-15

Total Installed Size:  1.56 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                     [################################################] 100%
(1/1) checking package integrity                                                   [################################################] 100%
(1/1) loading package files                                                        [################################################] 100%
(1/1) checking for file conflicts                                                  [################################################] 100%
(1/1) checking available disk space                                                [################################################] 100%
(1/1) reinstalling mtpaint                                                         [################################################] 100%
root /home/guest # umount /mnt/sda1
root /home/guest # find / -name mtpaint*xzm
/mnt/sda3/porteus/modules/mtpaint-3.40-x86_64-bundle.xzm
no module for nemesis appears to be created?

attempt 2
##########

Code: Select all

pman -R mtpaint
checking dependencies...

Packages (1) mtpaint-3.40-15

Total Removed Size:  1.56 MiB

:: Do you want to remove these packages? [Y/n] y
(1/1) removing mtpaint
pman -S mtpaint
(same as above )
find / -name mtpaint*xzm
/mnt/sda3/porteus/modules/mtpaint-3.40-x86_64-bundle.xzm

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1027
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: pacman/pman --feedback do not attempt

Post#10 by ncmprhnsbl » 10 Nov 2015, 06:31

@francois ;) -Ss = search

Code: Select all

guest ~ $ yaourt -Ss --insecure pamac
aur/pamac-aur 2.4.3-3 (46)
    A Gtk3 frontend for libalpm
aur/pamac-patched-headerbar 2.4.3-2 (0)
    A Gtk3 frontend for libalpm, patched by me to use GtkHeaderBar to match 
    GNOME
@aus9 are you using changes cheatcode? i'm not sure if brokenman made it so module isnt created when using changes?
heres how it should look: (without 'changes=' cheatcode)

Code: Select all

root / # pacman-db-upgrade
==> Pre-4.2 database format detected - upgrading...
root / # pman -S mtpaint
resolving dependencies...
looking for conflicting packages...

Packages (1) mtpaint-3.40-15

Total Download Size:   0.47 MiB
Total Installed Size:  1.56 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 mtpaint-3.40-15-x86_64   480.5 KiB  13.8K/s 00:35 [######################] 100%
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
(1/1) installing mtpaint                           [######################] 100%
Optional dependencies for mtpaint
    gifsicle: for exporting GIF files from mtPaint
 Decompressing mtpaint-3.40-15-x86_64.pkg.tar.xz 
 Stripping mtpaint-3.40-15-x86_64.pkg.tar.xz 

 Size before strip: 
 1.7M
 Size after strip: 
 1.7M

Parallel mksquashfs: Using 2 processors
Creating 4.0 filesystem on /tmp/mtpaint-3.40-15-x86_64.pkg.xzm, block size 262144.
[=================================================================\] 28/28 100%

Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
	compressed data, compressed metadata, compressed fragments, compressed xattrs
	duplicates are removed
Filesystem size 507.35 Kbytes (0.50 Mbytes)
	31.56% of uncompressed filesystem size (1607.78 Kbytes)
Inode table size 618 bytes (0.60 Kbytes)
	24.94% of uncompressed inode table size (2478 bytes)
Directory table size 590 bytes (0.58 Kbytes)
	33.13% of uncompressed directory table size (1781 bytes)
Number of duplicate files found 0
Number of inodes 77
Number of files 26
Number of fragments 4
Number of symbolic links  0
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 51
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	root (0)

 Operation completed successfully. 
The following modules were copied to your modules folder:
/mnt/sdb1/nemesis/modules

mtpaint-3.40-15-x86_64.pkg.xzm

Packages were removed from /var/cache/pacman/pkg.
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

aus9

Re: pacman/pman --feedback do not attempt

Post#11 by aus9 » 10 Nov 2015, 09:06

@aus9 are you using changes cheatcode?
Yes and did not realize that changes cheatcode was seen by some as being not recommended?

OK lets go, booted up with nochanges bootcode and commands as root

Code: Select all

pacman-db-upgrade
==> Pre-4.2 database format detected - upgrading...
pman -S mtpaint
resolving dependencies...
looking for conflicting packages...
Packages (1) mtpaint-3.40-15
Total Download Size:   0.47 MiB
Total Installed Size:  1.56 MiB
:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 mtpaint-3.40-15-x86_64                             480.5 KiB   313K/s 00:02 [###########################################] 100%
(1/1) checking keys in keyring                                               [###########################################] 100%
(1/1) checking package integrity                                             [###########################################] 100%
(1/1) loading package files                                                  [###########################################] 100%
(1/1) checking for file conflicts                                            [###########################################] 100%
(1/1) checking available disk space                                          [###########################################] 100%
(1/1) installing mtpaint                                                     [###########################################] 100%
Optional dependencies for mtpaint
    gifsicle: for exporting GIF files from mtPaint
 Decompressing mtpaint-3.40-15-x86_64.pkg.tar.xz 
 Stripping mtpaint-3.40-15-x86_64.pkg.tar.xz 
 Size before strip: 
 1.7M
 Size after strip: 
 1.7M
Parallel mksquashfs: Using 4 processors
Creating 4.0 filesystem on /tmp/mtpaint-3.40-15-x86_64.pkg.xzm, block size 262144.
[================================================================================================================/] 28/28 100%
Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
	compressed data, compressed metadata, compressed fragments, compressed xattrs
	duplicates are removed
Filesystem size 507.34 Kbytes (0.50 Mbytes)
	31.56% of uncompressed filesystem size (1607.78 Kbytes)
Inode table size 618 bytes (0.60 Kbytes)
	24.94% of uncompressed inode table size (2478 bytes)
Directory table size 590 bytes (0.58 Kbytes)
	33.13% of uncompressed directory table size (1781 bytes)
Number of duplicate files found 0
Number of inodes 77
Number of files 26
Number of fragments 4
Number of symbolic links  0
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 51
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	root (0)
 ERROR: Module directory is not mounted or unwritable. 
Check your module config file for ModuleDirctory=
 Operation completed successfully. 
The following modules were copied to your modules folder:
/mnt/sda3/nemesis/modules
mtpaint-3.40-15-x86_64.pkg.xzm
ERROR: Module directory is not mounted or unwritable.
well blow me, I should have checked this but this is the first time I get the error to check it

Code: Select all

ls -al /mnt/sda3/nemesis
total 36
dr-xr-xr-x  7 root root  4096 Nov  7 13:09 .
drwxr-xr-x 10 1001 games 4096 Nov  7 13:04 ..
dr-xr-xr-x  2 root root  4096 Nov  9 22:22 base
drwxr-xr-x 11 root root  4096 Nov  1 21:50 changes
-r-xr-xr-x  1 root root   853 Oct  9 22:36 make_iso.sh
dr-xr-xr-x  2 root root  4096 Nov 10 08:56 modules
-r--r--r--  1 root root   437 Dec 12  2013 nemesis-v3.1-x86_64.sgn
dr-xr-xr-x  2 root root  4096 Nov  9 23:02 optional
drwxr-xr-x  2 root root  4096 Nov  1 21:50 rootcopy
However, it is likely to be explained that I simply unpacked the iso and copied umm cd files and should have made them read writeable
However (2) without chmod command to fix this issue

Code: Select all

find / -name mtpaint-3.40-15-x86_64.pkg.xzm
/mnt/sda3/nemesis/modules/mtpaint-3.40-15-x86_64.pkg.xzm
It still got in there!

will fix and report back if changes bootcode now works with the chmod to fix directories

Code: Select all

chmod 755 -R /mnt/sda3/nemesis

aus9

Re: pacman/pman --feedback do not attempt

Post#12 by aus9 » 10 Nov 2015, 09:27

OK this post is a full reboot using the changes bootcode cheatcode

no modules is created so it does look like I will need to watch that.

ncmprhnsbl and francois

You have got beyond the job description to help me out.
I now know how to get a module and the gui to package manager can be a later topic

for now, thankyou very much marked as solved

:friends:

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1027
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: [SOLVED] pacman/pman --feedback do not attempt

Post#13 by ncmprhnsbl » 10 Nov 2015, 12:06

aus9 wrote: Yes and did not realize that changes cheatcode was seen by some as being not recommended?
well it is the default entry in the bootloader and definately not "not recomended"
aus9 wrote:It still got in there!
that it wrote to unwritable is a bit odd..

bear in mind that this is a work in progress and i think pman should inform us when its not
making a module and why..or perhaps a choice.. along the lines of:
You are saving your changes, so you dont need a module?(Y/N)
or
Changes cheatcode detected, package(s) will be installed. Do you wish to make a Module as well?(Y/N)
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
brokenman
Site Admin
Site Admin
Posts: 5657
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: [SOLVED] pacman/pman --feedback do not attempt

Post#14 by brokenman » 10 Nov 2015, 21:15

You are saving your changes, so you dont need a module?(Y/N
Yes thanks. This has been implemented in the latest version (as yet unreleased). If you are saving changes but have the option to create modules in the config file then it will still create the module. I have also added a script to create a module from a package that you already have installed. A little like: bacman will create a tarball of a package you have installed. pkg2xzm will create a porteus module from a package.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: [SOLVED] pacman/pman --feedback do not attempt

Post#15 by francois » 10 Nov 2015, 22:19

@ brokenman:
Very good.

Thanks.
Carpe diem.

Post Reply