minor bug gutenprint espcutil no dev or module

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
aus9

minor bug gutenprint espcutil no dev or module

Post#1 by aus9 » 02 Nov 2015, 09:15

Hi

On another distro I can run a command to get my ink levels like this

Code: Select all

escputil --ink-level --raw-device /dev/usb/lp0
That command belongs to the gutenprint package for Portesu 64 bit, I also searched USM and its not an independent package
---nor could I find mtink but mtink has less model support for ink levels. I have the 07-printing and gutenprint XZM active

2) Back on Porteus I try with root powers

Code: Select all

ls /dev | grep usb (no hits)
lsmod | grep usb (no hits)
modprobe usblp
(result) modprobe: FATAL: Module usblp not found
3) OK lets load the cups XZM

still no change to modprobe or /dev/usb issue

thanks for reading

##################
trivia below
I can get my Epson TX110 to print using just the 07-printing XZM so all is not lost
but I prefer to get ink levels.

When I rebooted into my other distro, because I had not used the printer for a long time, my ink was drier than my mouth
so replaced all cartridges and got my ink levels then rebooted to test on Porteus.

aus9

Re: minor bug gutenprint espcutil no dev or module

Post#2 by aus9 » 03 Nov 2015, 23:35

Ok I found a file that has some relevance but its pathway is NOT
/etc/modprobe.d ----me thinks it should not blacklist the usblp module

EDIT I was wrong but still unresolved see below, thanks francois

pathway found was
/mnt/sda3/porteus/changes/lib/modprobe.d

contents of file=cups-blacklist-usblp.conf
##############################################################################
# Do not edit this file; instead, copy it to /etc/modprobe.d/ and edit that
##############################################################################

# Blacklist the (obsolete) usblp module. While the CUPS package has been
# patched to handle if this module is loaded, there are some reports that
# it doesn't always work. Anyway, there should be no need to have this
# module loaded, so we'll blacklist it just in case.

blacklist usblp
In case I am wrong, what is the best way to check for blacklisted modules please?
Last edited by aus9 on 04 Nov 2015, 06:44, edited 1 time in total.

User avatar
francois
Contributor
Contributor
Posts: 5122
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: minor bug gutenprint espcutil no dev or module

Post#3 by francois » 04 Nov 2015, 03:18

Hello aus9.

Porteus is slackware. Here is what I found:
http://www.linuxquestions.org/questions ... 175490109/
Even though Pat added my patch to cups that addresses outstanding conflicts some printers have with usblp, he chose a conservative approach and also blacklisted "usblp" in Slackware 14.1.

You can disable the blacklisting by removing /lib/modprobe.d/cups-blacklist-usblp.conf.

--mancha


So make a backup of the file by changing its name to cups-blacklist-usblp.confbak.

I hope this helps.
Carpe diem.

aus9

Re: minor bug gutenprint espcutil no dev or module

Post#4 by aus9 » 04 Nov 2015, 06:38

Hmmm thanks for looking into this

What I have now is this, after full reboot still no joy

Code: Select all

ls -al /lib/modprobe.d/cups-blacklist-usblp.conf 
---------- 1 root root 525 Oct 11  2013 /lib/modprobe.d/cups-blacklist-usblp.conf

cat /etc/modprobe.d/cups-blacklist-usblp.conf 
##############################################################################
# Do not edit this file; instead, copy it to /etc/modprobe.d/ and edit that
##############################################################################

# Blacklist the (obsolete) usblp module.  While the CUPS package has been
# patched to handle if this module is loaded, there are some reports that
# it doesn't always work.  Anyway, there should be no need to have this
# module loaded, so we'll blacklist it just in case.

# blacklist usblp
#####################################################################
lsmod | grep usblp
root@porteus:/home/guest# modprobe usblp
modprobe: FATAL: Module usblp not found.
In case you don't want to read my code box it reads
disable the /lib/modprobe.d/cups-blacklist-usblp.conf
b as per the contents, file copies to etc/modprob.d
c as per contents of file, file contents changed to disable the command bllacklist usblp

BTW I do not have any bootcode to blacklist this module

Maybe there is something else I need to do?

Kind of ontopic, when I look at my Debian kernel config, I can not even find usblp mentioned.
I found the neko kernel and downloaded that to check out his config and its not mentioned there either.

On Debian it exists at
lib/modules/kernel/drivers/usb/class/usblp.ko

Post Reply