Tcc (Gcc?) is missing...

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
User avatar
blue4meridian
Shogun
Shogun
Posts: 279
Joined: 29 Sep 2014, 05:58
Distribution: 64bit LxQt (Plastique/Mikachu)
Location: Jersey City N.J. USA

Tcc (Gcc?) is missing...

Post#1 by blue4meridian » 18 Oct 2015, 17:41

Salutations... :good:

Unsuccessful... :wall:
(Pls Note: I replaced glibc with musl and gcc with tcc.)

Code: Select all

root@porteus:/home/guest/Downloads# src2pkg libressl-2.3.0.tar.gz
/usr/libexec/src2pkg/01-pre_process: line 789: gcc: command not found
/usr/libexec/src2pkg/01-pre_process: line 918: gcc: command not found
  Notice - Creating src2pkg-helpers:
  src2pkg uses a shared library and a few programs
  when creating packages. For best compatibility,
  these binaries will be compiled on your system.
  They are then installed in a private directory.
  When done, src2pkg is ready for use.

  TEMP_DIR=/usr/src/src2pkg/builds/src2pkg-helpers
  Starting build in 5 seconds
/usr/libexec/src2pkg/01-pre_process: line 789: gcc: command not found
/usr/libexec/src2pkg/01-pre_process: line 918: gcc: command not found
Unpacking sources - OK
Creating libsentry - Ooops! Can't live without it...
Found source archive: libressl-2.3.0.tar.gz
Creating working directories:
   PKG_DIR=/tmp/libressl-2.3.0-x86_64-1
   SRC_DIR=/tmp/libressl-2.3.0-src-1
Unpacking source archive - Done
Correcting source permissions - Done
Checking for patches - None found
Found configure script - Done
Configuring sources using:
 LDFLAGS="-Wl,-O1,-L/lib64,-L/usr/lib64" CFLAGS="-O2 -fPIC -m64" ./configure --prefix=/usr
ERROR! Configuring sources has failed!
This may be because of some missing libraries, or you may
need to pass extra options to configure using EXTRA_CONFIGS.
Sorry! No Dependency or Requirements information found.
Best Regards... :beer:

User avatar
blue4meridian
Shogun
Shogun
Posts: 279
Joined: 29 Sep 2014, 05:58
Distribution: 64bit LxQt (Plastique/Mikachu)
Location: Jersey City N.J. USA

Re: Tcc (Gcc?) is missing...

Post#2 by blue4meridian » 21 Oct 2015, 12:24

Salutations... :good:

Ok... the problem was tcc. Back to the drawing board. :wall:

Best Regards... :beer:

Posted by 71.250.239.251 via http://webwarper.net
This is added while posting a message to avoid misusing the service

Post Reply