Wake On Lan Not Working With Certain NICs

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Wake On Lan Not Working With Certain NICs

Post#1 by feist » 18 Sep 2015, 22:12

Hello,

I have upgraded to version 3.5.0 to see if the new version would fix a problem we've been having with WOL not working with specific models, but the problem persists.

Specifically, WOL does not work with these NICs:
Broadcom NetXtreme 57XX (Dell OptiPlex GX520)
Intel Pro/100 VE (Gateway E2100)

WOL works perfectly with another model we are using with Realtek NIC just fine. For the above PCs, when we ran Windows on them WOL worked just fine and I haven't changed anything in the BIOS. I have verified WOL is still enabled in the BIOS.

Thanks

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Wake On Lan Not Working With Certain NICs

Post#2 by fanthom » 19 Sep 2015, 10:54

Hello feist,

Please follow this doc:
http://porteus-kiosk.org/wol.html

Maybe linux drivers does not support WOL on Intel/Broadcom NICs? Please login to kiosk through ssh and post an output following commands:

Code: Select all

card=`route -n | grep " UG " | head -n1 | rev | cut -d" " -f1 | rev`
echo $card
ethtool $card | grep Wake-on
Thank you.
Please add [Solved] to your thread title if the solution was found.

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#3 by feist » 21 Sep 2015, 21:37

Well this is embarrassing. I have added these command to the global config.txt in order to get SSH onto the kiosks:

root_password=xxxxxxxxx
additional_components=08-ssh.xzm

After the reconfiguration and reboot, I cannot SSH into the kiosks. I keep getting "Connection Refused." I have SSH previous versions before, so I am not sure what I am doing wrong? Is there anything else I am missing?

I have changed the ports like so to see if it would help, but I still get the same error message. I can ping the kiosks, but no SSH?
ssh_port=555

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Wake On Lan Not Working With Certain NICs

Post#4 by fanthom » 22 Sep 2015, 08:49

Can your kiosk access porteus-kiosk.org to download 08-ssh.xzm component during reconfiguration?
Maybe a typo in the parameters name? Please run wizard in VirtualBox and double check that your config is ok.
Please add [Solved] to your thread title if the solution was found.

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#5 by feist » 23 Sep 2015, 16:18

Ok, it seems that if I add rm /etc/acpi/default.sh to /etc/rc.d/rc.local in order to disable the power button then it will break SSH. I configured the kiosk using an unmodified ISO in order to get SSH working. As requested:

root@vclcat02:~# echo $card
eth0

root@vclcat02:~# ethtool $card | grep Wake-on
Supports Wake-on: g
Wake-on: g

I also tested WOL with the unmodified iso, but WOL still does not work. As a side note, perhaps the Kiosk Wizard can have a choice to disable the Power Button?

Thanks

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Wake On Lan Not Working With Certain NICs

Post#6 by fanthom » 23 Sep 2015, 16:58

"it seems that if I add rm /etc/acpi/default.sh to /etc/rc.d/rc.local in order to disable the power button then it will break SSH."
There is no connection between these two. Its rather something else ...

"As requested:"
Everything looks ok. Could you boot Ubuntu live CD -> switch the NIC to WOL mode -> shutdown the PC and check if it wakes correctly?

"As a side note, perhaps the Kiosk Wizard can have a choice to disable the Power Button?"
I wont be able to disable the power button completely. If user holds it for 5 secs then can still force shutdown. From the hardware point of view its better to power off the kiosk gently.
Please add [Solved] to your thread title if the solution was found.

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#7 by feist » 23 Sep 2015, 17:28

It didn't seem like there would be a connection either, but I am going to create another modified iso and test again. All I did was add the line in rc.local, make rc.local executable with chmod 755, squashed the folder, and then burned the CD.

I'll have to download the Ubuntu at home and maybe try again tomorrow. Internet at work is horrible.

As per the power button request, yes the computer can still be shutdown by holding the power button. The extra five seconds really do help in preventing incidental shutdowns, like when kids come by and play with the power button. The kids usually give up after pressing the button a few times. Although the kiosk computer cannot be hidden from the public, very rarely do we have a problem with a member of the public intentionally holding the power button to turn off the system. Scheduled tasks take care of gentle shutdowns for us at the end of the day.

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#8 by feist » 23 Sep 2015, 22:48

Ubuntu Test Completed

Hello, the ISO took half the day to download, but I managed to get it done today. I downloaded Lubuntu, installed ethtool via apt-get, and then ran the ethtool to set the adapter to wol g.

Once I shutdown the computer, I went to the main server and issued a WOL command to the PC and the computer woke up!

Once the kiosk booted into Porteus, I shutdown the computer by pressing the power button (unmodified ISO, system goes down) and then issued another WOL command. Sadly, the computer did not wake this time.
Last edited by feist on 23 Sep 2015, 23:17, edited 1 time in total.

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#9 by feist » 23 Sep 2015, 23:13

Additional Tests

WOL Works When Shutdown Command is Issued from SSH
1. SSH into kiosk
2. Issue shutdown command
3. Issue WOL command from server
4. Kiosk wakes up!

If the kiosk is powered down by pressing the power button, the computer does not wake up. Something else to think about is why does the computer not wake up either when using scheduled tasks? Doesn't the scheduled task just issue the same shutdown command? Is something causing the WOL G flag to reset during any of these processes? Again, the kiosk using the Realtek NIC is configured the exact same way and works perfectly.

Just putting down notes, if it helps you any.

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#10 by feist » 24 Sep 2015, 00:14

Since shutdown command in SSH keeps the WOL G flag alive in the NIC, and shutdown via the power button or scheduled tasks in Porteus Kiosk does not keep the WOL G flag alive, it made me want to see how Porteus Kiosk was issuing it's shutdown command. In the sbin folder, I found the shutdown script and it is shutting down the system via init 0.

Perhaps init 0 is too good at killing processes and is also resetting the WOL G flag?

feist
White ninja
White ninja
Posts: 23
Joined: 27 Dec 2013, 02:02
Distribution: Porteus Kiosk 3.1
Location: USA

Re: Wake On Lan Not Working With Certain NICs

Post#11 by feist » 24 Sep 2015, 01:32

SOLVED?

I couldn't figure out when the shutdown script was invoked, so I opted to modify the shutdown combination script instead. I overwrote "init 0" with "shutdown" and reconfigured the kiosk with the customized iso. This was the only setting changed.

I enabled the shutdown combination in the global config file.

Once kiosk booted up and reconfigured automatically, I pressed CTRL-ALT-DEL and chose the SHUTDOWN option. The system goes down.

I issued the WOL command from the server and voila! It works!!!

Perhaps the "shutdown" command should be used instead of "init 0" to shutdown the computers gracefully. Shutdown seems to keep the WOL G flag alive in the NICs while init 0 can cause some NICs to lose the flag. Whatever instances of "init 0" in the various shutdown scripts (shutdown combination, scheduled tasks, and power button response) would have to be replaced with "shutdown" to make WOL to work for certain NICs.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4621
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Wake On Lan Not Working With Certain NICs

Post#12 by fanthom » 24 Sep 2015, 06:50

Hello feist,

Thanks for your investigation. Anyway - i dont think the 'shutdown' command is the key to resolve this issue. I have created '/sbin/shutdown' script as a wrapper for 'init 0' command. Please login through ssh and check:

Code: Select all

cat /sbin/shutdown
#!/bin/sh

# Shutdown PC gracefully:
init 0
Please do more tests to find the root cause.
Please also check if holding the power button for 5 secs (when /etc/acpi/default.sh is removed) lets the 'g' flag persist.

Thank you.
Please add [Solved] to your thread title if the solution was found.

Post Reply