[Solved] No Gateway after boot up on 3.4.0 PXE ?

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
AiR-0nE
White ninja
White ninja
Posts: 13
Joined: 05 Mar 2014, 10:08
Distribution: zorin-os
Location: France

[Solved] No Gateway after boot up on 3.4.0 PXE ?

Post#1 by AiR-0nE » 01 Sep 2015, 09:25

Hello,

First thx again for this wonderful Distro !

I try to upgrade to 3.4.0, everything is loading well but no connexion at all After boot. I try to get more info with debug option and see that on Kernel IP routing table : gateway is Missing.

3.1.1 is still working perfectly and i change nothing on PXE server dsnmasq.conf .

Any idea ?
Last edited by AiR-0nE on 01 Sep 2015, 11:52, edited 2 times in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: No Gateway after boot up on 3.4.0 PXE ? (Work with 3.1)

Post#2 by fanthom » 01 Sep 2015, 10:27

Hello AiR-0nE,

Seems that latest dhcpcd version 6.9.0 used in 3.4.0 release is causing this. I have downgraded to version 6.2.0 from kiosk 3.1.x and it works out of the box.

Investigating ...
Please add [Solved] to your thread title if the solution was found.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: No Gateway after boot up on 3.4.0 PXE ? (Work with 3.1)

Post#3 by fanthom » 01 Sep 2015, 11:02

Bumped to dhcpcd-6.9.2 and issue is resolved.

Please download Porteus Kisosk 3.4.0 ISO once again or wait about a week for 3.5.0 which is a nice upgrade :)
Please add [Solved] to your thread title if the solution was found.

AiR-0nE
White ninja
White ninja
Posts: 13
Joined: 05 Mar 2014, 10:08
Distribution: zorin-os
Location: France

Re: No Gateway after boot up on 3.4.0 PXE ? (Work with 3.1)

Post#4 by AiR-0nE » 01 Sep 2015, 11:50

Dear fanthom,

Huge thank you for your responsiveness. I was going crazy ... But you save my day !

I check Porteus news for 3.5.0 and it's look impressive !

AiR-0nE
White ninja
White ninja
Posts: 13
Joined: 05 Mar 2014, 10:08
Distribution: zorin-os
Location: France

Re: [Solved] No Gateway after boot up on 3.4.0 PXE ?

Post#5 by AiR-0nE » 04 Sep 2015, 15:49

Hi fanthom,

Did the 3.5.0 get the dhcpcd-6.9.2 update too ? Because i'am facing same problem on new release ...

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [Solved] No Gateway after boot up on 3.4.0 PXE ?

Post#6 by fanthom » 04 Sep 2015, 20:11

Seems that i never updated 3.5.0 ISO with dhcpcd-6.9.2.
Done now - please download again.

Sorry for the troubles.
Please add [Solved] to your thread title if the solution was found.

Post Reply