Can you help me to make a PAN module? (newsreader)

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
Post Reply
att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

Can you help me to make a PAN module? (newsreader)

Post#1 by att » 16 May 2011, 14:15

Hello,

For SLAX 6.1.2, I have made the module called "attbins", which also contains PAN, a very good newsreader.
( http://pan.rebelbase.com/ )
Unfortunately, PAN does not work out-of-the-box with Porteus. It needs some fixes.

When you convert the attbins-PAN-containing-module to Porteus XZM module and you start pan, it looks like that:

http://666kb.com/i/btjbsx8zu11eao61t.gif

This means: It does not display characters at all, just squares.
I am trying to figure out what to do, but I cannot seem to fix it.
I have tried to copy fontpaths and font-dirs from Slax 6.1.2 to Porteus, but I had no luck.
Please help, any advice is greatly appreciated.

Posted after 8 minutes 55 seconds:
By the way, when starting up PAN, from the converted Slax module, I get the following errors:

bash-4.1# pan

(process:19151): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

(pan:19151): Pango-CRITICAL **: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
'/etc/pango/pango.modules'
You should create this file by running:
pango-querymodules > '/etc/pango/pango.modules'

(pan:19151): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'

(pan:19151): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'

(pan:19151): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(pan:19151): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

User avatar
fanthom
Site Admin
Site Admin
Posts: 4613
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Can you help me to make a PAN module? (newsreader)

Post#2 by fanthom » 16 May 2011, 16:15

@att
please stop using 32bit modules (pango errors are related to different paths). you will save a lot of troubles to us and yourself.
building 64bit 'pan' is very easy with slackyd, do as follows:

(i forgot to change repositories to 64 bit so first command is critical - sorry for that)
sed -i /etc/slackyd/slackyd.conf -e 's/slackware-13.37/slackware64-13.37/g'
slackyd -u
slackyd -g pan
slackyd -g gtkspell
slackyd -g gmime
slackyd -g enchant

now convert all txz packages placed in /var/slackyd to xzm with dolphin (porteus module tools didnt work for me, gonna fix it). and activate, effect:
http://imageshack.us/m/859/3416/snapshot1zh.png

Cheers
Please add [Solved] to your thread title if the solution was found.

Post Reply