Volume too low.

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
steve s
Ronin
Ronin
Posts: 2
Joined: 08 Aug 2015, 12:59
Distribution: Porteus KDE
Location: Missouri

Volume too low.

Post#1 by steve s » 08 Aug 2015, 13:06

I've got Windows on my laptop but have been using Porteus KDE lately because videos play back smoother. The problem is that the volume is too low when using Porteus. The master is at 100%, but it's not even half as loud as when I run Windows. Other distros of Linux sound just fine.
I went into the config file and raised the value from 100% to 200%, but that didn't work. Any suggestions?

Steve S

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Volume too low.

Post#2 by Bogomips » 08 Aug 2015, 13:25

Try in a terminal alsamixer:

Code: Select all

alsamixer
which is what I'm using to try and get a reasonable volume.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

steve s
Ronin
Ronin
Posts: 2
Joined: 08 Aug 2015, 12:59
Distribution: Porteus KDE
Location: Missouri

Re: Volume too low.

Post#3 by steve s » 09 Aug 2015, 05:11

Thanks, that did it. Even though the master was at 100, the one labeled Speaker was only about 60%.

Steve S

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Volume too low.

Post#4 by Bogomips » 09 Aug 2015, 14:14

To round things off, preferred settings can be saved. In terminal under root:

Code: Select all

alsactl	store	# All that's needed if saving Changes
If not saving Changes, then rootcopy will do the trick. Immediately after saving sound settiings, the file /var/lib/alsa/asound.state has to be copied to the rootcopy folder. Again as root:

Code: Select all

alsactl store
cp --parents /var/lib/alsa/asound.state  /mnt/sdxy/porteus/rootcopy
sdxy - Partition where Porteus has been installed. For example: /mnt/sdb1

Am able myself to get reasonable sound without getting into the red. However always a good idea upon starting up Porteus to check sound settings, as somewhere along the line some startup program/s clobberi them. KDE System Settings is another of these programs, which puts pcm into the red. Not very desirable if watching a late night video which starts off with an ear-splitting musical introduction.

If settings clobbered, then

Code: Select all

alsactl restore
Feedback was appreciated. Please append Solved to topic title, if everything has been covered.
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3161
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Volume too low.

Post#5 by Ed_P » 10 Aug 2015, 02:43

Bogomips wrote:Feedback was appreciated.
What do you suggest for this situation?

Code: Select all

guest@porteus:~$ alsactl store
alsactl: state_lock:121: file /var/lib/alsa/asound.state lock error: File exists
alsactl: state_lock:121: file /var/lib/alsa/asound.state unlock error: File exists
guest@porteus:~$ 
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Volume too low.

Post#6 by Bogomips » 10 Aug 2015, 12:05

@Ed_P

For starters

Code: Select all

alsactl -L store
See man alsactl. Otherwise copy configuration file somewhere else, and use this other one as configuration file perhaps?
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3161
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Volume too low.

Post#7 by Ed_P » 10 Aug 2015, 12:33

:no:

Code: Select all

guest@porteus:~$ alsactl -L store
alsactl: invalid option -- 'L'
Usage: alsactl <options> command

global options:
  -h,--help        this help
  -d,--debug       debug mode
  -v,--version     print version of this program

Available state options:
  -f,--file #      configuration file (default /var/lib/alsa/asound.state)
  -l,--lock        use file locking to serialize concurrent access
  -F,--force       try to restore the matching controls as much as possible
                     (default mode)
  -g,--ignore      ignore 'No soundcards found' error
  -P,--pedantic    do not restore mismatching controls (old default)
  -I,--no-init-fallback  
                   don't initialize even if restore fails
  -r,--runstate #  save restore and init state to this file (only errors)
                     default settings is 'no file set'
  -R,--remove      remove runstate file at first, otherwise append errors
  -p,--period #    store period in seconds for the daemon command
  -e,--pid-file #  pathname for the process id (daemon mode)

Available init options:
  -E,--env #=#     set environment variable for init phase (NAME=VALUE)
  -i,--initfile #  main configuation file for init phase
                     (default /usr/share/alsa/init/00main)
  -b,--background  run daemon in background
  -s,--syslog      use syslog for messages
  -n,--nice #      set the process priority (see 'man nice')
  -c,--sched-idle  set the process scheduling policy to idle (SCHED_IDLE)

Available commands:
  store     <card>  save current driver setup for one or each soundcards
                      to configuration file
  restore   <card>  load current driver setup for one or each soundcards
                      from configuration file
  nrestore  <card>  like restore, but notify the daemon to rescan soundcards
  init      <card>  initialize driver to a default state
  daemon    <card>  store state periodically for one or each soundcards
  rdaemon   <card>  like daemon but do the state restore at first
  kill      <cmd>   notify daemon to quit, rescan or save_and_quit
guest@porteus:~$ alsactl -v
alsactl version 1.0.27.2
guest@porteus:~$ 

Same with lower case -l also.

Code: Select all

guest@porteus:~$ alsactl -l store
alsactl: state_lock:121: file /var/lib/alsa/asound.state lock error: File exists
alsactl: state_lock:121: file /var/lib/alsa/asound.state unlock error: File exists
Ed

Bogomips
Full of knowledge
Full of knowledge
Posts: 2541
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: Volume too low.

Post#8 by Bogomips » 10 Aug 2015, 12:49

Try running under root, as you do not have write access to /var/lib/alsa/asound.state. 8)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

User avatar
Ed_P
Contributor
Contributor
Posts: 3161
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: Volume too low.

Post#9 by Ed_P » 10 Aug 2015, 15:44

Bogomips wrote:Try running under root,
Bingo!! :good:

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# alsactl store
root@porteus:/home/guest# 
Thanks Bogomips. :beer:
Ed

Post Reply