USB pendrive not mounting automatically

Non release banter
Post Reply
rnport
Black ninja
Black ninja
Posts: 98
Joined: 01 May 2011, 00:55

USB pendrive not mounting automatically

Post#1 by rnport » 13 May 2011, 17:21

The usb pendrives (fat32 formatted) are not mounting automatically on porteus v09 32bit. I have to manually mount them by command 'mount /dev/sdb1 /mnt/sdb1'
The message that I get is:
Rejected send message, 1 matched rules; type="method_call", sender=":1.4" (uid=0 pid=4326 comm="kded [kdeinit] --new-startup) interface="org.freedesktop.Hal.Device.Volume" member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=3674 comm="/usr/sbin/hald)

Can someone please help me to overcome this problem?

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: USB pendrive not mounting automatically

Post#2 by Ahau » 13 May 2011, 17:40

Try booting with the delay= cheatcode. I had this issue in V09 as well, and delay=2 allowed the system enough time to settle in and mount my flash drive. You might want to start higher (delay=9) and work down from there.

If that resolves your problem, then this issue has been resolved in V1, and you won't need the delay= cheatcode to get them automounted at startup.

Hopefully that helps...let us know if it doesn't. Also, if possible, try the 32-bit version 1.0 RC1, as it's the most up to date version of everything.
Please take a look at our online documentation, here. Suggestions are welcome!

rnport
Black ninja
Black ninja
Posts: 98
Joined: 01 May 2011, 00:55

Re: USB pendrive not mounting automatically

Post#3 by rnport » 14 May 2011, 01:24

I tried delay=5 ; it delays initial booting process by live-linux rather than usb mounting. On 'dmesg' command after putting in usb pendrive, I noted that there is no statement 'waiting for device to settle down' which probably should be there.
I will try porteus version 1.0 RC1 iso.

User avatar
82issa
DOC Team
DOC Team
Posts: 127
Joined: 13 Apr 2011, 17:24
Location: USA, NC

Re: USB pendrive not mounting automatically

Post#4 by 82issa » 14 May 2011, 06:17

If it is still giving you the same issue. I have run into a problem booting from specific usb locations. I have 3 seperate usb ports 2 of them I don't need any cheatcode for. The other works just fine after system is fully initialized, but always gives me issues booting.
Sorry guys... I got to go. My girlfriend just casted "get your dirty ass into the shower" on me.
Oh and here is some naked grandpa pictures too.

Post Reply