[Solved] 3.4.0 - proxy credentials not saved?

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
cinmar
White ninja
White ninja
Posts: 9
Joined: 25 Nov 2014, 14:54
Distribution: Porteus
Location: Italy

[Solved] 3.4.0 - proxy credentials not saved?

Post#1 by cinmar » 09 Jul 2015, 14:12

Hi,
we encountered an issue with new version 3.4.0. Our network is behind a proxy, so in porteus kiosk wizard we have always selected DHCP -> Proxy in user:password@proxyIP:port format .
In previous versions we were able to go with Firefox to a web page, where we saved configurations in a text file. With version 3.4.0, we can not reach any external website, Firefox gives connection error. So i tried to visit an internal website, and I was able to reach it: this is because our proxy is configured to allow connections to internal websites, and ask for authentication for external ones. Proxy configuration set in welcome wizards are correct, because at the beginning it gives "Connection successful" message and downloads Firefox correctly: it looks like that proxy credentials are not saved in Firefox.
Moreover, if we manually configure the wizard and install Porteus kiosk on the hard disk, Firefox opens a popup after reboot and asks for proxy credentials. With previous versions we did not have similar issues.

Do you have any clue?
Last edited by cinmar on 30 Jul 2015, 15:26, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 3.4.0 - proxy credentials not saved?

Post#2 by fanthom » 09 Jul 2015, 16:58

will check this over the weekend.
thank you for reporting.
Please add [Solved] to your thread title if the solution was found.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 3.4.0 - proxy credentials not saved?

Post#3 by fanthom » 13 Jul 2015, 12:15

should be fixed now - please download 3.4.0 ISO once again and give it a shot.

thank you.
Please add [Solved] to your thread title if the solution was found.

cinmar
White ninja
White ninja
Posts: 9
Joined: 25 Nov 2014, 14:54
Distribution: Porteus
Location: Italy

Re: 3.4.0 - proxy credentials not saved?

Post#4 by cinmar » 14 Jul 2015, 09:57

Thanks fanthom for the quick fix. I will be able to test the new .iso only next week, as soon as I have news I will post them here.

cinmar
White ninja
White ninja
Posts: 9
Joined: 25 Nov 2014, 14:54
Distribution: Porteus
Location: Italy

Re: 3.4.0 - proxy credentials not saved?

Post#5 by cinmar » 30 Jul 2015, 15:26

Problem solved! Thanks :good:

Post Reply