It takes for ever to start initiationon script.(solved)

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

It takes for ever to start initiationon script.(solved)

Post#1 by Kozmopol » 21 Jun 2015, 00:30

Hello.

It literally takes like 10 minutes for Porteus to fully boot up. It takes alot of time to start the initiation script. Im using an SD card, my HDD is broken. It's really annoying that the system takes so long to start, i have resulted to not shutting my laptop down, so at the moment it has been running for a week, and i dont bother carrying it with me anymore.

I hope anyone can help me, thank you.
Last edited by Kozmopol on 22 Jun 2015, 13:26, edited 1 time in total.

Seva
Samurai
Samurai
Posts: 134
Joined: 30 Apr 2015, 12:00
Distribution: XFCE Porteus Desktop 3.1 64bit
Location: Moscow, Russia

Re: It takes for ever to start initiationon script at boot.

Post#2 by Seva » 21 Jun 2015, 01:11

maybe too many modules to boot up, or unusual boot parameters
posted from Porteus

Seva
Samurai
Samurai
Posts: 134
Joined: 30 Apr 2015, 12:00
Distribution: XFCE Porteus Desktop 3.1 64bit
Location: Moscow, Russia

Re: It takes for ever to start initiationon script at boot.

Post#3 by Seva » 21 Jun 2015, 01:13

or something to do with saved changes,
there is 'always fresh' mode and 'copy to ram' mode
posted from Porteus

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: It takes for ever to start initiationon script at boot.

Post#4 by francois » 21 Jun 2015, 06:40

This is really abnormal behavior.
Seva has proposed interesting suggestions:
1.0 try to boot always fresh mode and text more Please report the result.
2.0 using xfce or lxqt should give a better performance. What is the Linux box you are using? What are the specs?
Voltaire: Le mieux est l'ennemi du bien.

Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

Re: It takes for ever to start initiationon script at boot.

Post#5 by Kozmopol » 21 Jun 2015, 09:24

Hello, reporting in. Because i made my usb in windows, i have a save.dat and run from always fresh mode. I tried copy to ram mode and the problem still exists.


Im running lxce with estonian keyboard and timezone and somee added apps like chrome etc. The whole size of my Porteus
Is 270mb. My computer has 4gb of ram, i5-4200u and a disfunctioning hdd. My sd card is a 8gb sandisk. Have ran tails from it beforehand.

Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

Re: It takes for ever to start initiationon script at boot.

Post#6 by Kozmopol » 21 Jun 2015, 09:27

Also the problem existed before i made a save.dat .

Seva
Samurai
Samurai
Posts: 134
Joined: 30 Apr 2015, 12:00
Distribution: XFCE Porteus Desktop 3.1 64bit
Location: Moscow, Russia

Re: It takes for ever to start initiationon script at boot.

Post#7 by Seva » 21 Jun 2015, 09:30

maybe making a new porteus bootable sd card formatted to ext4 will help
posted from Porteus

Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

Re: It takes for ever to start initiationon script at boot.

Post#8 by Kozmopol » 21 Jun 2015, 10:04

Sorry about my typo earlier, i meant to say i was running KDE4. Okay, i will try formatting my usb as i run porteus from ram.

Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

Re: It takes for ever to start initiationon script at boot.

Post#9 by Kozmopol » 21 Jun 2015, 15:41

Formatted te usb to ext4 , the problem still exists :/

donald
Full of knowledge
Full of knowledge
Posts: 1121
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: It takes for ever to start initiationon script at boot.

Post#10 by donald » 21 Jun 2015, 15:56

Would be interesting to know if it's the same when you boot from a different
kind of media.(e.g. usb-flash or a live-CD.)
may be that your sd-card/reader is not that fast.(usb 1.1 ?)

Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

Re: It takes for ever to start initiationon script at boot.

Post#11 by Kozmopol » 21 Jun 2015, 16:54

Atm i dont have acess to a second usb, but i have a feeling that porteus takes long time to find itself, because when i tried slax it ran through 7 sda devices for 15 minutes searching for itself.. Then finally finding itself on sdb1 and booting up.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: It takes for ever to start initiationon script at boot.

Post#12 by fanthom » 21 Jun 2015, 17:02

your broken hd takes forever to power up and initialize slowing down the booting. disable it in the BIOS (or remove physically) and porteus will be flying.
Please add [Solved] to your thread title if the solution was found.

Kozmopol
White ninja
White ninja
Posts: 9
Joined: 21 Jun 2015, 00:21
Distribution: Porteus
Location: Euro

Re: It takes for ever to start initiationon script at boot.

Post#13 by Kozmopol » 22 Jun 2015, 13:24

Thanks! Worked.

Post Reply