Porteus-v1.0-rc1-x86 ready for testing

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
Post Reply
User avatar
brokenman
Site Admin
Site Admin
Posts: 5461
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Porteus-v1.0-rc1-x86 ready for testing

Post#1 by brokenman » 09 May 2011, 14:31

The penultimate 32bit rc1 release before our official release is now ready for testing.
Please test thoroughly so we can sort out the last remaining bugs before v1. Suggestions are welcome and if you feel like taking a crack at some of the still existing bugs you will be endowed with magical powers and receive your weight in gold coin.

Kernel headers exist separately on server for now. Will include in final release.
If someone could create the nvidia driver and let me know i will put it on the server.

Repo:
http://ponce.cc/porteus/i486/testing/

Changelog:
- kernel 2.6.38.5
- userland bumped to Slackware-13.37
- KDE-3.5.12 (Trinity)
- LXDE from GIT by ponce compiled on Slack 13.37
- Kernel support for older i486 processors

Known (still existing) bugs
- Shutdown from kdm screen requires you to press enter
- wicd tray icon not loading in lxde (shouldn't be difficult to fix)
- Login as guest and su from terminal, then start mc is garbled.

Other - smaller changes:
- updated syslinux to version 4.0.4 (pxelinux.0 must be placed in /boot folder and not /boot/pxelinux.cfg)
- Cleaned up boot and porteus folders with subfolders docs & tools which contains Fixmbr.exe, UAC.exe, memtest and /dos loader.
- added function to win_start_here.hta which disables UAC (Blaze's job)
- updated linuxrc and some other stuff inside initrd (fanthom)
- fixed dhcpcd long delay for IP in rc.inet1 (thanks to crashman for bug report)
- rc.M now creates 10 loops at boot instead of one (Rava request), also moves passwd.xzm automatically to /porteus/modules when is writable (francoise suggestion)
- /usr/local/bin/man searches netowork when man page is not found in Porteus (82issa and lo-n-behold job)
- changes-time.sh strips module from *.cache files which are causing aufs hang
- activate script add one free module after insertion (it doesn't do anything when free loops are available)
- nouveau is blacklisted by default again as people are having troubles with compilation of nvidia binary driver
- USB HID is compiled into kernel (thanks to bong for bug report)
- udisk mounts FAT and NFTS without 'showexec' flag (all files are executable: needed for porteus installation scripts)
- hibernation works ok after upgrading to 2.6.38.5 (requires further testing)
- added 'Porteus' string to firefox user agent
- Added save-changes script (from console)
- Added GUI for changing save.dat size, creating new one or attempted corruption recovery
- many, many, many other changes.....

To come for rc2 or final:
1. Bundle package manager
Not a full package manager but enough to get users to put together their preferred applications from within Porteus. If anyone would like to assist me with this it would be welcome.

2. Porteus repo with 100% working modules. I would ask xzm team to begin preparing modules that adhere to the Porteus standard. Same as slackware but has /var/log/packages file mention CATEGORY:. See the existing repo on server for categories. Please have dependencies as separate modules which will be used in library category.

Please enjoy and report all bugs as usual.

Regards,
The Porteus Team
Last edited by brokenman on 09 May 2011, 18:28, edited 1 time in total.
Reason: sticky
How do i become super user?
Wear your underpants on the outside and put on a cape.

crashman
Contributor
Contributor
Posts: 118
Joined: 28 Dec 2010, 17:03
Location: Poland

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#2 by crashman » 09 May 2011, 20:24

@Brokenman
Thank you for a hard work, xorg-xserver-1.9.5 work now in my machine :beer: with 'nomodeset' cheatcode - no more frustration :good:

Chears
Last edited by crashman on 09 May 2011, 20:36, edited 1 time in total.

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#3 by Hamza » 09 May 2011, 20:26

The shortlog of this pre-final is posted on the facebook account.
NjVFQzY2Rg==

toby
White ninja
White ninja
Posts: 7
Joined: 09 May 2011, 02:29
Location: Kuala Lumpur

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#4 by toby » 10 May 2011, 03:12

Hi,

Short report of using Porteus-v1.0-rc1-x86 on my notebook Ausus K43U:

No window start up music and a massage pop up:

"Sound server informational message:
Error while initializing the sound driver
device:default can't be opened for playback (No such file or directory)
The soundserver will continue, using the null output device."

Further observation.
1. All my rmvb files could play with kplayer without error (sound is audible).
2. mp3 is functional on kplayer but not with Beeb media player. Here is a message pop up from Beep Media player:

"Couldn't open audio
Please check that:
1.You have the correct output plugin selected.
2.No other programs is blocking the sound card.
3.Your sound card is configured properly."

3. No sound output when playing youtube on the web browser.

4. Screen resolution is perfect 1366x768
5. Atheros wifi card is working flawlessly
6. PCman file manager - the icons are not visible in the "icon view" mode (no sure whether it is a problem)

additional information for your reference:
under kmix, the Currenct mixer showing 2 devices:
1.ATI R6xx HDMI
2.Realtek ALC269VB
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

Code: Select all

----------------------
Output from psinfo
----------------------
script by jayflood
.
.

====== USER INFO =====
User is: root
.
===== MACHINE INFO =====
Platform: i686
Kernel: 2.6.38.5-porteus
Processor: AMD E-350 Processor
MemTotal:        2719964 kB
MemFree:         1875868 kB
Bootparam: root=/dev/ram0 ramdisk_size=6666 rw initrd=/boot/initrd.xz vga=791 splash=silent quiet autoexec=xconf;telinit~4 changes=/porteus/ BOOT_IMAGE=/boot/vmlinuz 
.
===== SOUND INFO =====
Sound card:  0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 41
 1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfeb40000 irq 16
Sound driver: Advanced Linux Sound Architecture Driver Version 1.0.23.
.
===== PARTITION INFO =====
Porteus is on: /mnt/sr0
.
Partitions: 
sda
sda1
sda2
.
Mounted: 
/dev/sr0       iso9660  258M  258M     0 100% /mnt/sr0
/dev/sda1      fuseblk   56G   28G   29G  50% /mnt/sda1
/dev/sda2      fuseblk  243G  4.3G  239G   2% /mnt/sda2
.
===== OPTICAl DRIVE =====
sr0
.
===== USB INFO =====
Removables: USB2.0-CRW
Removable status: sd0:0:0:0:[sda]Protect
.
lsusb: 
.
===== SCREEN INFO =====
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
.
===== MODULES LOADED =====
000-kernel.xzm
001-core.xzm
002-xorg.xzm
003-lxde.xzm
004-kde.xzm
005-kdeapps.xzm
006-koffice.xzm
007-devel.xzm
008-firefox.xzm
.
===== NETWORK INFO =====
eth0      Link encap:Ethernet  HWaddr F4:6D:04:A3:F1:AE  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:40 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1156 (1.1 Kb)  TX bytes:1156 (1.1 Kb)

wlan0     Link encap:Ethernet  HWaddr E0:B9:A5:46:F0:DE  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::e2b9:a5ff:fe46:f0de/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13891 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11414 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:18850017 (17.9 Mb)  TX bytes:1145073 (1.0 Mb)

wlan1     Link encap:Ethernet  HWaddr 00:C0:CA:4F:91:0B  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
.
# Generated by dhcpcd from wlan0
# /etc/resolv.conf.head can replace this line
nameserver 192.168.1.1
# /etc/resolv.conf.tail can replace this line
.
===== PCI INFO =====
lspci: 
.
.
===== LOGS INFO =====
dmesg | tail 
.
[ 5343.239170] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 5349.435990] wlan0: authenticate with 00:1e:58:ba:a0:fe (try 1)
[ 5349.438652] wlan0: authenticated
[ 5349.438710] wlan0: associate with 00:1e:58:ba:a0:fe (try 1)
[ 5349.441828] wlan0: RX AssocResp from 00:1e:58:ba:a0:fe (capab=0x471 status=0 aid=3)
[ 5349.441842] wlan0: associated
[ 5349.442373] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 5349.691043] Intel AES-NI instructions are not detected.
[ 5349.715690] padlock_aes: VIA PadLock not detected.
[ 5359.906198] wlan0: no IPv6 routers present
.
.
cat /var/log/messages | tail
.
May 10 23:45:02 (none) kernel: [ 5349.442373] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
May 10 23:45:03 (none) kernel: [ 5349.691043] Intel AES-NI instructions are not detected.
May 10 23:45:03 (none) kernel: [ 5349.715690] padlock_aes: VIA PadLock not detected.
May 10 23:45:03 (none) dhcpcd[5415]: version 5.2.11 starting
May 10 23:45:03 (none) dhcpcd[5415]: wlan0: broadcasting for a lease
May 10 23:45:05 (none) dhcpcd[5415]: wlan0: offered 192.168.1.4 from 192.168.1.1
May 10 23:45:05 (none) dhcpcd[5415]: wlan0: acknowledged 192.168.1.4 from 192.168.1.1
May 10 23:45:05 (none) dhcpcd[5415]: wlan0: checking for 192.168.1.4
May 10 23:45:11 (none) dhcpcd[5415]: wlan0: leased 192.168.1.4 for 3600 seconds
May 10 23:45:11 (none) dhcpcd[5415]: forked to background, child pid 5442
..

////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
Regards

toby
Last edited by toby on 10 May 2011, 16:19, edited 3 times in total.

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#5 by Hamza » 10 May 2011, 05:02

@toby,

Thanks for output , but you don't repect this rule.
4. Include logs and tell us commands executed. Most wanted are: /var/log/dmesg and /var/log/messages. Use pastebin.com for long and multiple files. Jayflood's 'Porteus System Info' tool can be also very helpful - you can launch it from Kmenu/Lxde menu and receive a lot of useful info about your system straight on the desktop.
Remember: nobody can help you if they don't know what's wrong, or what you did to get the error you received. Providing this information will greatly aid others in assisting you, and will allow us to diagnose your problem easier and sooner.
If someone want to see what is the topic ,and if he has a low bandsiwtch speed , the loading of this page will be very slow.
Do you understand?

Regards,
NjVFQzY2Rg==

toby
White ninja
White ninja
Posts: 7
Joined: 09 May 2011, 02:29
Location: Kuala Lumpur

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#6 by toby » 10 May 2011, 05:14

Hi,

I have something to share here. For those who want to surf the website with Chinese characters, a good quality font is required.
So far, I found fireflysung.ttf is good, it gives thin and sharp without shadow for comfortable view.
Here is the download link:

Code: Select all

http://www.multiupload.com/JUOF0DN4QA
simply download and put it directly into the folder /usr/share/fonts/TTF.

I login as root for easy drag and drop the file, you don't need to restart your pc, just close your browser, and open it again, it will take effect immediately.

the file size is 14.7Mb, not sure it is too large to be included in the package for the coming new release. kindly consider it.

By the way, may I know how to make the Chinese characters to be readable in the file manager as some of my file is named in Chinese characters
as well.

Thanks in advance

regards

toby.

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#7 by Hamza » 10 May 2011, 05:18

Thanks a lot for the fonts!
NjVFQzY2Rg==

toby
White ninja
White ninja
Posts: 7
Joined: 09 May 2011, 02:29
Location: Kuala Lumpur

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#8 by toby » 10 May 2011, 05:32

Hamza wrote:@toby,

Thanks for output , but you don't repect this rule.
4. Include logs and tell us commands executed. Most wanted are: /var/log/dmesg and /var/log/messages. Use pastebin.com for long and multiple files. Jayflood's 'Porteus System Info' tool can be also very helpful - you can launch it from Kmenu/Lxde menu and receive a lot of useful info about your system straight on the desktop.
Remember: nobody can help you if they don't know what's wrong, or what you did to get the error you received. Providing this information will greatly aid others in assisting you, and will allow us to diagnose your problem easier and sooner.
If someone want to see what is the topic ,and if he has a low bandsiwtch speed , the loading of this page will be very slow.
Do you understand?

Regards,
@Hamza
Thanks Hamza, you teach me something new today, I will post the dmesg in a short while.

Regards

potato toby

Falcony
Full of knowledge
Full of knowledge
Posts: 233
Joined: 01 Jan 2011, 12:44
Location: Russia

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#9 by Falcony » 10 May 2011, 06:14

Goot job - mostly I impressed by your Trinity desktop!

Some changes for pxe boot

Here is the patch for boot/pxelinux.cfg/start

Code: Select all

--- start.orig	2011-05-09 16:23:52.000000000 +0400
+++ start	2011-05-07 23:10:34.000000000 +0400
@@ -5,23 +5,42 @@
 
 cd $(dirname $(readlink -f $0))
 # find out our own IP address. If more interfaces are available, use the first one
-IP=$(ifconfig "$(ls -1 /sys/class/net | grep eth | head -n 1)" | grep "inet addr" | cut -d : -f 2 | cut -d " " -f 1)
+IP=$(ifconfig "$(ls -1 /sys/class/net | grep eth | head -n 1 | sed "s|@||g" )" | grep "inet addr" | cut -d : -f 2 | cut -d " " -f 1)
 
 # if no IP is assigned to this computer, setup private address randomly
 if [ "$IP" = "" ]; then
    killall dhcpcd 2>/dev/null
    IP="10."$(($RANDOM/130+1))"."$(($RANDOM/130+1))".1"
-   ifconfig $(ls -1 /sys/class/net | head -n 1) $IP netmask 255.0.0.0
+   ifconfig $(ls -1 /sys/class/net | head -n 1 | sed "s|@||g" ) $IP netmask 255.0.0.0
 fi
 
 # calculate C class range
 RANGE=$(echo $IP | cut -d "." -f 1-3)
 
+
+if [ -e /mnt/live/memory/copy2ram ]; then
+
+ROOT=`cd ../../ ; pwd | sed "s|/mnt/||"`
+
+else
+
+ROOT=$(ls -A1 /mnt/live/mnt | head -n1 )
+
+if [ "$ROOT" = "" ]; then
+   echo "Can't find root directory with live data," >&2
+   echo "try to specify a directory with ./base in it" >&2
+   echo "with at least one .xzm module." >&2
+   exit 1
+fi
+
+fi
+
+
 # make sure dnsmasq can be started
 killall dnsmasq 2>/dev/null
 mkdir -p /var/state/dnsmasq
 
 # start the DHCP server and TFTP server
-./dnsmasq --enable-tftp --tftp-root=/boot \
---dhcp-boot=/pxelinux.0,"$IP",$IP \
---dhcp-range=$RANGE.2,$RANGE.250,infinite --log-dhcp
+./dnsmasq --enable-tftp --tftp-root=/mnt/$ROOT/boot \
+--dhcp-boot=pxelinux.0,"$IP",$IP \
+--dhcp-range=$RANGE.50,$RANGE.250,infinite --log-dhcp
Patch reflect following:

1. Now in Porteus there is no /boot catalog in file system. So $ROOT var is defined to provide path to Porteus boot media;

2. Adding possiability to use pxe boot in copy2ram mode;

3. Range DHCP and IP lease of last octet changed from *.2-250 to *.50-250. As muliply static IPs allow to have in *.1-49 RANGE for other home PCs.

This change is tested by me - works OK.

Also there is attitional patch of linurc script which fix one bug of pxe booting - which prevent loading all *.xzm modules from /mnt/httpfs/ mount share

I put in in other thead

viewtopic.php?f=53&t=41&p=3224#p3224

User avatar
Blaze
Moderator
Moderator
Posts: 1389
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus-v1.0-rc1-x86 ready for testing

Post#10 by Blaze » 10 May 2011, 08:32

I have bug report:

1)

Code: Select all

rm: cannot remove '/root/.kde/share/config/session/kwin_10736c6178000117871092200000072420000_1195208764_439069': No such file or directory
rm: cannot remove '/root/.kde/share/config/session/kmix_10736c6178000117871092500000072420008_1195208764_398674': No such file or directory
2) In VMware Workstation i don't have sound and I see a 'floppy drive'
Image

3) Image - need to tweak a scheme of porteus.cfg (It is badly read)

4) After reboot ejecting of CD does not work.

5) Xwindow does not start with my NVIDIA GeForce 8600 again.

Logs: Xorg.0.log | debug | dmesg | kdm.log | messages | syslog

Then i tried to run Xwindow:

Code: Select all

xconf
startx
Xwindow work for me very slow and my cursor is broken.

A new logs: Xorg.0.log | debug | dmesg | kdm.log | messages | syslog
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#11 by fanthom » 10 May 2011, 09:03

@Blaze
"4) After reboot ejecting of CD does not work."
this is probably my fault - will check linuxrc/rc.6 once again

"5) Xwindow does not start with my NVIDIA GeForce 8600 again."
@brokenman - please make sure that your cleanup script for 002-xorg removes modesetting driver, it should be in /usr/lib/xorg/drivers
Please add [Solved] to your thread title if the solution was found.

lo-n-behold
White ninja
White ninja
Posts: 10
Joined: 14 Jan 2011, 11:13
Location: belgium

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#12 by lo-n-behold » 10 May 2011, 11:31

I tried the new release, using the from_iso cheatcode so I don't have to unpack the iso...

the nouveau driver is not working, but I noticed it's blacklisted for now,
so I added the rootcopy cheatcode, and copied the BLACKLIST-nouveau.conf
to the appropriate place and commented out the nouveau line.

the nouveau kernel module seems to be loaded after booting,
but it looks like xconf doesn't generate the correct Xorg.conf file
to load it

do I need to do something else to make porteus use the nouveau driver?

Posted after 1 hour 27 minutes 11 seconds:

Code: Select all

[    18.245] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
...
[    18.245] (II) modesetting: Driver for Modesetting Kernel Drivers:
	NVIDIA Graphics Device
...
[    18.827] (II) Reloading /usr/lib/xorg/modules/extensions/libdri2.so
...
[    18.849] (II) modesetting(0)[DRI2]   DRI driver: i915
...
[    18.849] (II) modesetting(0)Using Gallium3D backend
[    18.849] (II) modesetting(0)2D Acceleration is disabled
it looks like the modesetting driver recognizes the nVidia NV46 card,
but then the DRI2 submodule thinks it's an intel i915 card ...

User avatar
Blaze
Moderator
Moderator
Posts: 1389
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#13 by Blaze » 10 May 2011, 11:50

The same story with my NVIDIA GeForce 8600

Code: Select all

[   220.941] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
...
[   220.941] (II) modesetting: Driver for Modesetting Kernel Drivers:
        NVIDIA Graphics Device
[   220.941] (++) using VT number 7
...
[   229.513] (II) Reloading /usr/lib/xorg/modules/extensions/libdri2.so
...
[   229.527] (II) modesetting(0)[DRI2] Setup complete
[   229.527] (II) modesetting(0)[DRI2]   DRI driver: i915
...
[   229.527] (II) modesetting(0)Using Gallium3D backend
[   229.527] (II) modesetting(0)2D Acceleration is disabled
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

lo-n-behold
White ninja
White ninja
Posts: 10
Joined: 14 Jan 2011, 11:13
Location: belgium

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#14 by lo-n-behold » 10 May 2011, 11:58

@brokenman - please make sure that your cleanup script for 002-xorg removes modesetting driver, it should be in /usr/lib/xorg/drivers
@fanthom : deleting the modesetting driver does indeed make the nouveau driver work

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus-v1.0-rc1-x86 ready for testing

Post#15 by fanthom » 10 May 2011, 14:16

@lo-n-behold
"@fanthom : deleting the modesetting driver does indeed make the nouveau driver work"
yep - that's whay i have asked brokenman for adding removal function to the cleanup sctipt.
@all
affected users can workaround this bug with an empty file in /rootcopy dir:
"touch /mnt/sdxY/porteus/rootcopy/usr/lib/xorg/modules/drivers/modesetting_drv.so"
Please add [Solved] to your thread title if the solution was found.

Post Reply