PXE Boot error

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: PXE Boot error

Post#16 by fanthom » 22 Apr 2015, 07:04

here you can read about PXE setup:
http://porteus-kiosk.org/pxe-server.html

regarding fail:
you may run 'modprobe e100' or 'modprobe r8169' and check if eth0 shows up once you run 'ifconfig' command. if yes then please run 'udhcpcd &' and check if you obtain IP address.

would be great if you could record a video showing the PXE boot process as some info are displayed on the screen.
Please add [Solved] to your thread title if the solution was found.

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#17 by chkchaitu » 27 Apr 2015, 10:36

Hi, I too am having similar problem while trying to boot from PXE.

please find the error message that I get

Image

I actually tried with multiple branded systems like acer, lenovo and hp, same error.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: PXE Boot error

Post#18 by fanthom » 27 Apr 2015, 13:51

@chkchaitu
'http_server=' cheatcode cant be empty.
please refer to documentation.
Please add [Solved] to your thread title if the solution was found.

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#19 by chkchaitu » 28 Apr 2015, 05:59

Thank you for the reply. I have followed the document and modified the default file as below. let me know if I need to modify anything or missed something

timeout 0 prompt 0 default pxe label pxe kernel vmlinuz append initrd=initrd.xz,pxelinux.cfg/initrdpxe.xz quiet http_server=192.168.1.11

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: PXE Boot error

Post#20 by fanthom » 28 Apr 2015, 08:21

@chkchaitu
you are still short of the port part. if your http server listens on port 80 then proper cheatcode syntax will be:

Code: Select all

http_server=192.168.1.11:80
anyway - i have updated the ISO to accept also an IP without port:

Code: Select all

http_server=192.168.1.11
so you have two options:
a) download 3.3.0 image once again
b) add port variable to your http_server= cheatcode (easier)

@Egor4eva
just realized that you are missing the http_server= cheatcode in your config. please add it and all will be good.
Please add [Solved] to your thread title if the solution was found.

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#21 by chkchaitu » 29 Apr 2015, 04:38

Hi Thank you so much.

I have added port 80 to http_server cheatcode but still same problem.

I have download the new iso from http://porteus-kiosk.org/download.html and used it as well. still same issue. http_server cheatcode is always blank no idea why.

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#22 by chkchaitu » 29 Apr 2015, 05:33

Ah Finally found what the issue is. I was editing the default file in Windows Notepad so while saving it was appending windows end of line character. Now I edited it in notepad++ and now I do not get that error anymore. Looks like it is to do with how windows and linux handles end of line characters.

Now I get http error. working on it will update with my findings.

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#23 by chkchaitu » 29 Apr 2015, 05:55

Getting these errors. Tried with IIS, Serva64 and HFS on windows as webservers

Image

Image

Image

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#24 by chkchaitu » 29 Apr 2015, 06:23

I think it is to do with mime settings in webserver.

finally I have added * as the file extension in IIS mime settings and voila Porteus-Kiosk booted like magic. :Yahoo!:

Now have to work on customizing Firefox, so that ctrl+i, ctrl+-, ctrl++, backspace etc would not work.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: PXE Boot error

Post#25 by fanthom » 29 Apr 2015, 07:53

great - thanks for sharing
Please add [Solved] to your thread title if the solution was found.

chkchaitu
Black ninja
Black ninja
Posts: 33
Joined: 06 Apr 2015, 10:32
Distribution: Porteus-Kiosk
Location: Bangalore, India

Re: PXE Boot error

Post#26 by chkchaitu » 14 Jun 2015, 20:15

Hi, any idea what is working mime setting in Apache to PXE boot Porteus Kiosk. Currently I run Apache and IIS on same server with different ports. Apache for web application and IIS to load Porteus Kiosk and load the web application as homepage in full screen mode.

Post Reply