lxde as root [SOLVED]

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
hitsware
Black ninja
Black ninja
Posts: 80
Joined: 12 Jan 2014, 19:13
Distribution: porteus
Location: sacramento, calif.

lxde as root [SOLVED]

Post#1 by hitsware » 27 Feb 2015, 18:52

Previously I downloaded (from the Wizard)
LXDE with the run as root option.
Now I have gone back to LXDE, but as guest.
(since it is no longer on the Wizard)
How can I modify to boot as root ?
Or redownload a boot to root version ?
Last edited by hitsware on 28 Feb 2015, 20:25, edited 1 time in total.

donald
Full of knowledge
Full of knowledge
Posts: 1123
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: lxde as root

Post#2 by donald » 27 Feb 2015, 22:27

Hi
at the boot screen,hit the TAB key and add login=root,..hit enter to boot.

If you want it to be permanent, add this cheatcode "login=root" to the APPEND line in /boot/syslinux/porteus.cfg

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: lxde as root

Post#3 by francois » 27 Feb 2015, 23:27

Hum! Very fast reply! :wink:
Voltaire: Le mieux est l'ennemi du bien.

hitsware
Black ninja
Black ninja
Posts: 80
Joined: 12 Jan 2014, 19:13
Distribution: porteus
Location: sacramento, calif.

Re: lxde as root

Post#4 by hitsware » 27 Feb 2015, 23:42

Vielen Dank :)

> at the boot screen,hit the TAB key and add login=root,..hit enter to boot.

That works ..........

> If you want it to be permanent, add this cheatcode "login=root" to the APPEND line in /boot/syslinux/porteus.cfg

That doesn't .........
Here's what I have:

APPEND hd0 1

How do I add ?

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: lxde as root

Post#5 by beny » 27 Feb 2015, 23:49

hi, not in this way,you have to open the porteus cfg and choosing the option you want ,add the login=root in the APPEND line.
APPEND initrd=initrd.xz changes=/porteus login=root
something like this

donald
Full of knowledge
Full of knowledge
Posts: 1123
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: lxde as root

Post#6 by donald » 28 Feb 2015, 00:01

@ hitsware
(as root) open /boot/syslinux/porteus.cfg (on your boot device)
scroll down to the first APPEND line,which should look similar to this:
APPEND initrd=initrd.xz changes=/porteus
now add login=root,so it will look like that:
APPEND initrd=initrd.xz changes=/porteus login=root
save it..reboot..should work

hitsware
Black ninja
Black ninja
Posts: 80
Joined: 12 Jan 2014, 19:13
Distribution: porteus
Location: sacramento, calif.

Re: lxde as root [ SOLVED ]

Post#7 by hitsware » 28 Feb 2015, 20:23

Got it !
Thanks ...... :D

Post Reply